?
Solved

Client cannot connect. SBA 2008 on SBS 2003 with SQL 05 WG

Posted on 2007-12-03
5
Medium Priority
?
572 Views
Last Modified: 2012-08-13
I have Small business Accounting 2008 installed on my SBS 2003 R2 server running SQL 2005 WG.
The DB exists in SQL and local accesses to it works (on the server) but no client can connect.
.sbc file points to correct DB and port 5356 is added. (1433,5356) on the server IP
SQL is set to allow remote connections.
I have setup Accounting Security Group and Accounting Database shared folder.
I have followed these instruction exactly: http://www.microsoft.com/downloads/details.aspx?FamilyID=1193e3f3-b626-4264-af3e-8c4f190caa69&DisplayLang=en   using the 2007 options
In SBA 2008 I have enabled remote access, though the "manage users" will not allow me to add users.

Error I am getting is: The company could not be opened. Please ensure the SQL server exists...

I can get to the DB location from the client \\servername\folder

What am I missing?
0
Comment
Question by:mellow52
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 74

Accepted Solution

by:
Jeffrey Kane - TechSoEasy earned 2000 total points
ID: 20400056
With notepad, open up the .sbc file that is being used to open the company.  Make sure that it's actually pointing to the correct servername and database.

Jeff
TechSoEasy
0
 

Author Comment

by:mellow52
ID: 20400208
This I have done. It does point to the correct server and database.
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 20400250
Oops!  I missed that in your original question.  sorry.

Anyhow... have you reviewed the troubleshooting steps in http://support.microsoft.com/kb/910012 ?

Jeff
TechSoEasy
0
 

Author Comment

by:mellow52
ID: 20401242
No you were right. The default file that SBA gives after you turn on multi user works fine for a workgroup but not domain.

this is what it gave:

database=dbasenamehere
server=MONKEY-servernamehere,5356

database=dbasenamehere
server=MONKEY-servernamehere\sqlinstancenamehere,5356

Hope thius helps so poor sole... to 10 hours of my life

Thanks for your help.
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 20402353
:-)  I like being right.  

Glad it worked out for you.  

Jeff
TechSoEasy
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

A Stored Procedure in Microsoft SQL Server is a powerful feature that it can be used to execute the Data Manipulation Language (DML) or Data Definition Language (DDL). Depending on business requirements, a single Stored Procedure can return differe…
In this blog post, we’ll look at how using thread_statistics can cause high memory usage.
Polish reports in Access so they look terrific. Take yourself to another level. Equations, Back Color, Alternate Back Color. Write easy VBA Code. Tighten space to use less pages. Launch report from a menu, considering criteria only when it is filled…
In this video, Percona Solution Engineer Rick Golba discuss how (and why) you implement high availability in a database environment. To discuss how Percona Consulting can help with your design and architecture needs for your database and infrastr…

801 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question