?
Solved

VPN Split Tunneling - Cisco ASA 5505

Posted on 2007-12-03
13
Medium Priority
?
12,509 Views
Last Modified: 2012-05-05
Hi,

I have a Cisco ASA 5505 which I have configured for VPN access and I can create a VPN connection fine.

The problem comes when I am VPN'ed in, I cannot access the internet/outlook emails locally - I need to be able to do this as we have a CRM system that has to be able to access a central server via the VPN connection.  At the same time the local MS Outlook needs to be able to communicate with a managed exchange server.

I have done a lot of research and have enabled split tunneling on the ASA.  I am using Cisco VPN Client software to establish the VPN connection (which I believe supports split tunelling).  

I do know this is possible but have little knowledge on networking?

I provide a print of my current configuration below:

ASA Version 7.2(3)
!
hostname ciscoasa
domain-name default.domain.invalid
enable password 8Ry2YjIyt7RRXU24 encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.1.1 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address dhcp setroute
!
interface Vlan3
 no forward interface Vlan1
 nameif dmz
 security-level 50
 no ip address
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd 2KFQnbNIdI.2KYOU encrypted
ftp mode passive
dns server-group DefaultDNS
 domain-name default.domain.invalid
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
access-list USAOFFICE_splitTunnelAcl_1 standard permit any
access-list DefaultRAGroup_splitTunnelAcl_1 standard permit any
access-list inside_nat0_outbound extended permit ip any 192.168.1.0 255.255.255.192
access-list test_splitTunnelAcl standard permit any
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
mtu dmz 1500
ip local pool NaplesPool 192.168.1.30-192.168.1.35 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-523.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto dynamic-map outside_dyn_map 20 set pfs
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
crypto dynamic-map outside_dyn_map 40 set pfs
crypto dynamic-map outside_dyn_map 40 set transform-set ESP-3DES-SHA
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 192.168.1.2-192.168.1.33 inside
dhcpd enable inside
!

!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
!
service-policy global_policy global
group-policy test internal
group-policy test attributes
 vpn-tunnel-protocol IPSec
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value test_splitTunnelAcl
group-policy DfltGrpPolicy attributes
 banner none
 wins-server none
 dns-server none
 dhcp-network-scope none
 vpn-access-hours none
 vpn-simultaneous-logins 3
 vpn-idle-timeout 30
 vpn-session-timeout none
 vpn-filter none
 vpn-tunnel-protocol IPSec l2tp-ipsec webvpn
 password-storage disable
 ip-comp disable
 re-xauth disable
 group-lock none
 pfs disable
 ipsec-udp disable
 ipsec-udp-port 10000
 split-tunnel-policy tunnelall
 split-tunnel-network-list none
 default-domain none
 split-dns none
 intercept-dhcp 255.255.255.255 disable
 secure-unit-authentication disable
 user-authentication disable
 user-authentication-idle-timeout 30
 ip-phone-bypass disable
 leap-bypass disable
 nem disable
 backup-servers keep-client-config
 msie-proxy server none
 msie-proxy method auto-detect
 msie-proxy except-list none
 msie-proxy local-bypass disable
 nac disable
 nac-sq-period 300
 nac-reval-period 36000
 nac-default-acl none
 address-pools none
 smartcard-removal-disconnect enable
 client-firewall none
 client-access-rule none
 webvpn
  functions url-entry
  html-content-filter none
  homepage none
  keep-alive-ignore 4
  http-comp gzip
  filter none
  url-list none
  customization value DfltCustomization
  port-forward none
  port-forward-name value Application Access
  sso-server none
  deny-message value Login was successful, but because certain criteria have not been met or due to some specific group policy, you do not have permission to use any of the VPN features. Contact your IT administrator for more information
  svc none
  svc keep-installer installed
  svc keepalive none
  svc rekey time none
  svc rekey method none
  svc dpd-interval client none
  svc dpd-interval gateway none
  svc compression deflate
group-policy NaplesOffice internal
group-policy NaplesOffice attributes
 vpn-tunnel-protocol IPSec
username douglas password ********** encrypted privilege 0
username douglas attributes
 vpn-group-policy NaplesOffice
tunnel-group NaplesOffice type ipsec-ra
tunnel-group NaplesOffice general-attributes
 address-pool NaplesPool
 default-group-policy NaplesOffice
tunnel-group NaplesOffice ipsec-attributes
 pre-shared-key *
tunnel-group test type ipsec-ra
tunnel-group test general-attributes
 address-pool NaplesPool
 default-group-policy test
tunnel-group test ipsec-attributes
 pre-shared-key *
prompt hostname context
Cryptochecksum:1555b93ac05fa659c8ed6563050df83a
: end
asdm image disk0:/asdm-523.bin
no asdm history enable
0
Comment
Question by:damsel__in__distress
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
  • 3
  • +1
13 Comments
 
LVL 28

Accepted Solution

by:
batry_boy earned 2000 total points
ID: 20399386
If you are using the ACL named "test_splitTunnelAcl" in your testing, then change the following line:

access-list test_splitTunnelAcl standard permit any

to this:

access-list test_splitTunnelAcl standard permit ip 192.168.1.0 255.255.255.0 any

This tells the firewall to only tunnel traffic destined for the 192.168.1.0/24 network for your remote VPN traffic.
0
 
LVL 18

Expert Comment

by:simsjrg
ID: 20399394
Have you checked off "Allow Local LAN Access" within the properties of the VPN Client?
0
 

Author Comment

by:damsel__in__distress
ID: 20399418
batry_boy - thanks for the comment.  

Yes I am using the ACL named "test....." but how do I actually change the line?  I have set up the tunnel groups etc.. using the wizards and my knowledge is very little beyond this.

Thank you.
0
Building an interactive eFuture classroom

Watch and learn how ATEN provided a total control system solution including seamless switching matrix switch, HDBaseT extenders, PDU, lighting control to build an interactive eFuture classroom.

 

Author Comment

by:damsel__in__distress
ID: 20399444
simsjrg - I have tried this checked and unchecked and it makes no difference.
0
 

Author Comment

by:damsel__in__distress
ID: 20399548
batry_boy:

I changed the line I think - it now reads in the print out "access-list test_splitTunnelAcl standard permit 192.168.1.0 255.255.255.0"

Is that correct?
0
 
LVL 28

Expert Comment

by:batry_boy
ID: 20399630
Not quite...do this:

no access-list test_splitTunnelAcl standard permit 192.168.1.0 255.255.255.0
access-list test_splitTunnelAcl extended permit ip 192.168.1.0 255.255.255.0 any

The first line deletes what you currently have and the second line puts in what should be there.  I mistakenly put "standard" instead of "extended" in my first post...sorry!
0
 

Author Closing Comment

by:damsel__in__distress
ID: 31412460
Fantastic - thank you so much.
0
 

Author Comment

by:damsel__in__distress
ID: 20399746
batry_boy:

The line i edited the first time actually worked and allows internet/mail access whilst vpn'ed in.

However to edit this I had to go to the Group Policy for that Tunnel Group and edit the ACL.  It doesn't seem that I have the ability to edit text file configuration and then reload it.  I do however have a command line interface, is this where I need to be putting the lines you are providing.

Now that its working, should I still change it to your last post?
0
 
LVL 28

Expert Comment

by:batry_boy
ID: 20399821
No, if it's working with the standard access list, then I would leave it in place.
0
 

Expert Comment

by:USWired
ID: 20721056
Thanks batry boy, your post helped me too!

IT guy in SJ
0
 

Expert Comment

by:USWired
ID: 20728711
FYI, we found that our ASA 5505 (running firmware 8.0(3)) did not create the correct split tunneling access-list entry when using the Remote User VPN Wizard, even though we specified the networks to be protected.  It created:

   access-list <VPN_Name>_splitTunnelAcl standard permit any

when the correct entry is:

   access-list <VPN_Name>_splitTunnelAcl standard permit <Local_Network> <Local_Mask>

Hope this helps.

IT Guy in SJ
0
 

Expert Comment

by:USWired
ID: 20765446
Never mind, upon re-doing the Remote User VPN Wizard it worked fine.  The neworks to be specified were not entered correctly the first time, and upon doing it correctly it worked.  Sorry about any confusion.

IT Guy in SJ
0
 
LVL 28

Expert Comment

by:batry_boy
ID: 20765558
Glad you got it working!  Wish I had a nickel for every time I've done that!
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article is a collection of issues that people face from time to time and possible solutions to those issues. I hope you enjoy reading it.
This article explains the fundamentals of industrial networking which ultimately is the backbone network which is providing communications for process devices like robots and other not so interesting stuff.
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…
There's a multitude of different network monitoring solutions out there, and you're probably wondering what makes NetCrunch so special. It's completely agentless, but does let you create an agent, if you desire. It offers powerful scalability …
Suggested Courses

765 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question