Solved

ASA 5510 - DMZ Server to access Internet

Posted on 2007-12-03
4
2,366 Views
Last Modified: 2008-08-26
I would to have the my web server in he DMZ to have access to the Internet.  I am hopinga pair of fresh eyes will help.  I had this working then I broke it!   Here's my config:

Result of the command: "sho run"

: Saved
:
ASA Version 7.2(2)
!
hostname ASARED
domain-name xxxxxxxxxx.local
enable password 2LVBvUZL09Lowe9I encrypted
names
!
interface Ethernet0/0
 nameif OUTSIDE
 security-level 0
 ip address xxx.xxx.166.194 255.255.255.224
!
interface Ethernet0/1
 nameif DMZ
 security-level 0
 ip address 10.10.10.1 255.255.255.0
!
interface Ethernet0/2
 nameif INSIDE
 security-level 100
 ip address 10.1.1.1 255.255.255.0
!
interface Ethernet0/3
 shutdown
 no nameif
 no security-level
 no ip address
!
interface Management0/0
 nameif management
 security-level 100
 ip address 192.168.1.1 255.255.255.0
 management-only
!
passwd 2KFQnbNIdI.2KYOU encrypted
ftp mode passive
dns server-group DefaultDNS
 domain-name xxxxxxxxxx.local
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
access-list DMZ_nat0_outbound extended permit ip 10.1.1.0 255.255.255.0 172.20.1.0 255.255.255.128
access-list DMZ_nat0_outbound extended permit ip 10.10.10.0 255.255.255.0 172.20.1.0 255.255.255.128
access-list DMZ_nat0_outbound extended permit ip 10.10.10.0 255.255.255.0 10.200.1.0 255.255.255.128
access-list OUTSIDE_access_in extended permit tcp any host xxx.xxx.166.201 eq www
access-list RBVPN_splitTunnelAcl standard permit 10.1.1.0 255.255.255.0
access-list RBVPN_splitTunnelAcl standard permit 10.10.10.0 255.255.255.0
access-list INSIDE_nat0_outbound extended permit ip 10.1.1.0 255.255.255.0 10.200.1.0 255.255.255.128
access-list DMZ_access_in extended permit tcp any host 10.10.10.3 eq www
pager lines 24
logging enable
logging asdm informational
mtu OUTSIDE 1500
mtu DMZ 1500
mtu INSIDE 1500
mtu management 1500
ip local pool VPNDMZIPS 10.200.1.2-10.200.1.100 mask 255.255.255.0
ip local pool VPN 172.20.1.2-172.20.1.100 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-522.bin
no asdm history enable
arp timeout 14400
nat-control
global (OUTSIDE) 200 interface
global (DMZ) 200 10.10.10.50-10.10.10.60 netmask 255.0.0.0
global (DMZ) 200 interface
nat (DMZ) 0 access-list DMZ_nat0_outbound
nat (DMZ) 200 10.10.10.0 255.255.255.0
nat (DMZ) 101 0.0.0.0 0.0.0.0
nat (INSIDE) 0 access-list INSIDE_nat0_outbound
nat (INSIDE) 200 10.1.1.0 255.255.255.0
static (DMZ,OUTSIDE) xxx.xxx.166.201 10.10.10.3 netmask 255.255.255.255
access-group DMZ_access_in in interface DMZ
route OUTSIDE 0.0.0.0 0.0.0.0 xxx.xxx.166.193 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
group-policy RBVPN internal
group-policy RBVPN attributes
 dns-server value xxx.xxx.64.66
 vpn-tunnel-protocol IPSec
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value RBVPN_splitTunnelAcl
username brajan password .NMoqi4CDrryIsFt encrypted
username rcohen password 1Kwgs9acVlptjHMK encrypted privilege 0
username rcohen attributes
 vpn-group-policy RBVPN
username mutso password No1lIUrfIv/ikmyk encrypted privilege 0
username lromano password naGfOPxoBxSQJkpx encrypted privilege 0
username lromano attributes
 vpn-group-policy RBVPN
http server enable
http 192.168.1.0 255.255.255.0 management
http 10.1.1.3 255.255.255.255 INSIDE
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto dynamic-map DMZ_dyn_map 20 set pfs
crypto dynamic-map DMZ_dyn_map 20 set transform-set ESP-3DES-SHA
crypto dynamic-map OUTSIDE_dyn_map 20 set pfs
crypto dynamic-map OUTSIDE_dyn_map 20 set transform-set ESP-3DES-SHA
crypto dynamic-map OUTSIDE_dyn_map 40 set pfs
crypto dynamic-map OUTSIDE_dyn_map 40 set transform-set ESP-3DES-SHA
crypto dynamic-map OUTSIDE_dyn_map 60 set pfs
crypto dynamic-map OUTSIDE_dyn_map 60 set transform-set ESP-3DES-SHA
crypto dynamic-map OUTSIDE_dyn_map 80 set pfs
crypto dynamic-map OUTSIDE_dyn_map 80 set transform-set ESP-3DES-SHA
crypto dynamic-map OUTSIDE_dyn_map 100 set pfs
crypto dynamic-map OUTSIDE_dyn_map 100 set transform-set ESP-3DES-SHA
crypto dynamic-map OUTSIDE_dyn_map 120 set pfs
crypto dynamic-map OUTSIDE_dyn_map 120 set transform-set ESP-3DES-SHA
crypto dynamic-map OUTSIDE_dyn_map 140 set pfs
crypto dynamic-map OUTSIDE_dyn_map 140 set transform-set ESP-3DES-SHA
crypto map DMZ_map 65535 ipsec-isakmp dynamic DMZ_dyn_map
crypto map DMZ_map interface DMZ
crypto map OUTSIDE_map 65535 ipsec-isakmp dynamic OUTSIDE_dyn_map
crypto map OUTSIDE_map interface OUTSIDE
crypto isakmp enable OUTSIDE
crypto isakmp enable DMZ
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto isakmp nat-traversal  20
tunnel-group RBVPN type ipsec-ra
tunnel-group RBVPN general-attributes
 address-pool VPNDMZIPS
 default-group-policy RBVPN
tunnel-group RBVPN ipsec-attributes
 pre-shared-key *
telnet timeout 15
ssh timeout 5
console timeout 0
dhcpd address 192.168.1.2-192.168.1.254 management
dhcpd dns xxx.xxx.64.66 xxx.xxx.65.66 interface management
!
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:8bebe4c4fd5b7029c370472efc2d245d
: end
0
Comment
Question by:mutso
  • 2
4 Comments
 
LVL 25

Expert Comment

by:Cyclops3590
Comment Utility
the first thing I saw was that your acl for the outside int isn't applied
0
 
LVL 79

Expert Comment

by:lrmoore
Comment Utility
no access-list DMZ_access_in extended permit tcp any host 10.10.10.3 eq www
access-list DMZ_access_in extended permit tcp host 10.10.10.3  any eq www
access-list DMZ_access_in extended permit udp host 10.10.10.3  any eq domain
0
 

Author Comment

by:mutso
Comment Utility
I am ok, with my INSIDE devices as they have internet.

lrmoore, I tried applying those statements but it does not seem to have an effect on the server 10.10.10.3, the web server in the DMZ.  I cannot access the web.  Nor can I ping anything. Yet,  I can access this webserver from the internet on its public IP address.

Here's what my config looks like now...
 
Result of the command: "show run"

: Saved
:
ASA Version 7.2(2)
!
hostname ASARED
domain-name xxxxx.local
enable password 2LVBvUZL09Lowe9I encrypted
names
!
interface Ethernet0/0
 nameif OUTSIDE
 security-level 0
 ip address xxx.xxx.166.194 255.255.255.224
!
interface Ethernet0/1
 nameif DMZ
 security-level 0
 ip address 10.10.10.1 255.255.255.0
!
interface Ethernet0/2
 nameif INSIDE
 security-level 100
 ip address 10.1.1.1 255.255.255.0
!
interface Ethernet0/3
 shutdown
 no nameif
 no security-level
 no ip address
!
interface Management0/0
 nameif management
 security-level 100
 ip address 192.168.1.1 255.255.255.0
 management-only
!
passwd 2KFQnbNIdI.2KYOU encrypted
ftp mode passive
dns server-group DefaultDNS
 domain-name xxxxx.local
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
access-list DMZ_access_in extended permit tcp host 10.10.10.3 any eq www
access-list DMZ_access_in extended permit udp host 10.10.10.3 any eq domain


access-list DMZ_nat0_outbound extended permit ip 10.1.1.0 255.255.255.0 172.20.1.0 255.255.255.128
access-list DMZ_nat0_outbound extended permit ip 10.10.10.0 255.255.255.0 172.20.1.0 255.255.255.128
access-list DMZ_nat0_outbound extended permit ip 10.10.10.0 255.255.255.0 10.200.1.0 255.255.255.128
access-list OUTSIDE_access_in extended permit tcp any host xxx.xxx.166.201 eq www
access-list RBVPN_splitTunnelAcl standard permit 10.1.1.0 255.255.255.0
access-list RBVPN_splitTunnelAcl standard permit 10.10.10.0 255.255.255.0
access-list INSIDE_nat0_outbound extended permit ip 10.1.1.0 255.255.255.0 10.200.1.0 255.255.255.128
pager lines 24
logging enable
logging asdm informational
mtu OUTSIDE 1500
mtu DMZ 1500
mtu INSIDE 1500
mtu management 1500
ip local pool VPNDMZIPS 10.200.1.2-10.200.1.100 mask 255.255.255.0
ip local pool VPN 172.20.1.2-172.20.1.100 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-522.bin
no asdm history enable
arp timeout 14400
nat-control
global (OUTSIDE) 200 interface
global (DMZ) 200 10.10.10.50-10.10.10.60 netmask 255.0.0.0
global (DMZ) 200 interface
nat (DMZ) 0 access-list DMZ_nat0_outbound
nat (DMZ) 200 10.10.10.0 255.255.255.0
nat (DMZ) 101 0.0.0.0 0.0.0.0
nat (INSIDE) 0 access-list INSIDE_nat0_outbound
nat (INSIDE) 200 10.1.1.0 255.255.255.0
static (DMZ,OUTSIDE) xxx.xxx.166.201 10.10.10.3 netmask 255.255.255.255
route OUTSIDE 0.0.0.0 0.0.0.0 xxx.xxx.166.193 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
group-policy RBVPN internal
group-policy RBVPN attributes
 dns-server value xxx.xxx.64.66
 vpn-tunnel-protocol IPSec
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value RBVPN_splitTunnelAcl
username brajan password .NMoqi4CDrryIsFt encrypted
username rcohen password 1Kwgs9acVlptjHMK encrypted privilege 0
username rcohen attributes
 vpn-group-policy RBVPN
username mutso password No1lIUrfIv/ikmyk encrypted privilege 0
username lromano password naGfOPxoBxSQJkpx encrypted privilege 0
username lromano attributes
 vpn-group-policy RBVPN
http server enable
http 192.168.1.0 255.255.255.0 management
http 10.1.1.3 255.255.255.255 INSIDE
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto dynamic-map DMZ_dyn_map 20 set pfs
crypto dynamic-map DMZ_dyn_map 20 set transform-set ESP-3DES-SHA
crypto dynamic-map OUTSIDE_dyn_map 20 set pfs
crypto dynamic-map OUTSIDE_dyn_map 20 set transform-set ESP-3DES-SHA
crypto dynamic-map OUTSIDE_dyn_map 40 set pfs
crypto dynamic-map OUTSIDE_dyn_map 40 set transform-set ESP-3DES-SHA
crypto dynamic-map OUTSIDE_dyn_map 60 set pfs
crypto dynamic-map OUTSIDE_dyn_map 60 set transform-set ESP-3DES-SHA
crypto dynamic-map OUTSIDE_dyn_map 80 set pfs
crypto dynamic-map OUTSIDE_dyn_map 80 set transform-set ESP-3DES-SHA
crypto dynamic-map OUTSIDE_dyn_map 100 set pfs
crypto dynamic-map OUTSIDE_dyn_map 100 set transform-set ESP-3DES-SHA
crypto dynamic-map OUTSIDE_dyn_map 120 set pfs
crypto dynamic-map OUTSIDE_dyn_map 120 set transform-set ESP-3DES-SHA
crypto dynamic-map OUTSIDE_dyn_map 140 set pfs
crypto dynamic-map OUTSIDE_dyn_map 140 set transform-set ESP-3DES-SHA
crypto map DMZ_map 65535 ipsec-isakmp dynamic DMZ_dyn_map
crypto map DMZ_map interface DMZ
crypto map OUTSIDE_map 65535 ipsec-isakmp dynamic OUTSIDE_dyn_map
crypto map OUTSIDE_map interface OUTSIDE
crypto isakmp enable OUTSIDE
crypto isakmp enable DMZ
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto isakmp nat-traversal  20
tunnel-group RBVPN type ipsec-ra
tunnel-group RBVPN general-attributes
 address-pool VPNDMZIPS
 default-group-policy RBVPN
tunnel-group RBVPN ipsec-attributes
 pre-shared-key *
telnet timeout 15
ssh timeout 5
console timeout 0
dhcpd address 192.168.1.2-192.168.1.254 management
dhcpd dns xxx.xxx.64.66 xxx.xxx.65.66 interface management
!
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:8bebe4c4fd5b7029c370472efc2d245d
: end

 
0
 
LVL 25

Accepted Solution

by:
Cyclops3590 earned 500 total points
Comment Utility
no static (DMZ,OUTSIDE) xxx.xxx.166.201 10.10.10.3 netmask 255.255.255.255
static (DMZ,OUTSIDE) xxx.xxx.166.201 10.10.10.3 dns

run that it'll do dns doctoring for your packets
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
ASA 5506-X 7 57
Configuring VLan for Internet Only Traffic 19 57
cisco switch stacking 6 29
Cisco NBAR 6 13
When I upgraded my ASA 8.2 to 8.3, I realized that my nonat statement was failing!   The log showed the following error:     %ASA-5-305013: Asymmetric NAT rules matched for forward and reverse flows It was caused by the config upgrade, because t…
Have you experienced traffic destined through a Cisco ASA firewall disappears and you do not know if the traffic stops in the firewall or somewhere else? The solution is the capture feature. This feature was released in 6.2(1) and works in all firew…
Access reports are powerful and flexible. Learn how to create a query and then a grouped report using the wizard. Modify the report design after the wizard is done to make it look better. There will be another video to explain how to put the final p…
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

14 Experts available now in Live!

Get 1:1 Help Now