Solved

Sql Reporting with SqlExpress

Posted on 2007-12-03
8
1,091 Views
Last Modified: 2008-02-01
This error is driving me nuts:  

An error has occurred during report processing.
Cannot create a connection to data source 'ProcessTrakker'.
The feature: "The edition of Reporting Services that you are using requires that you use local SQL Server relational databases for report data sources and the report server database." is not supported in this edition of Reporting Services.

My database is local.... My datasource is:  Data Source = localhost\SqlExpress; Initial Catalog = ProcessTrakker;  

I've tried windows authentication.... I've tried sql... I've tried to change the service to local system which just ended up with me having to delete everything, and reinstall..  I've tried using shared data sources and local report data sources...

This kinda error doesn't happen when I can use the deploy options in visual studio, but i can't do this in this case because the place won't let me do an ftp connection, pinholes, etc... basically anything... I have to email myself the reports, and then upload them, and then create a new source, and it just won't work...

I also tried to get rid of the sqlexpress, and use a default instance, and i couldn't get it to work.  I know that it should be allowed to do this, and I've got it to work on other systems after some troubles... but i don't know what makes it happy...

tony
0
Comment
Question by:picsnet
  • 4
  • 3
8 Comments
 
LVL 9

Expert Comment

by:the_b1ackfox
ID: 20401354
You may have got this to work in cases where sqlserver express and another version of SQL 2005 installed to the same machine.  But MS ripped out the reporting in the express edition to incent people to used one of the paid versions.  When you have the multiple version installed on the same machine, you will find both versions running as well as multiple instances.
0
 
LVL 18

Expert Comment

by:PFrog
ID: 20401766
SSRS is now included with the exress edition - but you have to download a specific version of it (SQL Server 2005 Express Edition with Advance Services - http://msdn2.microsoft.com/en-us/library/ms365166.aspx)

Are you using a shared data source or one embedded in the report? Either way, have you checked that the connection string is set after you have deployed? Deploying doesn't overwrite the old datasource by default.

Try deleting the report from the server and then re-deploying it, and then configure the datasource manually. Also check that you haven't got any other data sources being used in the report.
0
 
LVL 1

Author Comment

by:picsnet
ID: 20417285
yeah i'm using the sql express edition with advanced services and i spent hours changing all the datasources on the reporting server in every configuration i could possibly think of...
0
 
LVL 18

Expert Comment

by:PFrog
ID: 20418327
You mentioned that you don't get the problem when you deploy from Visual Studio, this means that there probably isn't a problem with SSRS, just a process issue.

After you upload the report manually, can you confirm that you are then manually setting each and every datasource for the report to a pre-created (and tested) shared data source?
0
Comprehensive Backup Solutions for Microsoft

Acronis protects the complete Microsoft technology stack: Windows Server, Windows PC, laptop and Surface data; Microsoft business applications; Microsoft Hyper-V; Azure VMs; Microsoft Windows Server 2016; Microsoft Exchange 2016 and SQL Server 2016.

 
LVL 1

Author Comment

by:picsnet
ID: 20421177
i was just changing it for one report and testing... i think i might have did all the reports for the first time, and yeah i know the datasource should work...
0
 
LVL 1

Author Comment

by:picsnet
ID: 20421189
a lot of times it seemed like i was changing it, but it just wasn't getting the changes... like when i'd change it to just a local data source instead of a shared... it'd still fuss about the shared data source.  a lot of times at the end i was only uploading one report to test though so the other reports weren't supposed to be in the system.  
0
 
LVL 18

Accepted Solution

by:
PFrog earned 500 total points
ID: 20427003
If you can't edt the datasource manually, then I'd say that SQL has got itself into a bit of a state - have you tried uninstalling SQL completely then reinstalling?
0
 
LVL 1

Author Comment

by:picsnet
ID: 20432371
it was just installed the day i was playing with it
0

Featured Post

How to improve team productivity

Quip adds documents, spreadsheets, and tasklists to your Slack experience
- Elevate ideas to Quip docs
- Share Quip docs in Slack
- Get notified of changes to your docs
- Available on iOS/Android/Desktop/Web
- Online/Offline

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
Select2 jquery help 9 46
Link SQL table to Webpage 9 39
How to find duplicates in SQL Server 3 23
Calculating Business Hours 19 65
How to increase the row limit in Jasper Server.
International Data Corporation (IDC) prognosticates that before the current the year gets over disbursing on IT framework products to be sent in cloud environs will be $37.1B.
Viewers will learn how the fundamental information of how to create a table.
Viewers will learn how to use the UPDATE and DELETE statements to change or remove existing data from their tables. Make a table: Update a specific column given a specific row using the UPDATE statement: Remove a set of values using the DELETE s…

759 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now