• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1142
  • Last Modified:

Sql Reporting with SqlExpress

This error is driving me nuts:  

An error has occurred during report processing.
Cannot create a connection to data source 'ProcessTrakker'.
The feature: "The edition of Reporting Services that you are using requires that you use local SQL Server relational databases for report data sources and the report server database." is not supported in this edition of Reporting Services.

My database is local.... My datasource is:  Data Source = localhost\SqlExpress; Initial Catalog = ProcessTrakker;  

I've tried windows authentication.... I've tried sql... I've tried to change the service to local system which just ended up with me having to delete everything, and reinstall..  I've tried using shared data sources and local report data sources...

This kinda error doesn't happen when I can use the deploy options in visual studio, but i can't do this in this case because the place won't let me do an ftp connection, pinholes, etc... basically anything... I have to email myself the reports, and then upload them, and then create a new source, and it just won't work...

I also tried to get rid of the sqlexpress, and use a default instance, and i couldn't get it to work.  I know that it should be allowed to do this, and I've got it to work on other systems after some troubles... but i don't know what makes it happy...

tony
0
picsnet
Asked:
picsnet
  • 4
  • 3
1 Solution
 
the_b1ackfoxCIOCommented:
You may have got this to work in cases where sqlserver express and another version of SQL 2005 installed to the same machine.  But MS ripped out the reporting in the express edition to incent people to used one of the paid versions.  When you have the multiple version installed on the same machine, you will find both versions running as well as multiple instances.
0
 
PFrogCommented:
SSRS is now included with the exress edition - but you have to download a specific version of it (SQL Server 2005 Express Edition with Advance Services - http://msdn2.microsoft.com/en-us/library/ms365166.aspx)

Are you using a shared data source or one embedded in the report? Either way, have you checked that the connection string is set after you have deployed? Deploying doesn't overwrite the old datasource by default.

Try deleting the report from the server and then re-deploying it, and then configure the datasource manually. Also check that you haven't got any other data sources being used in the report.
0
 
picsnetAuthor Commented:
yeah i'm using the sql express edition with advanced services and i spent hours changing all the datasources on the reporting server in every configuration i could possibly think of...
0
Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
PFrogCommented:
You mentioned that you don't get the problem when you deploy from Visual Studio, this means that there probably isn't a problem with SSRS, just a process issue.

After you upload the report manually, can you confirm that you are then manually setting each and every datasource for the report to a pre-created (and tested) shared data source?
0
 
picsnetAuthor Commented:
i was just changing it for one report and testing... i think i might have did all the reports for the first time, and yeah i know the datasource should work...
0
 
picsnetAuthor Commented:
a lot of times it seemed like i was changing it, but it just wasn't getting the changes... like when i'd change it to just a local data source instead of a shared... it'd still fuss about the shared data source.  a lot of times at the end i was only uploading one report to test though so the other reports weren't supposed to be in the system.  
0
 
PFrogCommented:
If you can't edt the datasource manually, then I'd say that SQL has got itself into a bit of a state - have you tried uninstalling SQL completely then reinstalling?
0
 
picsnetAuthor Commented:
it was just installed the day i was playing with it
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now