Solved

Cant connect to sqlplus on oracle 10g2

Posted on 2007-12-04
7
1,083 Views
Last Modified: 2013-12-18
Hello,

I have installed oracle 10g2 on Linux Red Hat enterprise 5 but when i try to get to sqlplus i get the following error:

bash: sqlplus: command not found

It looks as if sqlplus aint installed but i did a custom installation and i chose it from the list. For any further info concerning the installation ask me and i ll post it.

Thanx in advance for your help.
0
Comment
Question by:stavrama
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 2
7 Comments
 
LVL 143

Assisted Solution

by:Guy Hengel [angelIII / a3]
Guy Hengel [angelIII / a3] earned 50 total points
ID: 20401573
check out, is the oracle folder where sqlplus is in, in the path?

try to go to the folder of ORACLE_HOME, under the bin folder you should find it.
0
 
LVL 27

Expert Comment

by:sujith80
ID: 20401615
Have you set your environment?
Try $ORACLE_HOME/bin/sqlplus
0
 
LVL 2

Author Comment

by:stavrama
ID: 20401663
There is no such file or directory...
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 27

Expert Comment

by:sujith80
ID: 20401686
Can you change to $ORACLE_HOME/bin?
0
 
LVL 2

Author Comment

by:stavrama
ID: 20401788
Sorry but i dont understand what you are asking.  Under the bin folder i dont have any orcale_home folder. The only sqlplus folder i have is on the directory in which orcale10g2 was installed. The directory is the following:

u01/app/oracle/oracle/product/10.2.0/db_1

Furthermore i have followed the instructions from meta link about the things i need to do before the installation of 10g2 and one of those, was to set in the home/oracle/.bash.profile the follwoing lines:

export ORACLE_BASE=/u01/app/oracle
export ORACLE_SID=orcl
unset  ORACLE_HOME

Do i need to delete the last line and add there the oracle_home directory? If yes what this will be? The place where sqlplus folder is?
0
 
LVL 27

Accepted Solution

by:
sujith80 earned 75 total points
ID: 20401951
You should not unser your ORACLE_HOME in bash.profile.

ORACLE_HOME Should point to: /u01/app/oracle/oracle/product/10.2.0/db_1

Include this in bash profile :
export ORACLE_HOME=/u01/app/oracle/oracle/product/10.2.0/db_1

Login again OR run bash profile again and try:
$ORACLE_HOME/bin/sqlplus
0
 
LVL 27

Expert Comment

by:sujith80
ID: 20402012
The first line should read as:
You should not unset your ORACLE_HOME in bash.profile

And as instructed in the first post from angelIII:you should include $ORACLE_HOME/bin in your PATH, to have the executable sqlplus in your bin path.

0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

From implementing a password expiration date, to datatype conversions and file export options, these are some useful settings I've found in Jasper Server.
When it comes to protecting Oracle Database servers and systems, there are a ton of myths out there. Here are the most common.
Via a live example show how to connect to RMAN, make basic configuration settings changes and then take a backup of a demo database
This video shows how to copy a database user from one database to another user DBMS_METADATA.  It also shows how to copy a user's permissions and discusses password hash differences between Oracle 10g and 11g.

726 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question