Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 886
  • Last Modified:

Character set has been locked to Latin1 Latin1_swedish_ci ?

Hello all,

I have created several db with character set of utf8 for multilanguage
support,but from yesterday that i creat a new db ,i set character set
in Mysql Administrator to utf8 and utf8_general_ci but when i want
type persian i receive error 1366 ,when i see table options in Mysql

Administrator it is ok and is on utf8, but i try change the "NOT NULL"
and that in the box of Execute there is this message:

ALTER TABLE `testi`.`tbtest` MODIFY COLUMN `title` VARCHAR(45) CHARACTER SET

latin1 COLLATE latin1_swedish_ci;

so it seems that character set is locked to above (SWedish),is there any
solution?
Thanks
0
MOSTAGHASSI
Asked:
MOSTAGHASSI
  • 2
1 Solution
 
michofreihaCommented:

Well query browser has issues when concatenating queries together with static strings because of weird bug I am still working with the devs on, the workaround is to look at your static portions of the query and run a convert on them to make them UTF8 explicitly.

Please check the following:
http://dev.mysql.com/doc/refman/5.0/en/charset-server.html
http://dev.mysql.com/doc/refman/5.0/en/charset.html
0
 
MOSTAGHASSIAuthor Commented:
Thanks for your comment.
I read the articles and for creating new db i used comand line as:
CREATE DATABASE db_name CHARACTER SET utf8 COLLATE utf8_general_ci;
and it is good,now can you guide that how can apply this to an existance db?


0
 
michofreihaCommented:
0

Featured Post

Configuration Guide and Best Practices

Read the guide to learn how to orchestrate Data ONTAP, create application-consistent backups and enable fast recovery from NetApp storage snapshots. Version 9.5 also contains performance and scalability enhancements to meet the needs of the largest enterprise environments.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now