Cygwin install failing trying to uninstall bash

Hello,

I am updating an existing install of cygwin on my box.  I have the latest setup.exe from cygwin.com.

The only package getting updated is bash (3.2.25-16 to 3.2.25-17) -- every other package installed is up-to-date.

However, when trying to update bash I get the following error (Vista, naturally) during the bash uninstall:

  setup.exe has stopped working...
  APPCRASH
  setup.exe_unknown
  ...

How can I fix this problem?  Can I manually install the latest version of bash outside of the main installer?  Is there a log file that will give me details about what exactly the problem is?

_RD
rdefuriaAsked:
Who is Participating?
 
rdefuriaConnect With a Mentor Author Commented:
Found a solution online:

http://www.mail-archive.com/cygwin@cygwin.com/msg83804.html

"...the file /etc/setup /bash.lst.gz was corrupted..."
0
 
Vee_ModCommented:
Closed, 500 points refunded.
Vee_Mod
Community Support Moderator
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.