Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
Solved

Remote desktop stopped working

Posted on 2007-12-04
32
2,890 Views
Last Modified: 2012-06-27
Hey guys,

For some reason my remote desktop to my primary server (server1) is no longer working. When i click on it it states connecting to serverx:8080 than an error pops up that says"The remote desktop connection has times out. Please try connecting to the remote computer again.". Any suggestions to why this stopped all of a sudden. It just happend last week when I rebooted the server for maintenance.
0
Comment
Question by:sbodnar
  • 13
  • 10
  • 5
  • +1
32 Comments
 
LVL 8

Expert Comment

by:wfcraven12
ID: 20402891
i've seen this happen a couple of occasions if the Windows Firewall is running.  I would disable the windows firewall & connect & then re-enable the firewall (if necessary).  I don't use the Windows firewall though.
0
 
LVL 66

Expert Comment

by:johnb6767
ID: 20403336
Can you ping it?

Did you change the port that RDP listens on to 8080 on serverx?

0
 
LVL 66

Expert Comment

by:johnb6767
ID: 20403341
Try telnetting to it to make sure the port is listening....
0
Netscaler Common Configuration How To guides

If you use NetScaler you will want to see these guides. The NetScaler How To Guides show administrators how to get NetScaler up and configured by providing instructions for common scenarios and some not so common ones.

 

Expert Comment

by:qwert6
ID: 20403566
You haven't explained why/how you're using port 8080.
To be sure the server responds, try if this opens a connection from the server LAN: telnet server1 3389.
If you reconfigured the incoming RDP port in the past, check the effective settings in the registry at
HKLM\System\CurrentControlSet\Control\TerminalServer\WinStations\RDP-Tcp\PortNumber
If you employ port forwarding (also called virtual server on many routers), check those settings.
For some reason, also the remote connection might be turned off at Control panel => System => Remote.
Finally, if something failed during runtime, the only way to reinitiate RDP is to reboot the server.
0
 

Author Comment

by:sbodnar
ID: 20403856
qwert6:

I was not the one to set this up with port 8080 so I have no idea how the consultant did it or even how to change it. I am totally confused. Everything was working fine till last week. I made no changes to the system all I did was reboot the server.
0
 
LVL 8

Expert Comment

by:wfcraven12
ID: 20403902
can you confirm the remote desktop services are running on the server?
what anti-virus are you running?  we tested out symantec endpoint protection a few weeks ago & it was a mess.  ONE of the things SEP screwed up was remote desktop.  
0
 

Expert Comment

by:qwert6
ID: 20404011
If you're not on-site, you will have to physically access the server anyway. Try one of the steps above. RDP is running on port tcp/3389 by default. The port 8080 almost always indicate an internal (strange...) proxy server port. But if it worked before, 8080 must be set on the machine itself as a terminal services listener, or it is translated/forwarded (8080=>server1:3389) on the destination hop of "tracert <destination>".
0
 

Author Comment

by:sbodnar
ID: 20404080
qwert6:
I am on site currently. How do I check to see where 8080 is setup?

wfcraven12:
what service is RDP on the services menu? I am running TrendMicro.
0
 

Expert Comment

by:qwert6
ID: 20404383
You can see the port number in regedit:
HKLM\System\CurrentControlSet\Control\TerminalServer\WinStations\RDP-Tcp\PortNumber
From another computer try connecting by TS client to server1:<port-found-in-registry>.
If this works, the problem is in the gateway router. It might have a web-interface, so access it from the browser, however it will be password protected (check around if it's written) and also the port might be changed from 80 to another one.
0
 
LVL 66

Expert Comment

by:johnb6767
ID: 20404386
Using Telnet to Test Port 3389 Functionality
http://support.microsoft.com/kb/187628

Follow the directions, but change to port 8080.

If this fails, maybe you need to recreate the RDP listener....

From the following KB article. Disregard the part about the error though....

Event ID 52 When You Start Terminal Services
http://support.microsoft.com/?kbid=258021

" The RDP-tcp connection may have to be reset. To reset the RDP-tcp connection in the Terminal Services Configuration management console, right-click the connection, and then click Disable. Confirm the changes when you are prompted to do so. Repeat the process, and then click Enable.
" The RDP-tcp connection may be corrupted. Re-create the RDP-tcp connection in the Terminal Services Configuration management console. To re-create the connection, delete the connection, and then re-create it.
 " An evaluation license may have been used to configure Terminal Services Licensing. Verify that a retail license has been issued and correctly installed.
" The Network Adapter tab in RDP-tcp properties may be set to Maximum Connections: 0. This causes the "The Terminal server has ended the connection" error message.
" The Terminal device driver files may be corrupted or missing. Verify the existence of the Termdd.sys and Rdpwd.sys files in the %SystemRoot%\Sytem32\Drivers folder. Verify that the Rdpdd.dll and Rdpwsx.dll files are located in the %SystemRoot%\Sytem32 folder.
" The TermDD service may be disabled. Open the registry and locate the following key:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TermDD
Check the data setting for the Start value, which should be 2. If the value is set to 4, the driver has been disabled. Set the value to 2, and then restart the server computer.  



0
 

Author Comment

by:sbodnar
ID: 20404912
i can connect via telnet
0
 
LVL 66

Expert Comment

by:johnb6767
ID: 20404959
On what port?
0
 

Author Comment

by:sbodnar
ID: 20404976
8080
0
 

Author Comment

by:sbodnar
ID: 20404996
and 80
0
 
LVL 66

Expert Comment

by:johnb6767
ID: 20404998
start>run>mstsc /v:server1:8080

Still fails?
0
 

Author Comment

by:sbodnar
ID: 20405027
still failed
0
 
LVL 66

Expert Comment

by:johnb6767
ID: 20405042
I would recreate the RDP-TCP listener, in my previous post.....
0
 
LVL 8

Expert Comment

by:wfcraven12
ID: 20405052
is the windows firewall running?  i know it's a silly question but still....
0
 

Expert Comment

by:qwert6
ID: 20405055
A)
If "telnet server1 8080" connects, then an RDP session to server1:8080 should also work from the LAN. There's something wrong with your internet/other connectivity or firewall configuration (port redirection).

B)
If "telnet server1 3389" connects, then and RDP session to server1 (you can omit the port number) should also work from the LAN. There's something with your router setup - if you don't have credentials to the management, try to restart it considering the impact.

C)
If only telnet works, but an RDP session still could not be established on the opened port from the LAN, then (at least) a server reboot will be needed.
0
 

Author Comment

by:sbodnar
ID: 20405103
wfcraven12: the firewall is not running.

qwert6:
a.  the telnet session did work and that is why I am stumped as to why the RDP will not connect.
b. telnet server1 3389 does not work at all. The only extensions that work are 80 and 8080.
c. I rebooted the server on friday of last week hoping it would resolve the issue, however it did not.
0
 

Expert Comment

by:qwert6
ID: 20405190
I'm still talking about connecting the server from the local network.
80 only proves there is a website running on it.
Please log on to the server, run regedit and have a look on this value:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\TerminalServer\WinStations\RDP-Tcp\PortNumber
Is it really 8080? You might also export the whole RDP-Tcp key and paste the *.reg content here.
0
 
LVL 66

Expert Comment

by:johnb6767
ID: 20405194
reiterate....

 The RDP-tcp connection may have to be reset. To reset the RDP-tcp connection in the Terminal Services Configuration management console, right-click the connection, and then click Disable. Confirm the changes when you are prompted to do so. Repeat the process, and then click Enable.
" The RDP-tcp connection may be corrupted. Re-create the RDP-tcp connection in the Terminal Services Configuration management console. To re-create the connection, delete the connection, and then re-create it.
0
 
LVL 66

Expert Comment

by:johnb6767
ID: 20405298
FYI, I am not talking about WAN~~>server, I am talking about LAN~~>server

Just so were all on the same page...

:^)
0
 

Author Comment

by:sbodnar
ID: 20405336
qwert: it is indeed 8080

johnb6767: what do you mean the WAN server? I am on the primary server with the issue
0
 

Author Comment

by:sbodnar
ID: 20405619
could it be a firewall issue?
0
 
LVL 66

Expert Comment

by:johnb6767
ID: 20405671
Just clarifying that I am not talking about coming in RDP from the WAN to the server, but from the LAN into the server. I am not taking into account any External gateway firewalls.....

0
 

Author Comment

by:sbodnar
ID: 20405837
Ok, correct I am trying from the LAN to the server.
0
 

Author Comment

by:sbodnar
ID: 20406308
" The RDP-tcp connection may be corrupted. Re-create the RDP-tcp connection in the Terminal Services Configuration management console. To re-create the connection, delete the connection, and then re-create it.

I DID THIS AND STILL IT IS NOT CONNECTING.
0
 
LVL 66

Accepted Solution

by:
johnb6767 earned 100 total points
ID: 20406467
Ok, didnt see a repsonse to this one earlier...

Might try changing the port back to 3389, in the registry location above....
0
 

Author Comment

by:sbodnar
ID: 20406515
Im actually afraid to do it because like I said earlier I did not set this up and I am not sure how the consultant set it up before that you are required to type in server1:8080 to connect. Therefore I am not sure how to change it too 3389 instead. Any assistance is appreciated...
0
 
LVL 8

Assisted Solution

by:wfcraven12
wfcraven12 earned 25 total points
ID: 20406531
Here's how to change the listening port.

http://support.microsoft.com/kb/306759

I would definitely try that & then use the plain ol' remote desktop connection app to connect to the IP address (not server name) to see what happens.
0
 

Author Comment

by:sbodnar
ID: 20406627
Changing the port did it!!

Thanks guys!
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Setting up a Microsoft WSUS update system is free relatively speaking if you have hard disk space and processor capacity.   However, WSUS can be a blessing and a curse. For example, there is nothing worse than approving updates and they just have…
Issue: Unstable cursor in Windows XP and Windows runs extremely slow in that any click will bring up the Hour glass (sometimes for several seconds before giving you what you want) . Troubleshooting Process and the FINAL FIX: This issue see…
Two types of users will appreciate AOMEI Backupper Pro: 1 - Those with PCIe drives (and haven't found cloning software that works on them). 2 - Those who want a fast clone of their boot drive (no re-boots needed) and it can clone your drive wh…
Email security requires an ever evolving service that stays up to date with counter-evolving threats. The Email Laundry perform Research and Development to ensure their email security service evolves faster than cyber criminals. We apply our Threat…

792 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question