?
Solved

worspress error in IIS

Posted on 2007-12-04
8
Medium Priority
?
574 Views
Last Modified: 2013-12-13
I have followed instructions fro iis.net for setting up wordpress with PHP on IIS but I'm getting errors. Here is the one that is holding me up now:
The page cannot be displayed

You have attempted to execute a CGI, ISAPI, or other executable program from a directory that does not allow programs to be executed.
--------------------------------------------------------------------------------

Please try the following:

Contact the Web site administrator if you believe this directory should allow execute access.
HTTP Error 403.1 - Forbidden: Execute access is denied.
Internet Information Services (IIS)

In the vsite under default sites for the wordpress site on the home directory tab I have scripts and executables for excute permissions and on the local path I have checked script source access, read, log visits, and index this resource. I'm also getting prompted to username and password for this site as well and I don't have integrated windown auth checked and anon access enabled with the local iusr account selected............................. any ideas?
0
Comment
Question by:cebrooks03
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
8 Comments
 
LVL 3

Expert Comment

by:yjwong
ID: 20404462
Are you using PHP-CGI? If you are using PHP-CGI, you need to allow execute permissions on the interpreter (called php-cgi.exe on PHP 5, and php.exe on PHP 4). Also propagate the execute permissions of the PHP directory to the child directories.
0
 
LVL 1

Author Comment

by:cebrooks03
ID: 20406103
Yes, I'm using PHP-CGI. Can you elaborate a little on how to do this: "you need to allow execute permissions on the interpreter"
0
 
LVL 3

Accepted Solution

by:
yjwong earned 2000 total points
ID: 20408230
You need right click your PHP directory, hit the "Security" tab, and see whether a user named "IUSR_MachineName" is in the last. If it isn't, then you have to click on "Add", type in "IUSR_MachineName", and check all the boxes (read, write, execute, ... ).

* MachineName is the name of your computer.
0
Are You Using the Best Web Development Editor?

The worlds of web hosting and web development are constantly evolving. Every year we see design trends change, coding standards adapt and new frameworks/CMS created. With such a quick pace of change it’s easy to get lost trying to keep up.

See if your editor made the list.

 
LVL 1

Author Comment

by:cebrooks03
ID: 20408695
ok, that is what I have done. I still get prompted for username/password and if I enter my admin un/pw I get the same error. The iusr_computer account has the permissions as you have specified on both the php directory and the wordpress directory. I know something has a lock on this but for the life of me I can't find it.
0
 
LVL 34

Expert Comment

by:Dave_Dietz
ID: 20409115
Open the IIS manager.

Open the properties of the directory where you are receiving the error.

Go to the Virtual Directory tab and you should see a drop-down menu with options of "None", "Scripts only" and "Scripts and executables".

Select the "Scripts and executables" option.

This should fix it.

Dave Dietz
0
 
LVL 1

Author Comment

by:cebrooks03
ID: 20410368
That is already set to Scripts and executables.I did try checking "script source access" but I'm still getting ptompted for a username and password when I try to view the page.
0
 
LVL 3

Expert Comment

by:yjwong
ID: 20410678
Microsoft's MSDN might have more information on how IIS authentication works: http://msdn2.microsoft.com/en-us/library/ms955939.aspx

I might have run out of ideas, but maybe you can check your log files to see why IIS is refusing to use the Anonymous Internet User to authenticate.
0
 
LVL 1

Author Comment

by:cebrooks03
ID: 20482592
ok, I got the auth issue worked out. Turns out I was directing my browser to the wrong file..... woops. Thanks for all the help. I'm having another issue with php/mysql but I will start another thread for that.
0

Featured Post

Learn how to optimize MySQL for your business need

With the increasing importance of apps & networks in both business & personal interconnections, perfor. has become one of the key metrics of successful communication. This ebook is a hands-on business-case-driven guide to understanding MySQL query parameter tuning & database perf

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Since pre-biblical times, humans have sought ways to keep secrets, and share the secrets selectively.  This article explores the ways PHP can be used to hide and encrypt information.
Preparing an email is something we should all take special care with – especially when the email is for somebody you may not know very well. The pressures of everyday working life stacked with a hectic office environment can make this a real challen…
Explain concepts important to validation of email addresses with regular expressions. Applies to most languages/tools that uses regular expressions. Consider email address RFCs: Look at HTML5 form input element (with type=email) regex pattern: T…
This tutorial will teach you the core code needed to finalize the addition of a watermark to your image. The viewer will use a small PHP class to learn and create a watermark.
Suggested Courses

777 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question