Solved

Windows XP keeps logging off!

Posted on 2007-12-04
15
2,974 Views
Last Modified: 2013-12-04
When I try to entre the computer, inserting password on the Welcome Screen, it enters and then it keeps logging off, just seeing the background screen for some seconds.
I have installed Norton and might deleted some adware that was asked in the virus search!
I don't have windows CD as this is a pre-installed version in the Sony Vaio.
I have tried to start as administrator, but also keeps logging off!
I have tried to start on every mode, from last known configuration to safe mode  through safe mode with everything and without them!!!
Nothing!!
I came accross some explanation on the internet to change the registry, but I can't even log to anything!
Is there any program I can download that I could boot from a CD and then fix teh problem?

Thank you very much.

Kind regards
0
Comment
Question by:filipenascimento
  • 7
  • 4
  • 2
  • +2
15 Comments
 
LVL 17

Expert Comment

by:Shanmuga Sundaram
ID: 20405351
Though there are many suggesitions to come out of this, nothing helps. I say this to you because, I tried to resolve the same issue that i faced. Better try backing up your data and do a fresh install. or else lets hope better luck to you to solve this issue.
0
 

Author Comment

by:filipenascimento
ID: 20405610
That hit me in the eye!
I can't have a solution? It is very difficult for me to erase all data!
Thank you  shasunder!
0
 
LVL 4

Expert Comment

by:_Forgotten_
ID: 20405917
Sounds like you need to run a system restore.  If you can get to the recovery console, I will post a script you can run.
0
 

Author Comment

by:filipenascimento
ID: 20405941
Hi,
nope, it asks me for the passwd! And then it comes again...!
0
 
LVL 66

Accepted Solution

by:
johnb6767 earned 250 total points
ID: 20406002
Can you access this machine's registry from another system on the network?

If so....

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon
Userinit=C:\WINDOWS\system32\userinit.exe,     <~~notice the comma....

while youre in there...

shell=explorer.exe
0
 
LVL 66

Expert Comment

by:johnb6767
ID: 20406008
Can also check out these values by booting into UBCD4Win, or BartPE. Please advise if you need assistance...
0
 

Author Comment

by:filipenascimento
ID: 20406038
Thank you John6767,

This computer is disconnected from network, is there any way to boot from a CD and then enter the registry?

kind regards,
FN
0
Complete VMware vSphere® ESX(i) & Hyper-V Backup

Capture your entire system, including the host, with patented disk imaging integrated with VMware VADP / Microsoft VSS and RCT. RTOs is as low as 15 seconds with Acronis Active Restore™. You can enjoy unlimited P2V/V2V migrations from any source (even from a different hypervisor)

 
LVL 66

Assisted Solution

by:johnb6767
johnb6767 earned 250 total points
ID: 20406070
What is the Ultimate Boot CD for Windows?
http://www.ubcd4win.com/

Bart's Preinstalled Environment (BartPE) bootable live windows CD/DVD
http://www.nu2.nu/pebuilder/

Load your regedit, and then go to File>Load Hive....Navigate to c:\windows\system32\config\ and load the system hive....Then follow the key structure....
0
 

Author Comment

by:filipenascimento
ID: 20406114
I will try this.

Thank you very much!

Get back to you in a while.
0
 
LVL 4

Expert Comment

by:_Forgotten_
ID: 20407977
the passwoord for the recovery console is probaby blank.  Try no password
0
 

Author Comment

by:filipenascimento
ID: 20408302
Hi John,

Done all the requested actions, still the same.
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon
Userinit=C:\WINDOWS\system32\userinit.exe,     <~~notice the comma....
and also...
shell=explorer.exe

Could you advise please?

Kind regards,
FN
0
 
LVL 53

Expert Comment

by:McKnife
ID: 20408397
Could be http://support.microsoft.com/?kbid=249321 (applies to xp as well)
0
 

Author Comment

by:filipenascimento
ID: 20408921
Hi Guys,

Thanks... Got It!!!

I was being lame... Thanks a lot Johnb6767!
0
 
LVL 66

Expert Comment

by:johnb6767
ID: 20408930
Got it fixed? Which part was it?
0
 

Author Comment

by:filipenascimento
ID: 20413765
As you told.
I was only forgeting to unload the system hive to save changes.

Kind regards,
FN
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

The term "Bad USB" is a buzz word that is usually used when talking about attacks on computer systems that involve USB devices. In this article, I will show what possibilities modern windows systems (win8.x and win10) offer to fight these attacks wi…
Recently, I read that Microsoft has analysed statistics for their security intelligence report. It revealed: still, the clear majority of windows users do their daily work as administrator. An administrative account is a burden, security-wise. My ar…
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

746 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

14 Experts available now in Live!

Get 1:1 Help Now