Solved

Internet Explorer Blocks Access to Microsoft Access

Posted on 2007-12-04
8
685 Views
Last Modified: 2013-12-08
When Microsoft Internet Explorer 7 is installed on network pcs, it blocks access to Microsoft Access.  Whether it's a automatic update from Microsoft or a manual install of explorer 7 it blocks users from accessing the Microsoft Access Database.  I have to uninstall explorer 7 in order for users to access the database.  I don't understand how a Microsoft product would block access to another Microsoft product.  It will open access files that are not being used by other users.  Only the main database that users log into will not open.  Can anyone provide me with some insight on this situation.  All users have Windows XP Pro and Office 2000.
0
Comment
Question by:livinlif3
8 Comments
 
LVL 13

Assisted Solution

by:wiswalld
wiswalld earned 20 total points
Comment Utility
Not sure of your problem I have XP Pro and Access 2003 on a machine with explorer 7.0 and no problems. Check Tools-Options_Advanced and see if it is set to shared for the default open mode.
0
 
LVL 66

Expert Comment

by:johnb6767
Comment Utility
Are these local databases? Or just cant run start>run>msaccess.exe?
0
 
LVL 10

Assisted Solution

by:dragonjim
dragonjim earned 20 total points
Comment Utility
Ok. You have a shared database, with clients running local copies of Office 2000 (Access being issue).
I haven't run across any issues with the permissions itself.

You might want to check:
1) File / Directory permissions for all users (Full Control?)
2) Are there database level locks (if 1 user is in, are others allowed in?)
--> More common is a record lock ... if user1 is in record 221; then user2 is told "sorry, another user is editing this record, please try again" -- protects against data integrity issues.
0
 
LVL 3

Author Comment

by:livinlif3
Comment Utility
Yes, this is a shared database on the network.  

1) users have full control of the database.  (everyone has full access, to folder)   I'm in the process of rolling over from a workgroup network to a domain)  The update affected domain users and workgroup users, there is a few users on the old workgroup setup, that I'm in the process of transfering to new domain.
2)  Multiple users can access the database at the same time.
3)  If a computer has internet explorer 7 installed, when you click on the shortcut to the database the database doesn't even show up.  Say for instance I take the database and copy it to the desktop on the computer,  I can then access the database.  (only the database that is in use by multiple users will not open)   Pcs that have internet explorer 7 installed can't access the database.  Why would internet explorer not allow me to access the database when internet explorer 7 is installed is beyond me.   I've searched high and low and don't see anyone having this type of issue.
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 
LVL 66

Assisted Solution

by:johnb6767
johnb6767 earned 460 total points
Comment Utility
Are you accessing from mapped drives, or UNC paths?

Have you put the server of the shared DB in the trusted zones?
0
 
LVL 66

Accepted Solution

by:
johnb6767 earned 460 total points
Comment Utility
From "http://techrepublic.com.com/5208-6230-0.html?forumID=101&threadID=204752&messageID=2149264"

We encoutnered this shortly after people upgraded to IE7.

A workaround is to get IE to not try and detect your local intranet zone.

- in Control Panel, run Internet Options
- Go to the Security tab
- Click the Local Intranet icon
- Click the Sites button
- Uncheck "autmatical detect Intranet Zone" box
- leave the others checked as per your preference (for me it's all three).
0
 
LVL 66

Expert Comment

by:johnb6767
Comment Utility
Internet Explorer 7, Site Security, Mapped Drives argh!!
http://techrepublic.com.com/5208-6230-0.html?forumID=101&threadID=204752&messageID=2126861

The full threads....
0
 
LVL 3

Author Comment

by:livinlif3
Comment Utility
We encoutnered this shortly after people upgraded to IE7.

A workaround is to get IE to not try and detect your local intranet zone.

- in Control Panel, run Internet Options
- Go to the Security tab
- Click the Local Intranet icon
- Click the Sites button
- Uncheck "autmatical detect Intranet Zone" box
- leave the others checked as per your preference (for me it's all three)

This is the solution I was looking for.  It worked fine right after these directions.  It's crazy how Microsoft, would block access to one of their own applications!!
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

#Citrix #Internet Explorer #Enterprise Mode #IE 11 #IE 8
When you start your Windows 10 PC and got an "Operating system not found" error or just saw  "Auto repair for startup". After a while, you have entered a loop for Auto repair which does not fix anything and you will be in a  panic as all your work w…
Basics of query design. Shows you how to construct a simple query by adding tables, perform joins, defining output columns, perform sorting, and apply criteria.
This Micro Tutorial will demonstrate how to add subdomains to your content reports. This can be very importing in having a site with multiple subdomains.

763 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now