Solved

Having problems with Automatic DNS Updates from DCs

Posted on 2007-12-04
7
240 Views
Last Modified: 2010-04-07
Hello,

I have 2 DCs in two different locations connected via software VPN.
Both DCs run DNS server services on them.

However, one DC is behind an NAT router, so it only has a local address, while the other DC is behind a Cisco firewall co-located in a data center with both a public and a private IP.

The private IP works fine over the software VPN and can connunicate, however the co-located DC keeps updating it's DNS record for itself with both the public and the private IP address.
This is causing problems in the office where the NAT router sits because it tries to connect over a public IP when it should only be using the private IP.

I have tried to remove it in the DNS records, and it works perfectly.. However it keeps adding itself back in every couple of hours!

How can I stop this DNS server from updating itself with the public IP?
0
Comment
Question by:BuggyBoyNYC
  • 4
  • 3
7 Comments
 
LVL 12

Accepted Solution

by:
Amit Bhatnagar earned 500 total points
ID: 20409196
A very common problem normally seen with DNS Server with RRAS installed as well (Multihomed). Anyways, the fix is simple as well.

http://support.microsoft.com/kb/275554
http://support.microsoft.com/kb/246804/EN-US/
http://support.microsoft.com/kb/292822

I could have posted the exact keys for you but I want you to read the entire article if possible. It will help you know a lot of keys\registry changes which people are normally unaware of.


Cheats : Last article contains the resolution part..:D Cheers !!!
0
 

Author Comment

by:BuggyBoyNYC
ID: 20409519
Thanks for the response!
However I think I should clarify one thing, I am not using RRAS I am using a seperate third-party software VPN on the system which creates a new network adapter with a private address (much like how a Cisco VPN client does, except this runs 24/7 with no disconnect).

I am not quite sure exactly what instruction set to follow since this isn't specifically RRAS!

Many thanks again, hope you can clarify for me! :)

For example sake, lets say the public address is 66.237.111.111 and the private is 10.2.2.1. How do I keep 66.237.111.111 from automatically registering in the DNS on this server, even though both are valid connections?
0
 
LVL 12

Assisted Solution

by:Amit Bhatnagar
Amit Bhatnagar earned 500 total points
ID: 20409574
Hey Buggy Boy from New York City...:D...It does not really matter whether you have RRAS configured or not, if it is a DNS Box and you have multiple adapters, they will register themselves automatically in the form of SOA(Start of Authority) and Host A record. That means even if you have a Virtual network Card due to Loopback adapter or bluetooth, They will get registered in DNS as well. To disable this effect, Add the PublishAddresses and RegisterDnsARecords registry values for the DNS and Netlogon services.

You will notice in the last article that they have mentioned "This issue typically affects computers that are running Small Business Server because this version of Windows Server is frequently the only server on the network". This is because SBS in most of the cases has two NICs. One public and one private. Hope, this helps !!!
0
3 Use Cases for Connected Systems

Our Dev teams are like yours. They’re continually cranking out code for new features/bugs fixes, testing, deploying, testing some more, responding to production monitoring events and more. It’s complex. So, we thought you’d like to see what’s working for us.

 

Author Comment

by:BuggyBoyNYC
ID: 20409682
Thank you so much! :)
0
 
LVL 12

Expert Comment

by:Amit Bhatnagar
ID: 20409699
I'll be more happy if these steps actually resolve your issue...It is not like I have doubts...but technology has a mind of its own.... :D U never know...Do let me know the result.
0
 

Author Comment

by:BuggyBoyNYC
ID: 20409760
Added those two registry values, and restarted NetLogon and DNS Server services and it IMMEDIATELY resolved the issue! The only A record showing for the co-lo machine was the local address! :) Many thanks!!!!
0
 
LVL 12

Expert Comment

by:Amit Bhatnagar
ID: 20409861
You are welcome !! Just an advice...To be dead sure that it is fixed. Restart the Server in Off-Office hours and see if they are still missing. Take care..:) A lot of reregistration happens at the time of System Restart...:)
0

Featured Post

Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

I wrote this article to explain some important DNS concepts that should be known to avoid some typical configuration errors I often see in forums. I assume that what is described here is the typical behavior of Microsoft DNS client. I don't know …
I've written instructions for one router type, but this principle may be useful for others of the same brand and even other brands of router. Problem: I had an issue especially with mobile devices that refused to use DNS information supplied via…
Nobody understands Phishing better than an anti-spam company. That’s why we are providing Phishing Awareness Training to our customers. According to a report by Verizon, only 3% of targeted users report malicious emails to management. With compan…
With Secure Portal Encryption, the recipient is sent a link to their email address directing them to the email laundry delivery page. From there, the recipient will be required to enter a user name and password to enter the page. Once the recipient …

773 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question