• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 660
  • Last Modified:

Sending mail from a mail-in Database

Is it possible to send mail SMTP from a mail-in database in such a way as it can be replied to?
I have 2 users using a shared mail file which is a mail in database, and I made the mail file owner the mail-in DB name ABC/Organisation. The problem is that the organisation becomes part of the senders email address when mail goes out.
So replies go to ABC/Organisation@domain.com which doesn't work butI must have an organisation included in the mail file owner field.
I've checked the config doc and it is set up NOT to include the organisation in smtp mail addresses.

Thanks,

Sam.
0
Samurai073199
Asked:
Samurai073199
2 Solutions
 
dom_adminCommented:
Try to add an email address to the "Internet address" field on the Mail-In database document.

This address should then be used as the from address on outbound messages.

/Brian
0
 
TTCTECHCommented:
Unless you are using switch ID (or a Location Document) to access the Mail-in database, the messages will state both the email address AND the sender's address (e.g. sent by Mail@acme.com, sent by Jsmith@acme.com).
0
 
Samurai073199Author Commented:
dom_admin :There is an address in the Internet Address field of the mail in doc but the from address is not the same as the entry in that field when mails are recived that have been created by others.

TTCTECH: Yes it's a mail file being opened by two different users so when they generate and email in it, it says From: ABC/Org Sent by: XYZ/Org. The problem is the From address is used as the return address in it's entirety with the name AND org before the @ which means replies to it don't get delivered.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
qwaleteeCommented:
Workaround:

Set up a PERSON representing the mail-in instead of a mail-in record  representing the mail-in. Then, make the primary user name for that person match the Internet address. Finally, you assign that person as the mail file owner.
0
 
SysExpertCommented:
In addition, it should still be possible to do a little spoofing, since this is SMTP mail, but it requires that you create the mail directly in the Servers mail.box, and set the from, and Principal fields directly.

I did this using a modified mail template. I had to remove/ disable all the reply, and other options, and change the Send action totally, but it did work.


I hope this helps !


0
 
Samurai073199Author Commented:
Thanks guys. I've discovered they'd only given me half the story and there they only needed 2 users to be able to accept mail from an additional domain (easy enough) but both useful work arounds as I'm sure to encouter this issue for real.

Cheers,

Sam.
0
 
dom_adminCommented:
Just want to add a comment to the posting from qwaletee ... Remember that when you create additional user ID's, you will be charged for an extra license - even if the ID is just used for "impersonation" purposes...

I'm sorry for not responding sooner, but using the mail-in DB as the mailfile owner does work... I use it extensively :-)

It is probably caused by some improper setting in your SMTP configuration... It should be configured to lookup internet addresses, and not to automatically "generate" the address. I think it is called "Internet Address lookup" in the configuration document.

/Brian
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now