Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2854
  • Last Modified:

Moving ReportServer : The request failed with HTTP status 401: Unauthorized

     
Hi,
I am in the process of moving reportserver and reportmanager from one server to another due to upgrade. SQL Server remains in the same place.
I am getting the above error when trying to conenct to my reportmanger
https://reportshare.thegmcgroup.local/reports
I have SSL set up using SELFSSL.exe
I can access the lisy of report vis
https://reportshare.thegmcgroup.local/reportserver
BUT get the error when trying the previous URL

Any ideas?

SQL Server 2005
Windows 2003 Server
All SP added and up to date.
0
scottsanpedro
Asked:
scottsanpedro
1 Solution
 
James MurrellProduct SpecialistCommented:
a friend had this once... he ended up having to  reinstall the entire SQL Server environment to get rid of error and have the reports display properly.
0
 
nicolasdiogoCommented:
401 error

would you have a proxy on your network by any chance?
if you do, consider creating rules to allow users to ignore the proxy for internal networks.

also check how users are suppose to be identified to reporting services, it is normally AD, and check if there is a connection between them.

see if that helps.
0
 
scottsanpedroAuthor Commented:
Yes we have a proxy, and users are bypassed through Lan Settings on IE.
I can revert back to the original install on \\REPORTSERVER and conenct no problems to all the reports. As soon as I stop that services and initiate the new service on \\REPORTSHARE I get the 401 error.
I have backed up the Encryption Key from the old server and cleared out any reference via RSKeyMgmt on new install. Then restored the old key. BTW this doesn't seem to change anything when listing the keys on RSKeyMgmt -l  !
The encryption must be working because I can access the reports if I go via  https://reportshare.thegmcgroup.local/reportserver
Must be a permissions problem somewhere.
0
Lessons on Wi-Fi & Recommendations on KRACK

Simplicity and security can be a difficult  balance for any business to tackle. Join us on December 6th for a look at your company's biggest security gap. We will also address the most recent attack, "KRACK" and provide recommendations on how to secure your Wi-Fi network today!

 
scottsanpedroAuthor Commented:
if anyone has this problem....I solved it by setting Basic authentication on IIS (Do this only when you have SSL installed) we have a proxy here, so hence the problem.

Here's the info from MS

"      Integrated authentication is through a proxy. This happens because the proxy doesn't maintain the NTLM-authenticated connection and thus sends an anonymous request from the client to the server. Options to resolve this problem are as follows:
"      Configure IIS to accept Basic authentication. This should only occur over SSL for security purposes.
"      Don't use a proxy.

Make sure Windows Authenication is de-selected, only have Basic authentication set.

Question is now closed..
0
 
scottsanpedroAuthor Commented:
Done
0
 
Vee_ModCommented:
Closed, 200 points refunded.
Vee_Mod
Community Support Moderator
0

Featured Post

New Tabletop Appliances Blow Competitors Away!

WatchGuard’s new T15, T35 and T55 tabletop UTMs provide the highest-performing security inspection in their class, allowing users at small offices, home offices and distributed enterprises to experience blazing-fast Internet speeds without sacrificing enterprise-grade security.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now