Multiple connections to Access Database?

I'm having trouble with users not being able to access a single Microsoft Access Database at the same time.

When one user opens it up, it says it will open in read only mode because another user has another copy open.

Can I disable this feature?

Thanks
snyderkvAsked:
Who is Participating?
 
Jim Dettman (Microsoft MVP/ EE MVE)President / OwnerCommented:

  Make sure all users have full privs for the directory where the MDB resides.

JimD


 
0
 
peter57rCommented:
The likely cause for this  is that you have not given users adequate permissions on the folder containing the database files.
Users must have full permissions on the folder because Access involves creating, modifying and deleting files when it is being used.
If you are not sure whether users have those permission see if they can create and delete a Word or XL file in the database folder.



0
 
Arthur_WoodCommented:
Set the MDB to open in Shared Mode by default -

From the Menu bar, choose Tools>Options.Advanced tab - set Default Open mode to Shared.  Then close the MDB, and after that multiple users can open the MDB at the same time.

Is the Application structured as a Front-End/Back-End?

The Front-End MDB holds all the Forms, Reports and Queries, and LINKS to the Back-End MDB which holds only the REAl data tables, but no forms, Reports or queries.

AW

0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
snyderkvAuthor Commented:
Ok it was shared and we went ahead and put more share and NTFS permissions on it.
0
 
Arthur_WoodCommented:
Is the Application structured as a Front-End/Back-End?

AW
0
 
snyderkvAuthor Commented:
Fixed the problem. The issue was with not only the security permissions to the database but some users had shortcuts on there desktop that pointed to the old server (but same share) I deleted and recreated them.

Thanks for the help
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.