Why don't I have security permissions to access these files?

I have some files on an NTFS partition that I did not seem to have security permissions for.  Hmmm... my laptop, I created the partition, nobody else has access to the laptop... how did that happen?

So I opened up the properties security tab and see "To continue, you must be an administative user with perissions to view this object's security properties".  I "continued" and saw that my user name was not listed for permissions.

So I added my user name with FULL CONTROL to the PARTITION permissions.

But then I found out I STILL didn't have permissions to the files on that partition?!  What the....?

I went to the Partition properties, Security, clicked Advanced, Effective Permissions, entered my User Name: sure enough, all checkboxes were checked - I supposedly had FULL CONTROL!

Clicked on the Advanced, Permissions tab for the PARTITION which confirmed that I have FULL CONTROL that applies to "Folder, subfolders and files"

Huh?? Am I having a stupid moment here?

So I took ownership of the PARTITION and checked "Replace owner on subcontainers and objects" and Closed the properties window.  Went back into properties for the PARTITION and confirmed: Yes, I am now shown as the owner and Yes, I have Full Control for "Folder, subfolders and files".

So I check the security properties for one of the files and find that my user name is STILL NOT listed... AND that I am the owner.

Only thing left is to add my user name ONE FILE AT A TIME - which I do NOT want to do... too many files!

WHAT AM I MISSING HERE?!  How can I get FULL CONTROL security permissions (for my USER NAME) for all the objects by changing the security permissions for the partition?

With Regards-
Sam

Open in new window

SAbboushiAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
Kurt_BraeckmansConnect With a Mentor Commented:
When you go to the properties of the partition, then security, then advanced.
Did you check "Replace permissions entries on all child entries"?
0
 
SAbboushiAuthor Commented:
Thanks Kurt  - Nope I did not - For Vista, that checkbox doesn't appear unless I click Edit - so I missed it!  Thanks... I think I'm past that stupid moment now... Maybe!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.