Solved

samba pdc mapping windows groups to unix groups

Posted on 2007-12-05
4
1,273 Views
Last Modified: 2013-12-16
Dear Sir/Madam:

configured the linux as domain controller  
[root@parrot ~]# net groupmap list
Domain Admins (S-1-5-21-386657565-2353459576-620808375-512) -> 533
Domain Users (S-1-5-21-386657565-2353459576-620808375-513) -> users
Domain Guests (S-1-5-21-386657565-2353459576-620808375-514) -> nobody

created unix groups : ntadmins , users and nobody

when tried to map them to windows groups with the following command getting the error :

[root@parrot ~]# groupadd ntadmins
groupadd: group ntadmins exists
[root@parrot ~]# net groupmap modify ntgroup="Domain Admins"unixgroup=ntadmins
NT Group Domain Adminsunixgroup=ntadmins doesn't exist in mapping DB

please help me on this.











0
Comment
Question by:D_wathi
  • 2
  • 2
4 Comments
 
LVL 30

Accepted Solution

by:
Kerem ERSOY earned 500 total points
ID: 20411693
Hi,

You need to use "net groupmap" command to map groups.

This is the usage of the command:
net groupmap add rid=1000 ntgroup="Accounting" unixgroup=acct type=d

Please note the type=d switch it means that the gorup is a domain group.

For mote informaion please browse here:

http://samba.org/samba/docs/man/Samba-HOWTO-Collection/groupmapping.html
0
 

Author Comment

by:D_wathi
ID: 20412644
thanks sir did accordingly could able to map users  and when root login roaming profile is loaded from the linux domain controller but for ordinary samba users following message appears in the windows:

Windows did not load your roaming profile and is attempting to log you on with your local profile. Changes to the profile will not be copied to the server when you logoff. Windows did not load your profile because a server copy of the profile folder already exists that does not have the correct security. Either the current user or the Administrator's group must be the owner of the folder. Contact your network administrator.
0
 
LVL 30

Expert Comment

by:Kerem ERSOY
ID: 20413036
ok so in fact the answer to your question is ok. now you are asking another question. Let me remind you that it is better to close the question and pen-up another one is the best method for people to reach answer. Anyway the answer to your new question is that: Policies require that profiles be owned by the logged in user by defalt to prevent this follow these steps:

   - Run Group Policy editor (gpedit.msc)
   - Select Computer Configuration > Administrative Templates >  System > User Profiles
   - Remove check for user ownership of Roaming Profile Folders (Enabled)

If the key is not already there you can create it too:
    [HKEY_LOCAL_MACHINE \ SOFTWARE \ Policies \ Microsoft \ Windows \ System]:            CompatibleRUPSecurity = dword:00000001
0
 

Author Comment

by:D_wathi
ID: 20414216
thanks so much for the support  i had done the config in windows but stll the same problem finally
after adding the following line in smb.conf file able to login successfully with the roaming profile
but another error will post as a new query.

 write list = @smbusers @root
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Goal:  To set up a secure SSH server for your home computer to make it accessible anywhere AND to use it as a port forwarding proxy. Steps 1.  WinSSHD version 5 is free for personal use.  So download and install it.  You can download it from the…
Have you ever stumbled upon a software that is so great that you just love? It happened to me. Love at first sight. Filezilla Server.   Ok its not the most advanced ftp server I've came across. But its a fairly simple piece of software to get the …
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.

809 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question