How to set recursive folder permissions in an Exchange mailbox ?

We are running Exchange with SBS2003 / Outlook2003.

We created a utility mailbox, which would act as a store for old archived messages which all our users might need access to.
We copied a lot of data into this mailbox, mainly messages. It was from several users, and there are lots of folders and sub-folders. One folder has about 70 sub-folders for example.

Trying to set folder permissions is proving a nightmare. At the moment I have to go to each folder and set the permissions EXPLICITLY on each folder. With so many folders it will take a long time, and increases the chance of human error and missing one or two permissions.

Shouldn't there be a way for permissions set on a folder to replicate down recursively to all the sub-folders ? Then we could just add all 4x users to the root folder, and the permissions would propagate down the hierarchy ?

But don't know why this is not happening, or how to turn it on.....
zorba111Asked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
ormerodrutterConnect With a Mentor Commented:
Why didn't you set this on Exchange server? Grant the users whatever permissions to that utility mailbox?
0
 
zorba111Author Commented:
I did this from Outlook by setting the top level mailbox node's permission.

The permissions did not get inherited to the sub-folders.

Would it be any different had I done this from the server?
IE the permissions would have been inherited down the chain ?
0
 
zorba111Author Commented:
>> Would it be any different had I done this from the server?
>> IE the permissions would have been inherited down the chain ?

Well, I found out for myself - most definitely YES !!
This time the permissions were inherited down the chain and all is well.

So thank you !

I'd love to know why it worked one way but not the other way, just b4 I close this
0
 
zorba111Author Commented:
thanks ormerodrutter
would've loved a one-liner explanation of why it worked this way but not from Outlook, but that's only the cherry on top :-)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.