SafeNet SoftRemote 10.7.2 (Build 12) VPN Client: not starting "SafeNet Virtual Adapter" when connecting to VPN tunnel

Posted on 2007-12-05
Medium Priority
Last Modified: 2008-07-22
At my work we load a Netscreen Remote application on the laptops of our remote users so they can connect to our VPN tunnel to our network and access network resources.  Just recently I built a laptop for a user to replace their older, slower laptop.  I installed the VPN client on the laptop and added the security policy like I've done on tons of other laptops.  I shipped the laptop out to her and when she got it she powered it on, right-clicked on the Netscreen-Remote icon on the task tray and selected Activate Security Policy.  She then right-clicked on the icon again, selected Connect and then My Connections\Goldline (Goldline is the name of our company).  The application then asks for the user's username and password which you enter in and then a message appears saying "You are now connected to My Connections\Goldline".  However, at this time there should also be a "SafeNet Virtual Adapter" connection icon that pops up in the task tray but it doesn't.  On her old laptop everything works fine...
Question by:Swamp_Thing
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
LVL 32

Expert Comment

ID: 20439651
It appears that the VPN client software did not proceed successfully, as a remedy login with a user which has administrative privilidges and check if this simple steps solves the issue.
Otherwise, either reinstall the software on the machine or if the machine is a winXP with System Restore enabled; restore the system to a back date and then install the software which would solve the problem for sure.

I would suggest you to try establishing the tunnel with the administrative a/c at least once to make sure that all the virtual adapter components have been installed properly.

Please implement and update.

Thank you.

Accepted Solution

Swamp_Thing earned 0 total points
ID: 20541557
I solved this issue myself.

I had to contact SafeNet tech support because I found out something very interesting...  I had installed Symantec Anti-Virus 2008 on the users laptop and it just so happens that when Symantec is installed it uses a "Deterministic Network Enhancer" driver.  This is the same driver that the VPN client uses to start the SafeNet Virtual Adapter and if Symantec is installed and I try to connect to the VPN, it won't work.  When I told SafeNet about this they talked to Deterministic Networks (a 3rd party company that SafeNet uses to code some part of their VPN client software).  Currently SafeNet, Deterministic Networks, NetScreen, Microsoft, and Symantec are working on this issue.

I just uninstalled the Symantec Anti-Virus 2008 version and managed to find a 2007 version on Symantec's website, so I just installed that and everything works like a charm.
LVL 32

Expert Comment

ID: 20542300
Good to know that the problem is solved, this explanation of your is helpful for everyone! :)

Thank you.

Featured Post

Four New Appliances. Same Industry-leading Speeds.

But don't take it from us.  The Firebox M370 is Miercom tested and Miercom approved, outperforming its competitors for stateless and stateful traffic throughput scenarios.  Learn more about the M370, M470, M570 and M670 and find the right solution for your organization today!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

For a while, I have wanted to connect my HTC Incredible to my corporate network to take advantage of the phone's powerful capabilities. I searched online and came up with varied answers from "it won't work" to super complicated statements that I did…
Some of you may have heard that SonicWALL has finally released an app for iOS devices giving us long awaited connectivity for our iPhone's, iPod's, and iPad's. This guide is just a quick rundown on how to get up and running quickly using the app. …
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Windows 10 is mostly good. However the one thing that annoys me is how many clicks you have to do to dial a VPN connection. You have to go to settings from the start menu, (2 clicks), Network and Internet (1 click), Click VPN (another click) then fi…

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question