Solved

Split-tunnelling not working right - no Internet access with Cisco Vpn client

Posted on 2007-12-05
5
2,124 Views
Last Modified: 2012-05-05
I can not browse the Internet when connected to my Pix 501 with the Cisco Vpn Client. So I rechecked my split-tunnelling configuration, but cannot see what is wrong. I've compared to many split-tunnelling suggestions in this forum but can not see where is my error.  Can anyone see what I'm missing ? (everything else works ok)

What is normally the proper Acl format to use for split-tunnelling, assuming 10.200.6.0 is my internal ip network, 10.10.8.0 is the Vpn ip network:
1) access-list split permit ip 10.200.6.0  255.255.255.0  10.10.8.0 255.255.255.0
2) access-list split permit ip 10.200.6.0  255.255.255.0  any
Most of the configs I saw were using one of these two. Any one better than the other ?

If I define 2 vpngroups, should I create 2 Acl's (identical) to use for each vpngroup ?

So here is my configuration :
**********************
PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password kig2mWe5SfGES2pX encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname pix-biblio
domain-name testdomain.local
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list outside_access_in permit icmp any any
access-list outside_access_in permit tcp any interface outside eq 80
access-list nonat permit ip 10.200.6.0 255.255.255.0 10.10.8.0 255.255.255.0
access-list SPLIT permit ip 10.200.6.0 255.255.255.0 10.10.8.0 255.255.255.0
pager lines 24
icmp permit any inside
mtu outside 1500
mtu inside 1500
ip address outside 68.179.x.y 255.255.255.0
ip address inside 10.200.6.29 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool vpnpool1 10.10.8.1-10.10.8.254
pdm location 10.200.6.0 255.255.255.0 inside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list nonat
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) tcp interface 80 10.200.6.25 80 netmask 255.255.255.255 0 0
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 68.179.x.y 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
aaa authentication enable console LOCAL
aaa authentication http console LOCAL
aaa authentication ssh console LOCAL
aaa authentication telnet console LOCAL
http server enable
http 10.200.6.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set VPN esp-3des esp-sha-hmac
crypto dynamic-map VPNCLIENTS 10 set transform-set VPN
crypto map mymap 10 ipsec-isakmp dynamic VPNCLIENTS
crypto map mymap client configuration address respond
crypto map mymap interface outside
isakmp enable outside
isakmp identity address
isakmp nat-traversal 20
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption 3des
isakmp policy 10 hash sha
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
vpngroup 2mtbib address-pool vpnpool1
vpngroup 2mtbib dns-server 10.200.6.5
vpngroup 2mtbib wins-server 10.200.6.5
vpngroup 2mtbib default-domain testdomain.local
vpngroup 2mtbib split-tunnel SPLIT
vpngroup 2mtbib idle-time 1800
vpngroup 2mtbib password xxxxxxxxx
telnet timeout 5
ssh 10.200.6.0 255.255.255.0 inside
ssh timeout 5
management-access inside
console timeout 0
username aaaaaaaaaa password oZ4OzVZUIiu6KidY encrypted privilege 15
terminal width 80

 does not work on my Pix 501 - I'm not able to see what's wrong with my split-tunnelling configuration on my Pix 501. I've compared with many sample configurations
0
Comment
Question by:ndidomenico
  • 3
  • 2
5 Comments
 
LVL 28

Accepted Solution

by:
batry_boy earned 500 total points
Comment Utility
Since you have only the 1 VPN pool that you're giving out to the VPN client's, either ACL should work for your split tunneling definition.  The only difference would be that ACL #2 in your post would cover any future IP pools that you create...ACL #1 only covers split tunneling for your existing pool.

It looks OK to me, except a couple of things I have questions about.

1.  How are you performing your VPN user authentication?  I don't see the command:

crypto map mymap client authentication LOCAL

in your config...are you using the local user database for VPN user accounts?

2.  While in a VPN session, can you ping the DNS server that you are pushing out to the VPN clients?  I was just thinking that maybe the inability to get to the Internet is simply a name resolution issue...I've seen it before!
0
 

Author Comment

by:ndidomenico
Comment Utility
1. I'm connecting using the local users defined in the vpngroup commands
I didn't see the "crypto map mymap client authentication LOCAL" in the Cisco sample Vpn config file. I connect to 2 other Pix using Vpn and they don't have that command either.

2. Oh Oh - can not ping the Dns server 10.200.6.5 when connected in Vpn.

I just tried another Vpn client (4.8.02.0010) from another laptop and I'm able to browse the Internet. Would there be a problem with an earlier version of the Vpn client (4.6xx) ??
0
 
LVL 28

Expert Comment

by:batry_boy
Comment Utility
Yes, I've seen various issues with older versions of the client software.  That's why Cisco releases so many versions of the client...they're always having to fix bugs!  In their defense, however, they do add features as well with those newer releases.
0
 

Author Comment

by:ndidomenico
Comment Utility
When I do ipconfig/all, I noticed there is no gateway ip address for the vpn connection. Is this normal ? Should'nt there be one ?
0
 
LVL 28

Expert Comment

by:batry_boy
Comment Utility
Yes, that's normal.
0

Featured Post

Free Trending Threat Insights Every Day

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

For a while, I have wanted to connect my HTC Incredible to my corporate network to take advantage of the phone's powerful capabilities. I searched online and came up with varied answers from "it won't work" to super complicated statements that I did…
Let’s list some of the technologies that enable smooth teleworking. 
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now