Solved

Server Error in '/' Application....in Sharepoint

Posted on 2007-12-05
19
12,700 Views
Last Modified: 2012-06-27
I'm having this problem when trying to open "companyweb" from any of the computers in the same subnet with the server hosting the sharepoint. Please help...
Server Error in '/' Application.

--------------------------------------------------------------------------------
 

Runtime Error 

Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine. 
 

Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".
 
 

<!-- Web.Config Configuration File -->
 

<configuration>

    <system.web>

        <customErrors mode="Off"/>

    </system.web>

</configuration>

 
 

Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.
 
 

<!-- Web.Config Configuration File -->
 

<configuration>

    <system.web>

        <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>

    </system.web>

</configuration>

Open in new window

0
Comment
Question by:edmund7s
  • 8
  • 5
  • 4
  • +2
19 Comments
 
LVL 7

Expert Comment

by:jax79sg
ID: 20416244
It means that there is an error in the sharepoint application you tried to access. However, the server cannot display the error to you because its configured not to. The next step you should do now is to go to your web.config file in your web server (sharepoint), then search for the words 'customErrors'. You should see a similar config shown in the above code snippet you posted. Change the 'mode' to "off".

After you done this, retry the application from your client again. You should now be able to see more details on why there is an error.

Note: Or you can simply go to your web server and access the sharepoint web page from there. The current settings you have will allow you to view the error on the web server itself.
0
 
LVL 1

Author Comment

by:edmund7s
ID: 20416397
I did change it on the web.config file as you told me...still it is showing the same error message when I go to "companyweb"

How do I do this one?
>>Note: Or you can simply go to your web server and access the sharepoint web page from there. The >>current settings you have will allow you to view the error on the web server itself.
0
 
LVL 1

Author Comment

by:edmund7s
ID: 20416498
I went to the server and open internet explorer and put it "companyweb" and it showed this webpage but when I clicked to "My Company's Internal Web Site" link, it goes to this same page.  What is happening?




Welcome to Windows Small Business Server 2003 

 To get started, click a link. 
 
 

  My Company's Internal Web Site 

 Collaborate and share documents on your company's internal Web site. 

   

  Network Configuration Wizard 

 Join a client computer to the Windows Small Business Server network. 

   

  Remote Web Workplace 

 Connect to the Windows Small Business Server network over the Internet. 

   

  Information and Answers 

 Learn more about Windows Small Business Server. 

 

Open in new window

0
 
LVL 7

Expert Comment

by:jax79sg
ID: 20416635
[still it is showing the same error message when I go to "companyweb"]
Try resetting your IIS by performing the following operation on the command line.
iisreset /noforce

[it goes to this same page.  What is happening?]
Mouse over the link you mentioned. Is it actually linking back to the same site?

* There may be several web.config for each site, so make sure u are changing the right one.
0
 
LVL 1

Author Comment

by:edmund7s
ID: 20416775
>>Mouse over the link you mentioned. Is it actually linking back to the same site?
Yes

I tried iisreset /noforce and still the same error

I tried looking if there is other web.config file and found one on Sharepoint Central Administration v3 and changed to to "Off" but still not working

What next
0
 
LVL 7

Expert Comment

by:jax79sg
ID: 20417093
I'm sorry, i missed out one impt detail on the web.config.

In the same file, under the tag Sharepoint.

<Sharepoint>

  <SafeMode CallStack="false" ...> change to CallStack="true".

......

Open in new window

0
 
LVL 7

Expert Comment

by:jax79sg
ID: 20417099
The last post only applies to Sharepoint. And if there ain't a CallStack attribute, please add it in.
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 20417234
This is caused by installing .Net 2.0 on your server and allowing it to configure itself on the current web sites.

Open IIS Manager > Web Sites > Companyweb > Properties

If there is an ASP .NET tab make sure that it's set to 1.1.4322 and not 2.0.xxxx

If it was set to 2.0, then change it back and make sure none of the other SBS sites are set for .NET 2.0.  Then, run the following at a command prompt:

C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\aspnet_regiis.exe -r

Jeff
TechSoEasy


0
 
LVL 1

Author Comment

by:edmund7s
ID: 20417865
In IIS Manager the "Companyweb(stopped)".  I tried to start it but the following error showed up.

IIS was unable to start the site. Another site may already be using the port you configured for this site.  Please select a unused port for this site.
0
6 Surprising Benefits of Threat Intelligence

All sorts of threat intelligence is available on the web. Intelligence you can learn from, and use to anticipate and prepare for future attacks.

 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 20418761
Okay... I think this is related to your other question (http:Q_23005058.html).  So let's look at everything together here.

Please confirm that when you look at the Web Sites in IIS Manager they match what I've outlined here:
http://techsoeasy.spaces.live.com/blog/cns!AB2725BC5698FCB8!175.entry

Jeff
TechSoEasy
0
 
LVL 1

Author Comment

by:edmund7s
ID: 20421858
Jeff,

I've put everything according to your outline.  But the following error showed when I tried to get into the companyweb from the server.
Do you think I need to reset the IIS: iisreset /noforce ?
Server Error in '/' Application.

--------------------------------------------------------------------------------
 

Configuration Error 

Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately. 
 

Parser Error Message: Unrecognized attribute 'type'.
 

Source Error: 
 
 

Line 13:       <section name="PeoplePickerWildcards" type="System.Configuration.NameValueSectionHandler, System, Version=1.0.5000.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" />

Line 14:     </sectionGroup>

Line 15:     <sectionGroup name="System.Workflow.ComponentModel.WorkflowCompiler" type="System.Workflow.ComponentModel.Compiler.WorkflowCompilerConfigurationSectionGroup, System.Workflow.ComponentModel, Version=3.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35">

Line 16:       <section name="authorizedTypes" type="System.Workflow.ComponentModel.Compiler.AuthorizedTypesSectionHandler, System.Workflow.ComponentModel, Version=3.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />

Line 17:     </sectionGroup>

 
 

Source File: C:\Inetpub\wwwroot\wss\VirtualDirectories\Companyweb80\web.config    Line: 15 
 
 

--------------------------------------------------------------------------------

Version Information: Microsoft .NET Framework Version:1.1.4322.2300; ASP.NET Version:1.1.4322.2300 

Open in new window

0
 
LVL 1

Author Comment

by:edmund7s
ID: 20421881
When I tried using one of the computers inside the network to go to companyweb...This showed up.
Server Error in '/' Application.

--------------------------------------------------------------------------------
 

Runtime Error 

Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine. 
 

Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".
 
 

<!-- Web.Config Configuration File -->
 

<configuration>

    <system.web>

        <customErrors mode="Off"/>

    </system.web>

</configuration>

 
 

Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.
 
 

<!-- Web.Config Configuration File -->
 

<configuration>

    <system.web>

        <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>

    </system.web>

</configuration>

 

Open in new window

0
 
LVL 74

Accepted Solution

by:
Jeffrey Kane - TechSoEasy earned 500 total points
ID: 20422326
Whoah..... you need to do more than an IISReset...

You have apprarently attempted to UPGRADE your CompanyWeb to WSS 3.0... which cannot be done.  You've now hosed SharePoint.

Follow this guy's blog post to fix your server:
http://blogs.technet.com/edwalt/archive/2006/11/29/removing-wss-3-0-companyweb-upgrade-restoring-wss-2-0-on-sbs-2003.aspx

Jeff
TechSoEasy



0
 
LVL 1

Author Comment

by:edmund7s
ID: 20422598
Jeff,

They told me that it was installed using side by side installation using the white paper described here:
http://www.microsoft.com/downloads/details.aspx?FamilyID=0daafc81-efff-4f5b-a28a-8265f1e99f5b&displaylang=en

The other problem that I'm having is that the rww and owa is not working
0
 
LVL 1

Author Comment

by:edmund7s
ID: 20422616
Oh sorry...and the other thing was that the companyweb was working just fine on the internal network although unaccessible from outside...Until recently???
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 20427361
Nowhere in that paper does it say you can or should call your new site "companyweb".  In fact, you shouldn't.

Did you also happen to see that in Step 4.4.a it says, "do not use Port 80, Port 8080, or other used ports"?

Jeff
TechSoEasy
0
 
LVL 3

Expert Comment

by:XChangingIT
ID: 22859489
edmund7s:

did that resolve your problem??

i have the same error coming up.....but i dont see in Add/Remove programs anything pertaining to WSS 3.0 I only see  WSS 2.0 SP3

thanks!
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 22859718
Then you don't have the same issue.  I've responded directly though to your question: http:Q_23868202.html

Jeff
TechSoEasy
0
 

Expert Comment

by:vicky1982
ID: 24512663
firstly check from where it error comes , go to webconfig file and find customerror and change no to yes,

now open the webpage, and check which error is coming  it;s got error
now go to c drive or where the inetpub folder
in inetpub folder check your application directory, now open the browser applet folder and check whether the vt.cnf folder is hidden or not if its not then change its attribute to hidden and ok now open application webpage

i am sure its working.
0

Featured Post

What Security Threats Are You Missing?

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
Increase size of DHCP scope? 16 61
AD user acount change history 4 57
IIS 7.5 to 8.0 6 75
Working with SharePoint Data 8 13
These days socially coordinated efforts have turned into a critical requirement for enterprises.
Restoring deleted objects in Active Directory has been a standard feature in Active Directory for many years, yet some admins may not know what is available.
Access reports are powerful and flexible. Learn how to create a query and then a grouped report using the wizard. Modify the report design after the wizard is done to make it look better. There will be another video to explain how to put the final p…
This tutorial demonstrates a quick way of adding group price to multiple Magento products.

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now