Cannot connect to data source error

We have a new installation of sql server 2005 reporting services.
we can deploy reports without a problem users can connect to report server
but when they try to run reports they get this error msg.

An error has occurred during report processing.
Cannot create a connection to data source 'xxxxx'.
For more information about this error navigate to the report server on the local server machine, or enable remote errors

in reporting services the datasource credentials are saved on the server
deNZityAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
deNZityConnect With a Mentor Author Commented:
Restarted IIS and ReportingServices, and everything was fine ?
0
 
YveauCommented:
Looks like you saved the wrong credentials.
Try a trace with the SQL profiler to see who logs on and who fails to log in ...

Is all installed on one machine ? Two separate machine for RS and SQL ?
Windows credentials ? Checked the 'use as windows credentials' checkbox or did you use SQL authentication in the shared data source ?

Hope this helps ...
0
 
deNZityAuthor Commented:
All is installed on one machine.
Data sources use oracle username and pword.

when I access reports on via a browser on the server I get the following eror message

An error has occurred during report processing.
Cannot create a connection to data source 'Oracare'.
System.Data.OracleClient requires Oracle client software version 8.1.7 or greater.

Oracle client 10.2.0 is installed on the server so don't understand his msg
0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

 
YveauCommented:
OK, so you are connecting to an Oracle instance ... never tried that before, but should be the same as connecting to a SQL Server machine.
What Oracle version is running ? Strange that if a 10.2.0 server is installed, the message tells you to install client 8.1.7 or higher ... I would expect that it would ask for client 10.2.0 ... ?

Try setting up a DSN using the credentials and than fill in the DSN as connection string ... what does your connection string look like ?

Hope this helps ...
0
 
YveauCommented:
OK, one of those undocumented features ...

Glad it's solved, don't forget to close the Q.
0
 
Vee_ModCommented:
Closed, 500 points refunded.
Vee_Mod
Community Support Moderator
0
All Courses

From novice to tech pro — start learning today.