Can't connect Vista Home Basic Inspiron 1501 to wireless network. Get the message connected with limited access

I have connected the laptop to 2 different wired networks with network cable.

I managed to connect once.

It fails on 2 different wireless networks, first it says that it is connected with limited access. Then when it completes it says connection failed. When I try to connect again it says that it is still connected.

I can't connect to the Internet.

I have updated the drivers for the Broadcomm network card and the 1390 mini lan.

I have been through tech support with Netgear and Dell

LVL 4
dovidfCEOAsked:
Who is Participating?
 
willcompConnect With a Mentor Commented:
Have you tried resetting Windows Sockets (winsock)?

Click Start. In the Start Search dialog box, type: cmd, and right-click cmd.
Click Run as administrator.
Type: netsh winsock reset, and then press the ENTER key.
Type: Exit and press ENTER.
Restart the computer

If that doesn't work, try resetting the TCP/IP stack:

Click Start. In the Start Search dialog box, type: cmd, and right-click cmd.
Click Run as administrator.
Type: netsh int ip reset , and then press the ENTER key.
Type: Exit and press ENTER.
Restart the computer
0
 
YGregersenConnect With a Mentor Commented:
I have seen this happen a couple of times and I always get it to work. But the sad thing is I am not always sure what I did because I try so many things first.


1 - Open CMD (as adminstrator) type
IPconfig /flushDNS

1 - disable all of the NICs, wireless too. I also turn off the power to  the wireless (my laptop has a button) This way I can work on trying to rebuild the connections one at a time. I usually start with the hard connection first.

2. With the wired NIC I will get a new set of Drivers (from another PC and the net) then I uninstall the NIC and reboot.

3. While the machine is rebooting I usually reset my router. Then when the PC comes back up I reinstall the driver.

4. Make sure your TCP/IP is set for AUTO DHCP or static  with the correct settings. I usually disable IP6

-- this usually will fix my internet connection

When I turn the wireless back on and enable it most times it finds the internet just fine. If not you have to start troubleshooting it now.
0
 
dovidfCEOAuthor Commented:
Where do I right click for administrator? When I click on the cmd window or in the command line I don't get this option
0
Worried about phishing attacks?

90% of attacks start with a phish. It’s critical that IT admins and MSSPs have the right security in place to protect their end users from these phishing attacks. Check out our latest feature brief for tips and tricks to keep your employees off a hackers line!

 
willcompCommented:
You may not have to. If you get a command prompt window, just continue on with the rest.
0
 
YGregersenCommented:
Sorry, you can either create a short cut to the CMD.exe and do properties and set the Run As Adminstrator thing.

or

Usually I type CMD in the search box of Vista and it will show up at the top of the start menu. I right click it there.
0
 
dovidfCEOAuthor Commented:

The problem was that the Netgear router doesn't support ipv6 and this had to be disabled in the wireless configuration. The winsock reset was then done and a reboot and now it works.
0
 
dovidfCEOAuthor Commented:
The participants were on the right track but the vendor got involved first.
0
 
YGregersenCommented:
Great - does 'I usually disable ip6' count as an answer?  :)
0
 
dovidfCEOAuthor Commented:
Oops, sorry. I owe you for this one. Is there some way I could contact you?
0
 
willcompCommented:
Thanks. Should be surprised that Netgear tech support didn't tell you that right off the bat, but I'm not.

FYI -- Run Command in Vista
http://www.howtogeek.com/howto/windows-vista/enable-run-command-on-windows-vista-start-menu/
0
 
YGregersenCommented:
dovidf
12.06.2007 at 11:55AM MST, ID: 20422087
Oops, sorry. I owe you for this one. Is there some way I could contact you?

- Your are fine - you gave me an assist so it's all good. I am glad you got it to work. Nothing more frustrating then 'limited conectivity' with wireless.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.