Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
Solved

Disable XMS driver

Posted on 2007-12-05
11
2,208 Views
Last Modified: 2013-12-28
I am trying to install Hard Drive Mechanic Gold (I guess it's a DOS program) on a win98 OS PC. When I attempt to execute the .exe file I get the following error:  Found Extended Memory Handler.  Reboot without XMS driver. How do you disable or delete the XMS driver without rebooting problems. My previous question and and solution got me out of a crashed PC when I made some editing changes to the c:\windows HIMEM.sys file. I understand that HIMEM.sys is the XMS driver, but when I REM the file my PC would not boot with error: HIMEM,sys is missing or corrupt. Replace HIMEM.sys and reboot. I replaced the file and I am up and running again (thanks to Teckiedog). I have a crashed hard drive on another PC and I want use Hard Drive Mechanic  to fix it.
0
Comment
Question by:harryjj38
  • 5
  • 5
11 Comments
 
LVL 92

Expert Comment

by:nobus
ID: 20418020
i would suggest spinrite for fixing the data : http://www.grc.com/spinrite.htm
and the manufacturer's test to check the drive status :  http://www.tacktech.com/display.cfm?ttid=287
0
 

Author Comment

by:harryjj38
ID: 20420773
Thanks nobus, however your solution is not exactly what I want to do. I want disable the XMS driver in a win98 OS PC so I can fix this error: Found an extended memory handler! Reboot computer without XMS driver.
0
 
LVL 92

Expert Comment

by:nobus
ID: 20420826
I know it's not what you want, but it is all i can come up with
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 

Author Comment

by:harryjj38
ID: 20422976
Nobus, I wasn't dismissing your input to my question. Thanks again. I was hoping to get some new possible solutions from other Expert Exchange members  to my question: How to disable XMS driver in win 98 OS? I would like to keep my question open for awhile to see if I can get someone else's solution to this question. If I need to  "accept as solution" your input I can do this, but I want to keep my question open. How do I do this?
0
 
LVL 92

Expert Comment

by:nobus
ID: 20426011
maybe this helps :  DEVICE=C:\DOS\HIMEM.SYS /TESTMEM:OFF

from : http://support.microsoft.com/kb/109845
0
 

Author Comment

by:harryjj38
ID: 20428289
nobus, I have tried this last night (i got this fix on a Goggle search) but just give me an error message at boot up. I used Start>Run>Msconfig>Config.sys to add this DEVICE= string. Maybe I should have added the DEVICE= string thru a DOS prompt?  Here is what I get as a boot up message now: "The following file is missing or corrupt: HIMEM.SYS . There is an error in your CONFIG.SYS file on line 5" (without quotes). I do not understand the reference to an error on line 5 in my CONFIG.SYS file because there is only two (2) lines in the file. My  CONFIG.SYS file looks like this:

Rem TSHoot
DEVICE=C:\DOS\HIMEM.SYS /TESTMEM:OFF
Any more thoughts?
0
 
LVL 92

Accepted Solution

by:
nobus earned 500 total points
ID: 20428377
rename you config.sys file to config.bak
make a new one like this : http://www.computerhope.com/ac.htm
and add your DEVICE=C:\DOS\HIMEM.SYS /TESTMEM:OFF  once as first - if still problems, as last line
0
 

Author Comment

by:harryjj38
ID: 20429466
Nobus' great stuff. I will do as you suggest and let you know the results.
0
 

Author Comment

by:harryjj38
ID: 20437323
nobus, I am still working on suggestion. I am going to try another way of fixing my hard drive and I am going to close this session as "accepted solution" and points to you.  Thanks again for all you help.
0
 
LVL 92

Expert Comment

by:nobus
ID: 20437368
i hope it works out for you
0
 

Expert Comment

by:Jake Pratt
ID: 23264666
For anyone else reading this.  In the readme file that comes with Hard Drive Mechanic Gold, it states that you must remove autoexec.bat and config.sys from the win98 boot disk in order for the software to work.  I ran into this same problem, then noticed those instructions in the readme.  After removing those files, the program started up no problem.
0

Featured Post

Comprehensive Backup Solutions for Microsoft

Acronis protects the complete Microsoft technology stack: Windows Server, Windows PC, laptop and Surface data; Microsoft business applications; Microsoft Hyper-V; Azure VMs; Microsoft Windows Server 2016; Microsoft Exchange 2016 and SQL Server 2016.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
robocopy 33 114
Remote control Windows CE 7 94
Auto-launch VPN via Wifi 7 49
List out file 4 27
When you start your Windows 10 PC and got an "Operating system not found" error or just saw  "Auto repair for startup" or a blinking cursor with black screen. A loop for Auto repair will start but fix nothing.  You will be panic as there are no back…
In this article, I will show you HOW TO: Perform a Physical to Virtual (P2V) Conversion the easy way from a computer backup (image).
The viewer will learn how to successfully create a multiboot device using the SARDU utility on Windows 7. Start the SARDU utility: Change the image directory to wherever you store your ISOs, this will prevent you from having 2 copies of an ISO wit…
Windows 10 is mostly good. However the one thing that annoys me is how many clicks you have to do to dial a VPN connection. You have to go to settings from the start menu, (2 clicks), Network and Internet (1 click), Click VPN (another click) then fi…

840 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question