NAT option is disabled for Ethernet device on VM

My VM machines have the NAT option disabled for the Ethernet card, and when I try create a new Ethernet device, it's also had the NAT option disabled.

What can cause the NAT option to be disabled, and how can I fix it so it's enabled?
LVL 30
AxterAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

rindiCommented:
Shutdown the VM, select "Edit the VM", select the NIC, and change the options you have there to the ones you want.
0
AxterAuthor Commented:
>>Shutdown the VM, select "Edit the VM", select the NIC, and change the options you have there to the ones you want.

I did try making the changes with the VM shut down.
But the NAT option is still disabled.
0
rindiCommented:
What do you see when you edit the properties of the VM?
0
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

AxterAuthor Commented:
I see the NAT option disabled.
I can select any of the other three options, but I can't select the NAT option.
0
rindiCommented:
In the vmware menu bar select "Host", "Virtual Network Settings", and then in the NAT tab make sure it isn't disabled or stopped.
0
AxterAuthor Commented:
>>In the vmware menu bar select "Host", "Virtual Network Settings", and then in the NAT tab make sure it isn't disabled or stopped.

It's enabled and started.
0
rindiCommented:
Then try changing it's configuration in the virtual network settings, like using another virtual nic.
0
AxterAuthor Commented:
>>Then try changing it's configuration in the virtual network settings, like using another virtual nic.

I'm trying to determine why it's disabled, and I rather have it working with default virtual nic.
0
rindiCommented:
On my system it's using "VMnet8". That was the default it got during installation
0
AxterAuthor Commented:
>>On my system it's using "VMnet8". That was the default it got during installation
That's also what I have.
0
rindiCommented:
Did you update from an older vmware version? I saw something on the vmware site where it said that network settings aren't kept when updating a windows vmware host.

Check the following documention, it may have some more info on how to setup NAT.

http://pubs.vmware.com/server1/wwhelp/wwhimpl/js/html/wwhelp.htm

Also check out vmware's communities:

http://communities.vmware.com/community/vmtn/server/server
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
AxterAuthor Commented:
I believe the issue was related to upgrading from the older vmware.
I uninstalled, and the reinstalled the VM, and it fixed the problem.
0
rindiCommented:
Your welcome
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
VMware

From novice to tech pro — start learning today.