Solved

CRC erros on Ubuntu router

Posted on 2007-12-06
3
379 Views
Last Modified: 2008-02-01
Hi, we recently upgraded to a new metrofiber connection that connects 5 buildings together. Each of the buildings has a tellabs 8813-310 access node provided by our ISP. We use port 3 at all the remote stores and they each connect to a different port on the tellabs at the main store. We made an Ubuntu router with a total of 5 NIC's in it, 4 for the remote stores and 1 for our main location. 4 of the NIC's on the Ubuntu router plug directly into the corresponding port on the Tellabs node provided by our ISP. The other NIC plugs directly into a switch at our main store on our main subnet. The other 4 remote stores are all on different subnets.  We set up the routing table and we have connectivity between stores, but we're running into CRC errors being generated by the router. I worked with our ISP for several days on this and they said their Tellabs access node was receiving CRC erros but not transmitting them. This is causing problems with sharing files between computers on different subnets, for example, if I try and copy a file that's much more than a couple Mb's , it'll start to copy, then stop with the windows error message "the specified network name is no longer avaiable". These erros are very random and I can find no consistant pattern in them.  This is causing problems copying files between subnets and running programs hosted on our main server. We have full internet and network connectivity at each of the remote locations, though they are not running as fast as they should be. I ran ifconfig's on each of the NIC's on the router and saw lots of collisions for the NIC's that go to our remote stores through the tellabs access node, but no collisions on the NIC that plugs directly into our switch at the main store. I configured all the NICs to our ISP's requirements (100 mbps, full duplex, no auto negotation), tried swapping out CAT5 cable, even tried putting a small 5 port switch between our router and the tellabs to see if that might help with the CRC erros and nothing worked.  When I run a continuous ping from a remote store to it's corresponding gateway (NIC on the the Ubuntu router), I get random "request timed out" messages, but like I said before, have found no consistancey on it. From what we determined with our ISP, it sounds like it's an issue with the Ubuntu router and I was wondering if anyone has ran into similar problems running a home made linux router or would be able to point me in the right direct as to resolving this issue.  I know this is a lot of info and I hope I didn't leave anythign out, if I did please ask. Thanks!
0
Comment
Question by:buenit
3 Comments
 
LVL 88

Assisted Solution

by:rindi
rindi earned 100 total points
ID: 20422452
I've had an issue recently where my router ubuntu PC which was also acting as a router also had problems with routing. I then first used the filesystem check in repair mode which fixed a couple of errors on the disk, then ran apt-get update and then apt-get upgrade, which of course on that old machine took some time, but after the upgrade had finished everything was working perfect.
0
 
LVL 19

Accepted Solution

by:
Gabriel Orozco earned 400 total points
ID: 20483147
you have a pc with 5 nic and are obtaining CRC's
if that is not pointing to hardware of a faulty/wrong kernel module, then what else will

have you read the syslog.log, access.log, debug.log et al?
I think if you can isolate there is only one card you have won the battle. but if not, have you traced how loaded is your computer? did you ran "top" or even better, "htop" or "ntop"?

when I have many interface cards from the same vendor, then I can have problems with irq sharing, etc.
check that.
0
 
LVL 2

Expert Comment

by:mkurtzhals
ID: 20586421
You made sure that both ends are negotiating the same speed or capable of that speed that they are set to.  I have seen issues like this when a device cannot support 100 full.  If not that then look at the firmware on the router.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Span IP Range across two sites via Cisco ASA Site-to-Site VPN 8 63
Netgear modem router default firmware 11 59
SMPS issue 1 44
Failover for DMVPN 3 33
Every server (virtual or physical) needs a console: and the console can be provided through hardware directly connected, software for remote connections, local connections, through a KVM, etc. This document explains the different types of consol…
In the world of WAN, QoS is a pretty important topic for most, if not all, networks. Some WAN technologies have QoS mechanisms built in, but others, such as some L2 WAN's, don't have QoS control in the provider cloud.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

696 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question