[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 459
  • Last Modified:

CAN'T OPEN FILE WITH GREEK CHARACTERS IN FILENAME

I've got a system with Windows Vista and OpenOffice 2.2. We received a .doc attachment in Windows Mail and can't open it. The filename is composed of Greek characters. I saved it to the desktop and tried to launch - still wont load. if I load OpenOffice I can browse and open it. I renamed the file to test.doc, double clicking it launches OpenOffice and we can see it fine. If I rename it back to the original Greek filename it won't launch. Any ideas on how to get it to launch without having to save to desktop, rename, then launch with every single one?
0
jfiee
Asked:
jfiee
  • 7
  • 4
  • 2
  • +1
1 Solution
 
McKnifeCommented:
So it does not open and no error message is stated?
Did you try closed office as well?
0
 
jfieeAuthor Commented:
No error message. You double click the file, nothing happens. I checked Task Manager to see if it was hanging while trying to load, but it wasn't there. Office is installed but it's the 60-day trial version and not being opened. OpenOffice is registered as the default program for .doc files, and if I rename the file to something in English, OpenOffice opens right away.
0
 
McKnifeCommented:
"Office is installed but it's the 60-day trial version and not being opened." - well...open it
If you don't want to start the trial period, take the file to another computer or use word viewer.
This should determine if it's an open office problem or not.
0
The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

 
jfieeAuthor Commented:
I opened it initially to make sure it could see the file properly. The 60-day trial is started. If the filename is in English everything loads like it is supposed to (into OpenOffice). It's only when the filename contains Greek text that it won't load at all.
0
 
McKnifeCommented:
I don't get you. Start Microsoft office Word, navigate to "open file" and open the grrek thing - what happens?
0
 
jfieeAuthor Commented:
It loads fine. If I load the program first then browse, I can open through either. The problem is when trying to double click, or, getting back to the heart of the issue, trying to open the attachment through email, if it has Greek characters in the filename, it wont launch the needed program. If the same file is renamed with english characters, it loads properly. My client will get a lot of attachments in email with Greek characters, and under XP this wasn't an issue.
0
 
McKnifeCommented:
OK - and now again: is that mentioned behavior exactly the same for open office and microsoft office?
0
 
Jason WatkinsIT Project LeaderCommented:
Try this http://www.perseus.tufts.edu/Help/fonthelp.html

It is what we use @ school
0
 
jfieeAuthor Commented:
Firebar: I checked your link, but it seems to be an option for the display of Greek text. We can see the text fine, we just can't open the file from Windows Mail or double click it and launch it if it contains Greek text.

If OpenOffice is the default handler for .doc files, or Word 2007 is the default, we can't open the Mail attachment. If we save to desktop, rename it to test or some such, then double click it, it opens. Its a workaround, but not a permanent solution. I see every space on the desktop being filled with renamed attachments in a very short time!
0
 
Jason WatkinsIT Project LeaderCommented:
How about detatching the mail attachment and opening it from Word in there?
0
 
jfieeAuthor Commented:
I've mentioned a couple times already that if I save the attachment, load Word or OpenOffice, then browse for the file, it loads fine, even with the Greek text in the filename. It's only when trying to open the attachment from within Mail, or double clicking the file that it won't open. Other .doc files launch properly, it shouldn't be too much to expect all .doc files to launch!
0
 
jfieeAuthor Commented:
Any ideas, anyone?
0
 
jfieeAuthor Commented:
I've sorted the issue out, here's what I did.

1) Ran winword /r to reset registry entries for Office 2007.  After this, the Word was default for .doc files and they opened correctly.
2) Uninstalled OOo 2.2 and installed 2.3.1, which I believe has compatibility updates for Vista.  Set OO as default for .doc files.  Opening files with Greek characters is now working correctly on double click, or directly as attachments in Windows Mail.
0
 
Vee_ModCommented:
Closed, 250 points refunded.
Vee_Mod
Community Support Moderator
0

Featured Post

[Webinar] Improve your customer journey

A positive customer journey is important in attracting and retaining business. To improve this experience, you can use Google Maps APIs to increase checkout conversions, boost user engagement, and optimize order fulfillment. Learn how in this webinar presented by Dito.

  • 7
  • 4
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now