Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Get rid of IIS login dialog

Posted on 2007-12-07
15
Medium Priority
?
912 Views
Last Modified: 2013-12-04
I have two machines,
both have win2003, IIS6.0 and Ie7,
both are in workgroup and have same user name and password on local account
both firewall are turned off.

I setup to use Integrated Windows Authentication on IIS to support intranet user.
However, when i enter the url in IE, it ask for the password (user name already display on the dialog)

I'm 100% sure the password for that user on both machine are the same

What else should i setup to get rid of the login dialog?

0
Comment
Question by:EDDYKT
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 8
  • 5
  • 2
15 Comments
 
LVL 23

Assisted Solution

by:Ashish Patel
Ashish Patel earned 400 total points
ID: 20426663
User should be in same domain not workgroup.
0
 
LVL 26

Author Comment

by:EDDYKT
ID: 20426814
i don't have domain here to test
that's why i use workgroup with same user name and password
0
 
LVL 23

Expert Comment

by:Ashish Patel
ID: 20426821
Then i guess you will always get this username and password dialog.
0
Ransomware: The New Cyber Threat & How to Stop It

This infographic explains ransomware, type of malware that blocks access to your files or your systems and holds them hostage until a ransom is paid. It also examines the different types of ransomware and explains what you can do to thwart this sinister online threat.  

 
LVL 26

Author Comment

by:EDDYKT
ID: 20426921
that's what i don't understand.
That uses to work in workgroup environment.
Does it change on win2003 environment but i cannot find any doc to describe this
0
 
LVL 26

Author Comment

by:EDDYKT
ID: 20426927
As far as i know, the domain is stored all user in one place.
In workgroup, you need to define all same user and password on each local account to make it work similiar to domain situation
0
 
LVL 23

Expert Comment

by:Ashish Patel
ID: 20426933
Just wait to see if some other experts have any comments on this.
0
 
LVL 18

Accepted Solution

by:
John Gates, CISSP earned 600 total points
ID: 20426972
Do you just have integrated windows authentication chosen or do you have basic chosen as well basic authentication should be unchecked if you do not want a prompt.

-D-
0
 
LVL 26

Author Comment

by:EDDYKT
ID: 20427085
just integrated windows authentication is checked.

One strange thing is

if i do

http://localhost/...
it works
if i do
http://ipaddress/...
it brings up the login prompt

on local machine
0
 
LVL 26

Author Comment

by:EDDYKT
ID: 20427088
not anonymous as well
if i check anonymous, everything works but i want integrated windows authentication
0
 
LVL 18

Expert Comment

by:John Gates, CISSP
ID: 20427091
how about
http://machinename
0
 
LVL 23

Expert Comment

by:Ashish Patel
ID: 20427095
Okay so what you do is enter the dns entry in your web site properties with your IP address. This should resolve the issue. Go to IIS, properties of your website and click advance button in directory and enter the IP address entry.
0
 
LVL 26

Author Comment

by:EDDYKT
ID: 20427208
>>Okay so what you do is enter the dns entry in your web site properties with your IP address. This should resolve the issue. Go to IIS, properties of your website and click advance button in directory and enter the IP address entry.

no change, dialog shows
0
 
LVL 23

Expert Comment

by:Ashish Patel
ID: 20427232
Open IIS-> Right click Web Site Properties - > Web Site Tab - > Click Advance button - > Cick Add button -> enter 80 in TCP Port and IP in Host header -> Apply.

This should sovle your issue of
http://ipaddress/
0
 
LVL 26

Author Comment

by:EDDYKT
ID: 20427259
I do it on Default web site properties not web site properties beacsue web site properties is dimmed

>>This should sovle your issue of
>>http://ipaddress/
This is not my main problem, i just point is out it is not works even on local machine. My goal is to get rid of login dialog


>>http://machinename
not work even i enter the ip in host file
0
 
LVL 26

Author Closing Comment

by:EDDYKT
ID: 31413375
I still cannot make it work on workgroup.
I try several methods.
The ideas here is i have to use workgroup to make it work  because i don't have domain to test.
0

Featured Post

Are You Ready for GDPR?

With the GDPR deadline set for May 25, 2018, many organizations are ill-prepared due to uncertainty about the criteria for compliance. According to a recent WatchGuard survey, a staggering 37% of respondents don't even know if their organization needs to comply with GDPR. Do you?

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

As I write this article, I am finishing cleanup from the Qakbot virus variant found in the wild on April 18, 2011.  It was a messy beast that had varying levels of infection, speculated as being dependent on how long it resided on the infected syste…
OfficeMate Freezes on login or does not load after login credentials are input.
Video by: ITPro.TV
In this episode Don builds upon the troubleshooting techniques by demonstrating how to properly monitor a vSphere deployment to detect problems before they occur. He begins the show using tools found within the vSphere suite as ends the show demonst…
This tutorial will teach you the special effect of super speed similar to the fictional character Wally West aka "The Flash" After Shake : http://www.videocopilot.net/presets/after_shake/ All lightning effects with instructions : http://www.mediaf…
Suggested Courses

715 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question