We help IT Professionals succeed at work.

Windows Vista does not recognize DVD Burners

8,501 Views
Last Modified: 2013-11-06
Similar to question/s asked about this before, but none of the solutions or in process answers have fixed the problem with the exception of trying to re-install Vista which I have not tried.

Problem: Vista - by this I mean Windows DVD Maker, Windows Media Player, Ulead Movie Factory 6.x - does not see either of the two DVD burners that are installed in the system. No Nero or other burning products (InCD, etc) are installed. The two DVD drives are Sony DRU-830A (with updated Vista driver from Sony) and a brand new, Vista compatible DRU-840A, both of which work on my XP boxes. Both drives are EIDE and installed on the MB EIDE controller. All hard drives are SATA and work fine. Both Sony drives are listed correctly in Explorer with their model description (i.e. DRU-830A, etc), but do not have the recording tab in properties.

Have tried uninstalling the EIDE and CDROM drives in device manager and this has not fixed the problem. Suggestions about deleting uper and lower filters, checking drive types, etc in the registry are confusing since all links are for XP and the registry listings for Vista seems, although similar, to be substantiall different so I have not attempted that. I have not tried re-installing/repairing Vista which could be problematical due to all the other software that is installed (i.e. a lot of work if I have to re=install that as well).

I build my own boxes, this one has: Asus P5B mb with latest BIOS (7-12-07), Intel Core Duo 6400 2.13ghz, 3gb ram, BFG 8800 640mb GTS vidieo card, etc.

Has a reasonably standard solution to CD/DVD burners not working on Vista been found?
Comment
Watch Question

Top Expert 2007

Commented:
Some basic questions:

Which flavor of Vista are you using?

Do you have Administrative privileges for your login?

It sounds like Vista doesn't want you to WRITE to these drives - I assume you may READ from them, yes?

You might want to take a look at the system logs and see if there are any messages regarding these units - errors loading drivers or whatever (real precise suggestion here...).

On the hardware side:

Can you boot from one or both?  If so, you might want to try booting the UBCD for windows and see you can write with these drives from that setup (I think it includes a cd burning routine).  UBCD is here:

http://www.ubcd4win.com/

Back to Vista software:

I, too, have occasionally had one (the second of two) of my DVD drives 'dissappear' but it's been a while since that happened and a reboot always cleared problems up - I have never bothered to track it down.

Sorry I can't be of more help.

wb

Author

Commented:
It's Vista Ultimate. All available updates and patches are current (except language packs). I can read from both drives and I can boot from both drives. The same problem exists when I log in as Administrator or any other user. Rebooting does not fix the problem. Since I can't make a CD, I can't (easily) make a UBCD.

Several MS Technet articles refer to group policy settings that can prevent access like this to writable drives, but the group policy editor is included with their server products and not as part of the normal user distributions. SInce my computer has never been part of a business network or connected to anything with Active Directory, I would not suspect that these permissions would have been set to deny access to the drives. I upgraded from XP Pro to Vista Ultimate and the drives worked before, so it would seem that something got changed during the upgrade process.
CERTIFIED EXPERT
Most Valuable Expert 2015

Commented:
Updates can often cause such problems. Some of the old software on the PC may not be vista conform. There is also usually a lot of old stuff that will make things behave strangely. I'd first check all the installed software for updates or patches to make it vista compatible. If you have an extra HD or space on an extra partition, Install vista to that and check if it works. You could also post a hijackthis log here, maybe there is an app running that is causing problems.

http://hijackthis.de/en
CERTIFIED EXPERT
Distinguished Expert 2019

Commented:
did you install the jmicron driver ?  otherwise, your ide controller is inactive :
from this page ; http://support.asus.com/download/download.aspx?modelname=P5B-VM&SLanguage=en-us
raid sevction

Author

Commented:
I had not been aware of the HighjackThis Tool - thanks. However, the web link you gave was for analysis only, as you indicated, not the program. As a side note, Trend Micro has taken over the program. The old version from Merijn and the link to the newest version from Trend Micro is at MajorGeeks.com here http://www.majorgeeks.com/download3155.html . The analysis at highjackthis.de.en revealed no unknown programs or problems. I have thought about installing Vista on a virtual machine, but those types of what-ifs have licensing issues and are not viable options.

As for the micron drivers, yes they are the latest and up to date available. The drives are identified correctly, can be read from and booted from, but not written to. I also use Version Tracker Pro and all programs and drivers are up to date as much as can be done.

It does not appear to be a software or driver issue in general since the basic Windows programs do no see the burning capabilities. It seems to have the symtoms of prohibited access as described in a Microsoft Technet article on group policy settings restricting access to external devices like USB drives, burners, floppies, etc, but the tool to do this is paart of the server tool set and the registry settings are not obvious to check visually, but I could also be all wrong about that. I have been able to use eternal USB devices and drives and eSATA drives with no problem, it is just the EIDE drives that seem to be a problem. I may try a SATA DVD/CD burner to see if the problem exists there, but I'd have to buy another drive.
CERTIFIED EXPERT
Most Valuable Expert 2015

Commented:
At the top right corner of the page there is a "Direct Download" Link. The log might still show some other software that is interfering. It doesn't have to be malware.

Author

Commented:
I missed that, thanks. However, the link is for Merijn's version 1.99.1. The Trend version is 2.0.2, and the resulting log file can also be submitted thru Trend for analysis. In any case, I know what each piece of software, process, and BHOs that were listed, and none are interfering with the ability to burn to a PATA DVD that I can discern.
Top Expert 2007

Commented:
There are two approaches and some scattershot ideas related to both:

Hardware - make sure the drives really can write to the media by either running them on other hardware, using an alternate OS (UBCD, a stand-alone Linux such as Knoppix or other) or by disconnecting one drive at a time and seeing what happens (this is probably the easiest way to go).

Another thing to do, a bit further out, would be to make sure a hard drive can function properly on the IDE interface - dig up an IDE hard drive and hang it out there (w/o the DVD drives connected and watch out for cable problems - ATA66/100 require an 80 conductor cable to run at full speed (or sometimes run at all)).  See if you can write to it.  If not, something is seriously hosed up with the IDE setup but I can't imagine what that would be.

Software - your have beaten the driver horse pretty hard; you might want to try <another> third-party burner product such as ImgBurn [http://www.imgburn.com/] (a nice tool for the technically oriented with many drive options; not exactly a file-by-file burner but can be used as such with a bit of fiddling; good for making video DVDs or buring ISO files) or DeepBurner [http://www.deepburner.com/] (a little rinky-dink but it works on my Vista x64 Enterprise box).

By the way, you CAN access the local security policies via Control Panel > Administrative Tools > Local Security Policy (you must have Admin rights to do this).  You can take a look at removable media policies - these are normally 'undefined' on a workstation setup and are, as a result, restricted to Administrator accounts.

Have you tried creating an alternative account with administrator rights (I assume your own account has these - I wonder if something has gotten corrupted in them) and seeing if it can write to your DVD drives?

wb

Author

Commented:
DVD drives - tested on my XP machines and they work. IDE hard drives recognized and read/write.

HOWEVER - I tried the ImgBurn software you recommended and it recognized the two DVD drives as burners and I was able to burn successfully. This rules out problems with the IDE controller.

The problem now, then is that none of the MS Windows software recognize the drives, nor does ULead Movie Factory 6.0. Any recommendations on how to correct this?? I guess the next step may be to uninstall/reinstall the Ulead product to see what happens.

I went back to the local security policies, and there are some permissions that can be defined. They are not defined by default as you said. However, the device policy settings are not as extensive as with the Group Policy Editor which has over 1,700 settings according to MS. I only say this because my previous experience with group policy tools, which had extensive components, was with server products and these were not included with workstation products or resource kits. It was possible to install the policy editors on individual workstations, but don't know if this is true for Vista. In any case, it was possible to do anything manually that the tool could do if you were proficient with editing the registry. I don't know if anything in the registry would have changed to make this type of problem. This does not appear to be the problem at this point since the ImgBurn software works properly.

I sincerely appreciate your help. I can at least do my work that requires DVD authoring. It would be great to be able to correct the problem with the MS and ULead programs though.

cc.
CERTIFIED EXPERT
Most Valuable Expert 2015

Commented:
Make sure your burning software is current, look for vista versions or updates. I usually use nero, but for both versions 7 and 8 I had to run the most current updates to get them to work properly with vista.
Top Expert 2007

Commented:
rindi's comments are well taken - when I switched to Vista I wound up abandoning Nero due to 'update hell.'

Running Vista sometimes makes me feel like a one-armed paperhanger and, now that I think of it, there were some very strange write problems with my drives while Nero was still on-board.  I would guess they are fixed by now but I'm happy with the tools I have.  Just to soapbox a bit, it seems that success can result in a nice utility becoming overloaded with features (i.e., Norton and, in my experience, Nero), leaving users who want lightweight tools to move on to something else.  It's like starting out as an oviraptor and turning into a tyrannosaur.  But some people get tired of sucking eggs and want the red stuff.  Norton and Nero are still good products but the resource load seems to be higher than the return (just like Vista, yes?).

Back to reality: I don't know if you have tried to repair Vista - it is possible that somewhere, somehow, a critical piece of the OS has gotten corrupted.  ImgBurn operates at a pretty low level in the system and bypasses many of the 'features' associated with Vista's built-in writing apps.  The fact that ImgBurn works leads me to think your problem is in Vista - permissions, registry settings (well, same thing) or specific files (a *.dll, a *.sys or a *.??? - where * and ? means I don't know what I'm talking about).

I don't have much of any experience with Vista's repair utilities (found on the installation media or, for OEM systems, on a 'recovery' or 'repair' partition) but you might want to look at them - you can get some information by searching Help for 'repair vista.'   Backup first!

Your uninstall/reinstall approach for Ulead is a good one.  You also might want to scan your system's installed software and prune anything that isn't necessary.  Also, I would consider any software that has built-in CD/DVD writing features a target for (temporary) elimination - Picasa, for example, or Kodak's EasyShare.

Good luck,
wb

Author

Commented:
I uninstalled Ulead and all other software that had the ability to write to a cd or dvd burner, all vestiges of leftover Nero products, plus a slew of other software. This did not fix the problem.

After the above, I reinstalled Vista. This did not fix the problem either. Non of the native Windows apps like Media Player or DVD Maker can see the write capabilities of the two DVD drives.

I then reinstalled Ulead Movie Factory 6.0, which is Vista compliant, and ImgBurn again. Only ImgBurn can see the recording capabilities of the drives. That's where matters stand at this point. A clean install is not a viable option. Unless there is some registry setting that can be tweaked I don't know what else can be done.
CC
Top Expert 2007
Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Author

Commented:
The problem was a setting in the BIOS. The motherboard is an Asus P5B as noted in the original question. Under the "Advanced" tab in the BIOS settings, submenu PCIPnP, "Plug and Play OS" must be set to "Yes" or Vista cannot set up the hardware attached to the system. Having this set to "No" had no effect under XP, but does under Vista.
CERTIFIED EXPERT
Distinguished Expert 2019

Commented:
that is good info !

Gain unlimited access to on-demand training courses with an Experts Exchange subscription.

Get Access
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Empower Your Career
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.