We help IT Professionals succeed at work.

Attempting to change ownership of a mail database results in an error with no lasting change.

suns0ft
suns0ft asked
on
1,184 Views
Last Modified: 2013-12-18
I've recently taken on a role as an admin for a company that has just transfered from Outlook to Lotus Notes. I've had no previous experience with notes before now so don't know a whole lot about the program and am learning as I go.

Two users needed access to a mailbox set aside for the receiving of certain information, so I've created a mail database for their use. Everything works just fine, they can both access the inbox and send/receive mail just fine.

The problem is that any mail sent from that inbox appears to have been sent from my name, not theirs. I reasoned this was because I had created the database, so I looked for a way to change this.

I changed the Owners under Administration in the Mail-In Database options from myself to the two users who would be using the database with no problems, but it made no difference, so I opened the database and changed the owner under 'More, Preferences' to one of the two users, figuring this way the emails would send from him. I got the following error message:

Object variable not set
On Module: CLICK
On Line: 30
On Method: CLICK

However, when going back into the preferences, the name had successfully changed, and upon sending a test email, it appeared to be sending from the correct user. Unfortunately the change did not follow through to the two users, and any emails they sent were still showing as from me. Upon restarting Notes, I found that the change did not carry through for me either.

I tried changing the owner through my own Notes client, through the Admin client, and through the Admin client running off the server, logged in as Administrator. They all gave the same error message and had the same result.

Not really aware of the complexity of this problem, so I'm happy to increase points if this is something difficult :).
Comment
Watch Question

First check the mail template version and the notes client version. If I am not wrong, the mail template is of higher version and the Notes client is of lower version.

You can try accessing the mail database from web and try sending mails. It should work.
If the issue is with versions, try to downgrade the mail template version by doing replace design and selecting the correct version template.
Hope it helps.
If it is not of version problems, then try to refrsh/replace the design and compact the db. Also, what try to give manager access to the users.

Author

Commented:
Well first off I appologise for not including the basic stuff. We're running Notes 8.0, and I've just checked the mail template, which is also 8.0.

I tried to refresh/replace the design but had no luck. Same with compacting the DB.

It also makes no difference at all when I give the users manager access. I've also tried giving ownership to another admin, exact same error.
If you access from Web, it should work.

Also, try to create a new user account and check.

Author

Commented:
Unfortunately we need access from the Lotus Notes Client, not the web (which we do not have availible at the moment for various reasons).

I've tried with numerous users of varying access levels, they all give the same error.
Then it could be the installation problem.
Let's wait for other experts to give there inputs/suggestions.
Sjef BosmanGroupware Consultant
CERTIFIED EXPERT

Commented:
Did you check the owner of the database, as mentioned in the Preferences? Click on Tools/Preferences, "This database belongs to..."

Author

Commented:
sjef_bosman;

I've tried assigning to database to myself, the users who would access it, the administrator, random test users etc etc.

Doesn't seem to make any difference.

Commented:
You should assign the mail-in record itself as owner of the mail file. Open the mail file, then click TOOLS on the action bar, PREFERENCES. Click the button to select a new owner, and choose the mail-in record.

Now, messages sent from this mailbox will appear to come from the name assigned to the mail-in record.

Author

Commented:
qwaletee;

I tried this, but got the error "The owners name must be entered in hierarchical format, because the current users ID is hierarchical (current ID is administrator)."

I'm thinking this is because Share Trades is only a mail-in database, not a user. Though any attempt to change the databases ownership to a user has brought forth the error in my original post.
Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION
CERTIFIED EXPERT

Commented:
Closed, 150 points refunded.
modus_operandi
EE Moderator

Gain unlimited access to on-demand training courses with an Experts Exchange subscription.

Get Access
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Empower Your Career
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.