We help IT Professionals succeed at work.

Exchange SP1 fails with Error Code 1635

jasgot
jasgot asked
on
2,732 Views
Last Modified: 2012-05-05
SP1 Upgrade makes it all the way to Hub Transport Role before failing with this error:
Summary: 6 item(s). 0 succeeded, 1 failed.
Elapsed time: 00:01:56
Hub Transport Role
Failed
Error:
Unable to remove product with code c3f10d8c-bd70-4516-b2b4-bf6901980741. This patch package could not be opened.  Verify that the patch package exists and that you can access it, or contact the application vendor to verify that this is a valid Windows Installer patch package. Error code is 1635.

This patch package could not be opened.  Verify that the patch package exists and that you can access it, or contact the application vendor to verify that this is a valid Windows Installer patch package
Elapsed Time: 00:01:56

I have tracked that Product code to: Microsoft Exchange 2007 Enterprise Anti-spam Filter Updates
The package DOES exist at C:\WINDOWS\Installer\563a44.msi

All of my AntiSpam within Exchange 2007 is disabled. The package it is complaining about appears to have been installed on 2007/06/11. I don;t know if that it Nov 6 or June 11.

My Anti Spam Updates are indeed updating through windows Updates, (even though I am not using them).
If I go to C:\WINDOWS\Installer\563a44.msi and dbl click it, I get the same error as above "This patch package could not be opened.  Verify that the patch package exists and that you can access it, or contact the application vendor to verify that this is a valid Windows Installer patch package"

I'm stuck.....

Thanks for any input you have.
Jason

BTW: This is a production server.
Comment
Watch Question

Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Author

Commented:
Wow, SP1 is only out for two weeks and there is SP2 already? Where can I get it?

Author

Commented:
WAIT!!!!! My mistake! I have Exchange 2007.  I bet you are thjinking of 2003!  Sorry!

I should have made that clear in the title.......

Commented:
Oops, sorry. I assumed 2003. :-)

Author

Commented:
I don't see an install cleanup utility. I can download the windows install cleanup, should I try that?

Author

Commented:
Just ran the Windows Install Cleanup utility, the Anti Spam is not listed.

Author

Commented:
I ran E:\Program Files\Microsoft\Exchange Server\Scripts\uninstall-AntispamAgents.ps1 from the MS Exchange mgt shell and SP1 still failed. At the same place.
CERTIFIED EXPERT
Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Author

Commented:
I re-installed the antispam agent, I ran the Reset-AntispamUpdates.ps1Still no-go.

Author

Commented:
LeeDerbyshire: I stoppped the service. ( I have with them all stopped) Still no go.

I want to note... that If I watch closely, it looks like it had just moved on to Common Transport when the error pops up.

Commented:
Hi jasqot

Did any of the above answer with your question.

Please close or ask for further clafification if required. Please do not leave questions unresolved.

Regards
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.