We help IT Professionals succeed at work.

Mapped Drives disconnecting after coming back from idle.  Reboot is the only solution.

fferrel
fferrel asked
on
1,183 Views
Last Modified: 2013-12-09
We have recently begun to experience an unusual issue with our IBM desktops.  A thorough search of the usual suspects (Google, TechNet etc) has not revealed a solution and, before we draw our service revolvers and "do the decent thing", I thought I would ask the brain trust.

Symptom:

When a user logs-in My Computer shows two network drives as disconnected (a homedrive, L:, and a Z: drive).  If the user has administrative rights the contents of the drives are those that would have been mapped during the creation of the base image for all our workstations.  The connections cannot be deleted because the system reports "path not found".  Since the L: drive is the drive mapped in our Users' profiles, their homedrive does not mount because the L: drive is already in use (albeit disconnected).

Fix:

Rebooting the system resolves the issue and a user can login and get their drive mappings without a problem.

Thoughts:
After the machines have sat at a login prompt for an as yet unknown period of time (at least over a weekend, possibly shorter - we are working on that) the problem resurfaces.  We have only been seeing this for about two weeks and it has gradually become more prevalent.  The images have been in use all year.

Current thoughts are that either a Windows or Symantec update might be the culprit.  Since W2K3 closes network connections after inactivity to conserve server resources, I was wondering if there is some kind of account that is avctive on the workstation even when no one is logged in and it is that account's drives that are being disconnected?

Has anyone else seen this or something similar?
Comment
Watch Question

CERTIFIED EXPERT
Top Expert 2013

Commented:
It is possible power management is enabled on the network adapter. To check go to device manager, expand the network adapters, right click on the appropriate network adapter and choose properties, click on the power management tab, un-check "allow the computer to turn off this device to save power"
Exists on most but not all network adapters.

Author

Commented:
No power management settings.  Just turn off monitor.
CERTIFIED EXPERT
Top Expert 2013

Commented:
Just for the record, that setting is part of the normal power management options in control panel.

Only other thought I have is the "autodisconnect" feature in Windows. This is a common problem with Win2K, though it has been known to happen with XP:
http://support.microsoft.com/default.aspx?scid=kb;en-us;297684

Author

Commented:
Thanks.  Saw that one though, it's not our issue per se.  The drives that show up as disconnected when a user logs in are not their drives, but are drives that were mapped when the administrative user created the image used to clone the workstations last summer.  Only just started happening (last two or three weeks).  I have searched the registry, there is nothing mapped anywhere.  It's almost as if the administrative user was logged in and the drives were disconnected as per the link you provided.  But of course they were not, the machine was at a login prompt.

I meant to say "No power management settings applied except turn off monitor"
CERTIFIED EXPERT
Top Expert 2013

Commented:
Perhaps try eliminating all mapped drives, and then re-create any new ones. If they were originally created with the persistent "switch" they should come back, but odd not until now. At a command line:
net  use  /persistent:no
net  use  *  /delete
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Author

Commented:
Thank you for all the replies,  We are convinced it is a SAV/MS issue.
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.