We help IT Professionals succeed at work.

Can't change root password at run level one

holinux
holinux asked
on
1,815 Views
Last Modified: 2013-12-16
A Server I support crashed due to system disk space being filled up. I cleared the space, then ran chkdsk to fix the errors on the filesystem. All came up OK, but now X does not start, and I can't log in as root. From the console I type in root and it just goes back to the login prompt without asking for the password.

When I boot into single user mode and try to change the password, I get the error "authentication token manipulation error" and can't change the password.

I searched the internet and tried a few things suggested but to no avail. I want to try an upgrade thinking that will fix the problem, but can't find the drivers for the SATA Controller on the motherboard.

Help!!! :-(
Comment
Watch Question

Commented:
What are the permissions of /usr/bin/passwd file and who are the owner and group for the same?
SaM
Artysystem administrator
Top Expert 2007

Commented:
how exactly do you try to change password?
do you have some external authentication server, like Kerberos?
CERTIFIED EXPERT
Top Expert 2007

Commented:
Hi,

try mount -a

It could be that root file system is  mounted read only in single user mode.
Top Expert 2005
Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION
evilrixSenior Software Engineer (Avast)
CERTIFIED EXPERT

Commented:
Have you tried using 'su -' or sudo (if you've set it up and configured it) to assume root identity when logged in as a normal user?

Also, you can normally reset the root password by booting from your distro's recovery CD.

Commented:
Did you tried booting in RESCUE MODE?
evilrixSenior Software Engineer (Avast)
CERTIFIED EXPERT

Commented:
Didn't I suggest that 3 days ago?

Author

Commented:
I found out what the problem was. Booted into single user mode and did what ravenpl suggested in doing the strace on the root passwd. A whole bunch of gibberish was outputed to the screen, but what caught my attention was an error saying /var/lib/security/pam_deny.so no such directory or file does not exist. So I went to the directory /var/lib/security to confirm that the files did exist and indeed they did. Then I went to the /etc/pam.d/ directory and had a look at /etc/pam.d/passwd. That was OK. Then I decided to look at the file /etc/pam.d/system-auth and lo and behold the file was empty. Yes I mean empty. Fortunately I had another Linux system running Fedora core 4. So I just copied on a piece of paper what was in /etc/pam.d/system-auth and typed it in the system-auth file in the CentOS 4 server. When I did passwd I was able to change the root password.  I rebooted into run level 5 and was able to log onto the gui session.

Thank God I stumbled onto it because it did have me stumped.

Author

Commented:
ravenpl pointed me in the right direction with the strace command which helped me "stumble" upon what was wrong. That is why I said the solution was paritally complete and partially accurate but easy to understand.

Gain unlimited access to on-demand training courses with an Experts Exchange subscription.

Get Access
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Empower Your Career
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.