how do i disable touchpad as startup option

we successfully disabled touchpad after a LOT of werk.. therefore i am asking an easy question.

i could maybe MAYBE figger this out.. umm.. but TeRReF deserves more points for preserverance

we got it werking right here:

http://www.experts-exchange.com/Hardware/Peripherals/Mice_Keyboards/Q_22978082.html

but this is going to require a little commmand every time.. umm.. are the scripts

.ICEauthority           .gconfd                 .history                .profile
.Xauthority             .gnome                  .k5login                .ssh
.config                 .gnome2                 .lesshst                .thumbnails
.cshrc                  .gnome2_private         .login                  .xsession-errors
.dmrc                   .gstreamer-0.10         .metacity               Desktop
.evolution              .gstreamer-0.8          .mozilla                riese_resume.doc
.gconf                  .gtkrc-1.2-gnome2  

so i am thinking i can put something in .gnome or .gconf to make this happen on startup..

i'm not sure.. i should google it.. but i want to give TeRReF more points for a NEW
(easy) question
kayveyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

TeRReFCommented:
You could make a startup script that runs every time you boot into FreeBSD.
Is your mouse daemon started at /etc/rc.conf?
0
TeRReFCommented:
Look for this line in /etc/rc.conf

moused_enable="YES"

if it is present, fine. If not add it.

Then under that line add this line:

moused_port="/dev/ums0"
0
TeRReFCommented:
You might also need to add this one:

moused_type="auto"
0
Cloud Class® Course: CompTIA Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

kayveyAuthor Commented:
kv_bsd# cat /etc/rc.conf

# -- sysinstall generated deltas -- # Sun Dec  2 03:03:56 2007
# -- sysinstall generated deltas -- # Sun Dec  2 10:47:16 2007
# Created: Sun Dec  2 10:47:16 2007
# Enable network daemons for user convenience.
# Please make all changes to this file, not to /etc/defaults/rc.conf.
# This file now contains just the overrides from /etc/defaults/rc.conf.
linux_enable="YES"
moused_enable="YES"
gdm_enable="YES"
sshd_enable="YES"
ntpdate_flags="ntp1.mainecoon.com"
ntpdate_enable="YES"
usbd_enable="YES"
ifconfig_bge0="inet 192.168.0.2 netmask 255.255.255.0"
defaultrouter="192.168.0.1"
hostname="kv_bsd"
tcp_extensions="YES"
kv_bsd#
0
kayveyAuthor Commented:
am i doing vulnerabilities by catting my config files on thah web?
0
kayveyAuthor Commented:
allrighty then..

kv_bsd# cat /etc/rc.conf

# -- sysinstall generated deltas -- # Sun Dec  2 03:03:56 2007
# -- sysinstall generated deltas -- # Sun Dec  2 10:47:16 2007
# Created: Sun Dec  2 10:47:16 2007
# Enable network daemons for user convenience.
# Please make all changes to this file, not to /etc/defaults/rc.conf.
# This file now contains just the overrides from /etc/defaults/rc.conf.
linux_enable="YES"
moused_enable="YES"
moused_port="/dev/ums0"
moused_type="auto"
gdm_enable="YES"
sshd_enable="YES"
ntpdate_flags="ntp1.mainecoon.com"
ntpdate_enable="YES"
usbd_enable="YES"
ifconfig_bge0="inet 192.168.0.2 netmask 255.255.255.0"
defaultrouter="192.168.0.1"
hostname="kv_bsd"
tcp_extensions="YES"
kv_bsd#


i'll have to reboot to test this.. don't feel like doing that at the moment.  remind me to give u points by
saying hi.
0
TeRReFCommented:
Hi,

Your rc.conf is pretty standard, so no vulnerabilities there.
0
kayveyAuthor Commented:
umm.. oops.  whatever we did is backwards.  now touchpad werks and USB mouse doesn't
0
TeRReFCommented:
Can you show me the output of
ps -A | grep moused
0
kayveyAuthor Commented:
kv_bsd# ps -A | grep moused
  529  ??  Is     0:00.02 /usr/sbin/moused -p /dev/ums0 -t auto -I /var/run/moused.ums0.pid
 1082  p0  R+     0:00.00 grep moused
kv_bsd#
0
kayveyAuthor Commented:
i don't suppose u could think aloud along with giving me commands  {:}
0
kayveyAuthor Commented:
heh.. maybe i get it .. gheist's complains i mean.  {:P
0
PCBONEZCommented:
If this is a laptop generally you can disable the touchpad in the BIOS.
0
TeRReFCommented:
Now that is weird. I specifically set the mouse port on USB and now your PS/2 mouse is working. What kind of laptop did you buy in gods name :-)

Can you try to comment out the three mouse related lines in /etc/rc.conf (just use a # in front of the lines)

Reboot and see if any of the mouse devices is working. If not, add this line in /etc/rc.conf:

usbmouse_enable="YES"

then type this:

echo "/usr/bin/killall moused ; /usr/sbin/moused -p /dev/ums0" > /usr/local/etc/rc.d/usbmouse

then type this:

chmod 555 /usr/local/etc/rc.d/usbmouse

now type this:

/usr/local/etc/rc.d/usbmouse

Is it working? If so, see if it works properly after a reboot...
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
TeRReFCommented:
change this line:
echo "/usr/bin/killall moused ; /usr/sbin/moused -p /dev/ums0" > /usr/local/etc/rc.d/usbmouse

to
echo "/usr/bin/killall moused ; sleep 1 ; /usr/sbin/moused -p /dev/ums0" > /usr/local/etc/rc.d/usbmouse
0
PCBONEZCommented:
The touchpads on some newer laptops are USB and not PS/2.
0
TeRReFCommented:
Ah okay didn't know that, thanks for the info. But in Kayvey's case it's not. See the related question...
0
kayveyAuthor Commented:
jeez.. oh i can push the power button with no mouse!  i might feel uncomfortable with tab control only! {:}
0
kayveyAuthor Commented:
with three mouse lines commented out of /etc/rc.conf i have only touchpad mouse
0
kayveyAuthor Commented:
kv_bsd# echo "/usr/bin/killall moused ; /usr/sbin/moused -p /dev/ums0" > /usr/local/etc/rc.d/usbmouse
kv_bsd# chmod 555 /usr/local/etc/rc.d/usbmouse
kv_bsd# /usr/local/etc/rc.d/usbmouse
moused: unable to open /dev/ums0: Device busy
kv_bsd# ps -A | grep mouse
  993  p0  R+     0:00.00 grep mouse
kv_bsd#
0
kayveyAuthor Commented:
kv_bsd# echo "/usr/bin/killall moused ; sleep 1 ; /usr/sbin/moused -p /dev/ums0" > /usr/local/etc/rc.d/usbmouse
kv_bsd# /usr/local/etc/rc.d/usbmouse
No matching processes were found
kv_bsd# ps -A | grep moused
 1000  ??  Ss     0:00.00 /usr/sbin/moused -p /dev/ums0
kv_bsd#
0
kayveyAuthor Commented:
still running touchpad
0
TeRReFCommented:
It worked in the previous question right? You only had USB mouse left?
0
kayveyAuthor Commented:
yes.. sheesh.. can you explain a little bit what we are doing?
0
kayveyAuthor Commented:
this is fascinating.. i should probably google
0
kayveyAuthor Commented:
i'm hoping gheist saw that so he can be happy
0
kayveyAuthor Commented:
kv_bsd# dmesg | grep mouse
psm0: model Generic PS/2 mouse, device ID 0
kv_bsd#
0
kayveyAuthor Commented:
what follows is cut from dmesg

psm0: <PS/2 Mouse> irq 12 on atkbdc0
psm0: [GIANT-LOCKED]
psm0: model Generic PS/2 mouse, device ID 0
0
kayveyAuthor Commented:
more dmesg.. that's the mousie i want right there

ums0: vendor 0x2222 Macally Optigo USB Mouse, rev 1.10/6.30, addr 2, iclass 3/1
ums0: 3 buttons and Z dir.

heh {:}  i tried dmesg | grep macally and dmesg | grep optigo but not properly capitized.
the mousie says those two brandnames on it.. heh  {:}  guess i have to post fotos now.
0
kayveyAuthor Commented:
i made a cute lil folder for my mousie with 3 pix innit

http://www.monkeyview.net/id/965/fsck/mousie/index.vhtml
0
kayveyAuthor Commented:
did we kill psm0 ?

shoot.  i booted on bill now.  time to go beddie bye.
0
kayveyAuthor Commented:
for some strange reason uncle bill is doing my mousie right.  i don't remember configuring that.  i think i am having dual boot paranoid.  i thnk i have a partition werm.
0
TeRReFCommented:
You need to do grep -i if you want to ignore case distinctions.

Try this, go to
System->Preferences->Sessions

THen the Startup Programs tab, the Add button and then add this one:
/usr/local/etc/rc.d/usbmouse

See if that works...
0
kayveyAuthor Commented:
umm.. are you thinking i am on vista?  not so!  i don't understand.. umm.. System?  where the *@# is that here?

o mwan..

it seems like i have showed that dmesg defines the mice in those two devs.. umm..

kv_bsd# ls /dev
acd0            cuad0           lpt0            ptyp1           ttyv8
acpi            cuad0.init      lpt0.ctl        random          ttyv9
ad0             cuad0.lock      mdctl           stderr          ttyva
ad0s1           devctl          mem             stdin           ttyvb
ad0s2           devstat         net             stdout          ttyvc
ad0s2a          fd              net1            sysmouse        ttyvd
ad0s2b          fido            net2            ttyd0           ttyve
ad0s2c          fw0             net3            ttyd0.init      ttyvf
ad0s2d          fw0.0           net4            ttyd0.lock      ums0
ad0s2e          fwmem0          network         ttyp0           urandom
ad0s2f          fwmem0.0        nfs4            ttyp1           usb
agpgart         geom.ctl        nfslock         ttyv0           usb0
apm             io              null            ttyv1           usb1
ata             kbd0            pccard0.cis     ttyv2           usb2
atkbd0          kbd1            pccard1.cis     ttyv3           usb3
bpsm0           kbdmux0         pci             ttyv4           xpt0
console         klog            ppi0            ttyv5           zero
consolectl      kmem            psm0            ttyv6
ctty            log             ptyp0           ttyv7
kv_bsd#

okay.. there is such a thing as /dev/psm0 and /dev/ums0  i want to make sure /dev/psm0 is
disconnected while /dev/ums0 is connected
0
kayveyAuthor Commented:
it's backwards.  you are telling me to kill the wrong mouse.  i fix it now
0
kayveyAuthor Commented:
kv_bsd# ps -A | grep mouse
  529  ??  Is     0:00.01 /usr/sbin/moused -p /dev/ums0 -t auto -I /var/run/mou
  959  p0  I+     0:00.01 vi /usr/local/etc/rc.d/usbmouse
kv_bsd# ps -A | grep mouse
  529  ??  Is     0:00.01 /usr/sbin/moused -p /dev/ums0 -t auto -I /var/run/moused.ums0.pid
  959  p0  I+     0:00.01 vi /usr/local/etc/rc.d/usbmouse
  963  p1  S+     0:00.00 grep mouse
kv_bsd# dmseg | grep ums
dmseg: Command not found.
kv_bsd# dmesg | grep ums
ums0: vendor 0x2222 Macally Optigo USB Mouse, rev 1.10/6.30, addr 2, iclass 3/1
ums0: 3 buttons and Z dir.
kv_bsd# moused -p /dev/ums0
moused: unable to open /dev/ums0: Device busy
kv_bsd# moused -p /dev/psm0
moused: unable to open /dev/psm0: Device busy
kv_bsd#

this is starting to remind me of windows something..
0
kayveyAuthor Commented:
kv_bsd# cat /etc/rc.d/moused
#!/bin/sh
#
# $NetBSD: moused,v 1.1 2001/10/29 23:25:01 augustss Exp $
# $FreeBSD: src/etc/rc.d/moused,v 1.9.2.1 2006/05/29 14:43:05 matteo Exp $
#

# PROVIDE: moused
# REQUIRE: DAEMON cleanvar
# KEYWORD: nojail

. /etc/rc.subr

name=moused
rcvar=`set_rcvar`
command="/usr/sbin/${name}"
start_cmd="moused_start"
_pidprefix="/var/run/moused"
pidfile="${_pidprefix}.pid"
_pidarg=
load_rc_config $name

# Set the pid file and variable name. The second argument, if it exists, is
# expected to be the mouse device.
#
if [ -n "$2" ]; then
        eval moused_$2_enable=\${moused_$2_enable-${moused_nondefault_enable}}
        rcvar=`set_rcvar moused_$2`
        pidfile="${_pidprefix}.$2.pid"
        _pidarg="-I $pidfile"
fi
moused_start()
{
        local ms myflags myport mytype

        # Set the mouse device and get any related variables. If
        # a moused device has been specified on the commandline, then
        # rc.conf(5) variables defined for that device take precedence
        # over the generic moused_* variables. The only exception is
        # the moused_port variable, which if not defined sets it to the
        # passed in device name.
        #
        ms=$1
        if [ -n "$ms" ]; then
                eval myflags=\${moused_${ms}_flags-$moused_flags}
                eval myport=\${moused_${ms}_port-/dev/$ms}
                eval mytype=\${moused_${ms}_type-$moused_type}
        else
                ms="default"
                myflags="$moused_flags"
                myport="$moused_port"
                mytype="$moused_type"
        fi

        echo -n "Starting ${ms} moused:"
        /usr/sbin/moused ${myflags} -p ${myport} -t ${mytype} ${_pidarg}

        _mousechar_arg=
        case ${mousechar_start} in
        [Nn][Oo] | '')
                ;;
        *)
                echo -n ' mousechar_start'
                _mousechar_arg="-M ${mousechar_start}"
                ;;
        esac

        for ttyv in /dev/ttyv* ; do
                vidcontrol < ${ttyv} ${_mousechar_arg} -m on
        done
        echo '.'
}

run_rc_command $*
kv_bsd#
0
TeRReFCommented:
No, no vista. Don't you have a System option in your taskbar? I have:
Little foot, Applications, Places and System. The latter is the one you need. If you don't have it, try typing this in a console:

gnome-session-properties &

Then follow the instructions from the previous comment...
0
kayveyAuthor Commented:
::sigh:: i figgerd it out.. did it.. didn't werk.  I*@##@ now we wasted a cycle
0
kayveyAuthor Commented:
i have

Applications   Places   System
0
kayveyAuthor Commented:
*&@## it this was supposed to be an easy question!!!!   {:(
0
kayveyAuthor Commented:
i can't believe this.  this isn't werking anymore

You have mail.
kv_bsd# ps -A | grep moused
  921  ??  Is     0:00.00 /usr/sbin/moused -p /dev/ums0
 2020  p1  S+     0:00.00 grep moused
kv_bsd# killall moused
kv_bsd# moused -p /dev/ums0
kv_bsd# killall moused
kv_bsd# moused -p /dev/psm0
moused: unable to open /dev/psm0: Device busy
kv_bsd# ps -A | grep moused
 2027  p1  RL+    0:00.00 grep moused
kv_bsd# killall moused
No matching processes were found
kv_bsd# moused -p /dev/ums0
kv_bsd#

0
TeRReFCommented:
Go back to the old situation, enable just the moused_enable="YES" in /etc/rc.conf (not the other two lines)

That should start both instances of moused, then the usbmouse script should work...
0
kayveyAuthor Commented:
can you explain yer understanding of what's going on?
0
TeRReFCommented:
So, what we want to establish is that the psm0 port is not used by moused, only the ums0 (USB) port.

Somehow, the system starts a  mouse driver on psm0 again as well. It could be X that does it, can you show me the relevant part from xorg.conf again (the mouse section)
0
kayveyAuthor Commented:
kv_bsd# cat /etc/rc.d/xorg.conf
cat: /etc/rc.d/xorg.conf: No such file or directory
kv_bsd# cat /etc/rc.conf

# -- sysinstall generated deltas -- # Sun Dec  2 03:03:56 2007
# -- sysinstall generated deltas -- # Sun Dec  2 10:47:16 2007
# Created: Sun Dec  2 10:47:16 2007
# Enable network daemons for user convenience.
# Please make all changes to this file, not to /etc/defaults/rc.conf.
# This file now contains just the overrides from /etc/defaults/rc.conf.
linux_enable="YES"
#moused_enable="YES"
#moused_port="/dev/ums0"
#moused_type="auto"
gdm_enable="YES"
sshd_enable="YES"
ntpdate_flags="ntp1.mainecoon.com"
ntpdate_enable="YES"
usbd_enable="YES"
ifconfig_bge0="inet 192.168.0.2 netmask 255.255.255.0"
defaultrouter="192.168.0.1"
hostname="kv_bsd"
tcp_extensions="YES"
kv_bsd#
0
kayveyAuthor Commented:
omg.  i don't understand.. but it werks now  {:P

You have mail.
kv_bsd# cat /etc/rc.conf

# -- sysinstall generated deltas -- # Sun Dec  2 03:03:56 2007
# -- sysinstall generated deltas -- # Sun Dec  2 10:47:16 2007
# Created: Sun Dec  2 10:47:16 2007
# Enable network daemons for user convenience.
# Please make all changes to this file, not to /etc/defaults/rc.conf.
# This file now contains just the overrides from /etc/defaults/rc.conf.
linux_enable="YES"
moused_enable="YES"
#moused_port="/dev/ums0"
#moused_type="auto"
gdm_enable="YES"
sshd_enable="YES"
ntpdate_flags="ntp1.mainecoon.com"
ntpdate_enable="YES"
usbd_enable="YES"
ifconfig_bge0="inet 192.168.0.2 netmask 255.255.255.0"
defaultrouter="192.168.0.1"
hostname="kv_bsd"
tcp_extensions="YES"
kv_bsd#
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Peripherals

From novice to tech pro — start learning today.