We help IT Professionals succeed at work.

Multiple problems with Windows 2007

Last Modified: 2013-11-17
A few weeks ago I bought a Vostro 1700 laptop and transferred all my files onto it. Most of it works fine , but when I go to Windows Outlook 2007 and click the send and receive button, I get the message 'you don't have appropriate permission to perform this function'. Serioulsy hampering my work as I need email in order to function. I have tried everything. I am the admministrator on the laptop
Watch Question


Hi Paddywolf in the meantime while we wait,
What is your OS Vista? Just the header states for this question>>Multiple problems with Windows 2007?? Do you mean Outlook 2007, is there a windows 2007?
Sounds like a restrictions issue.
Check the answers here at EE if they are relevent
Outlook XP Message: "You don't have appropriate permission to perform this operation"

External redirect contact with exchange 2003 fails with permission denied message.

 Borrowed extract: added incase it assists but its for xp home maybe not relevent.
solution to send/receive errors
Outlook's issue can be solved by making
separate profiles for every account  in Outlook.
If you have more than ONE email account
using the SAME incoming/outgoing mail server names Outlook will throw an error when you hit send and receive,
so the ONLY way to solve it is to make a separate profile for each account--in Windows XP Service Pack 2 Home you reach this area by going into the control panel and then hitting
"Mail" and the "Profiles" button.

Hope it helps you



It is Outlook 2007, and was installed on a brand new laptop I bought a few weeks ago. I simply copied my files across (or a friend did it - I am very illiterate on computers) and everything has gone smoothly. Word 07 took some getting used to, as did PowerPoint 07. Outlook 07 works perfectly with calendars etc, but as soon as I hit the send/receieve button it throws up the 'do not have appropraite permission' box.
I will try what you said - thanks .


Is this Vista? or Xp Paddy
Thank you


Top Expert 2007

Perhaps it's an add-on to Outlook causing this.

Try this,
Start->Run->Outlook /a
or even
Start->Run->Outlook /safe

If either of these work, you simply have an add-in that's not functioning properly...


HI sirbounty

Tried them both and nothing ran.

Top Expert 2007
This one is on us!
(Get your first solution completely free - no credit card required)


Will try - nothing has helped so far. Losing the will to live.

Your comment here>I go to Windows Outlook 2007 << is this windows MAil or Outlook in Office 2007?
Is this is using Outlook in Office 2007 have tried using Outlook Express?
Is it setup to use emails? Maybe there is a connection?
As Outlook is not actually default email client in Vista, Office is an Add on.
Check Outlook Express.
Is office 2007 regestered to you?
Any error codes?

Your comment>>
It is Outlook 2007, and was installed on a brand new laptop I bought a few weeks ago. I simply copied my files across (or a friend did it -<< or a friend did? Did he install Office?

This maybe relevent from Microsoft: Hotfix available in URL
The "Request For Permission to Use a Key" dialog box appears whenever you try to send an e-mail message in Outlook 2007 after you configure Outlook 2007 to use a digital signature in Windows Vista
Consider the following scenario. " On a computer that is running Windows Vista, you configure Microsoft Office Outlook 2007 to use a digital signature when you send e-mail.
" You import a digital ID into Outlook 2007.
In this scenario, the Request For Permission to Use a Key dialog box appears whenever you try to send an e-mail message. After you grant Outlook 2007 permission to use the digital ID, Outlook 2007 successfully sends the e-mail message.

Note When you try to send the e-mail message, you may also be prompted to enter the password of the digital ID. This situation depends on the security level that you specify for the digital ID.
After you apply the following hotfix, Windows Vista caches the digital ID that an application uses. Therefore, the Request For Permission to Use a Key dialog box still appears when you send the first e-mail message after you start Outlook 2007.

By default, Windows Vista can cache up to 20 digital IDs in an application. However, you can modify the registry to configure this number. For information about how to do this, see the "Registry information" section.

Paddy as this is new OS you do have warranty?
If all fails I would suggest you use your free warranty, it is so much simpler to have an expert sitting in front of a problem computer.

Hope this helps you Paddy.

Thank you for coming onboard sirbounty


It's Office 07, and I was told that Outlook would serve my purposes better than Outlook Express, which I always used to run. I'm seriously doubting that now.
I am the sole user and am set up as the administrator.
My warranty is on the hardware, not the software.
There are no error codes and it is set up to me.

Top Expert 2007

Presumably you're using a pop3 account?
Can you double check the credentials supplied there when you setup Outlook?

Tools/Options/Email Accounts (or Tools/Email Accounts).
Highlight your account and click Change (I believe - I'm out of town and don't have Outlook on this machine), then check the tab that has your logon information - perhaps reenter your email address and password.  Some providers accept 'just' your sign on 'name'. . . others mandate you use your entire email address: someone@somewhere.com.  You might try both and see what happens.

Good luck!


Hi everyone

I think we can close out this question. A mate of mine came and set up a whole new user account on my laptop and reloaded all my files and closed down the old user i.d. and it works. It turns out that the previous person had simply transferred all my Outlook files across to Outlook 07, moving them from an XP to Vista and they didn't translate well into Vista format, corrupting a whole lot of stuff. I am now up and running. Thanks for the great support guys.


Hello Paddy glad to hear you have your emails back,
I believe we both assisted you knowing that transferring files may have had an association.
 but especially SirBounty as he suggested >>>Aside from that, hmm...  I'd suggest maybe creating a 'new' administrator account and seeing if any different results are encountered.
Please consider accepting his answer

You can now delete/close your own questions
please use  the "Delete Question" link in the body of your question and follow the prompts
That will give the Mods in Community Support General all of the information
they need to properly handle your request to Close .

Best Wishes for the new year


Thanks sirbounty

Setting up a new user account solved the problem. Nice work.
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.


Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.