Getting an error when trying to connect to my wireless - G Linksys Print Server (WPS54G)

I just got a new Dell laptop running Vista Home (my first computer with Vista loaded) and I'm trying to connect to my Linksys wirless - G print server.  After I have installed the Linksys print server driver and ran the utility to configure it, I can get all the way to the screen where it detects the print server.  The utility detects the correct print server and I select it then press next to do a test print, I get an error message stating the following:  Set Printer Fail.  Set Printer Error Code: #87.

I then ran the PS Diagnostic utility and it tells me that it failed to connect to the printer.

Any ideas?

Thank you for any help you can give me.
Jeff CarnleyCFOAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

brent_caskeyCommented:
I think that the wizard you are using does not work with Vista...

You will need to configure the printer manually.

The Linksys device should work with the standard TCP/IP port - so after you install the drivers for the printer (maybe use the lpt port just for installation) complete the following to setup the port.

Right click your printer and go to Properties.
Click on the Ports Tab, click on Add Port.
Choose Create a new port and select "Standard TCP/IP Port", then click Next.
The Add Standard TCP/IP Printer Port Wizard will popup, then click Next.
Enter the IP address of the Print Server and click Next.
Now select Custom and click on Settings.
Select LPR for the protocol and type L1 or L2 (USB) for the Queue name.
Accept the changes and exit the wizard.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Jeff CarnleyCFOAuthor Commented:
Thanks Brent for you response.  I followed your instructions but I'm still getting the same error.  I'm not sure if I'm using L1 or L2 (so I tried them both) and still got the same response.  Under my printers screen (in the control panel), I see the printer and it tells me that its ready.  I just can't seem to connect to the Linksys still.  I'm confused about the LPR byte counting enabled too, so I checked it as well under the LPR settings (still no luck) then I unchecked it (still no luck.)  

Any other ideas?
Jeff CarnleyCFOAuthor Commented:
Brent, I started all over except this time I deleted the printer driver and started from scratch.  I followed your instructions again and it works now!  Thank you!
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
System Utilities

From novice to tech pro — start learning today.