Printer Spooler keeps failing

So I purchased an Epson RX595 printer yesterday and took it home to install it. Before installing, I deleted all other printers from my computer as I do not use them anymore. I followed the installation instructions step by step. When attempting to print a test page, it could not connect to the printer. Upon further investigation I found this to be because the Printer Spooler had turned off. A quick google search gave me instructions to simply turn it back on. Ah, if it were so easy. Further research pointed me to downloading and using cleanspl.exe to clean out my spooler. However, due to impatience I accidentally deleted all of the ports including TCP/IP,  BJ Language, and USB. I was able to restore the TCP/IP one but not the BJ language one. I then uninstalled the Printer Software and everything from my computer, restarted and installed it all over again. As it currently stands, when I try to turn the printer spooler on, it stays on for about 5 seconds and then turns off. Is my problem with the BJ language or USB port being gone? Also, not sure if it makes a difference but I'm connecting the printer through a 4-port USB hub and the other devices(external hard drive, mouse, etc) all work fine still. I've tried to give as much info as I can on my problem. Any suggestions on what could be the problem here?
cakanodeAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

b0lsc0ttIT ManagerCommented:
cakanode,

I assume you have already restarted the computer.  What operating system?

I suggest you check the system files for your computer.  Choose Run and type in ...

sfc /scannow

... and then press OK.  It seems like some files are gone and this is a pretty simple and effective way to fix that.

Let me know if you have any questions or need more information.

b0lsc0tt
0
scrathcyboyCommented:
First, you will have to remove the 4 port hub to test /eliminate it as a source of problem.  Second, SFC /scannow merely checks the system files for the service pack the CD came with, and it often requires a reinstall of the latest service pack you are used to, so I would not suggest it yet -- but the idea is to make sure there is no corruption in your system files.  You can get the same effect by reapplying SP2 or which ever one you are running with.  In needs to be higher than SP1, that does not support USB correctly.

Third you should try to repair the spooler service, see these for ideas and directions --
www.theeldergeek.com/print_spooler.htm
www.theeldergeek.com/forum/index.php?showtopic=23495&mode=linear
www.mcse.ms/archive/index.php/t-503732.html
help.lockergnome.com/windows/spooler-service-running-ftopict516465.html
(there are many others)

With a straight through USB connection to the MB (use a different port than the 4 port hub), then remove the USB devices in device manager, and uninstall the printer from Control panel, reboot, watch the USB devices reinstall.  Now try to get windows to AUTODETECT your printer without installing the software.

Just try to print anything to it with some generic driver from XP.  If something prints, you are making way.
If still no joy, then try SFC /scannow or reinstall SP2.

I have to warn you, however, that there are cases when the USB part of the windows registry becomes so corrupted from repeated problems, that the only way to fix this is with a clean install of XP.  I know we all cringe at that, but there have been many cases where that is the only real fix.  Follow the above suggestions first before you even consider that.
0
cakanodeAuthor Commented:
Thanks for the suggestions. I am running Windows XP with SP2. I tried running sfc /scannow and it still does not work. I could not figure out how to reinstall SP2. As far as repairing the spooler service, I couldn't make sense of those posts you linked for me. Do I simply need to copy the good files from I386 to somewhere else? Or do I need to do something else? I'm pretty computer literate and can understand most things but when it comes to registry and device manager stuff, I'm fairly new. Scrathcyboy, I'm not quite sure what you meant by "remove the USB devices in the device manager". I completely uninstalled all drivers and printer software, restarted and installed it all again. One thing I should mention is that the Epson instructions specifically say to use the software cd to install the printer and that you cannot install by using Plug&Play. Not sure if that is part of the problem or not. As it stands right now, after I re-installed the printer software and drivers fresh the last time, the printer spooler will not stay "started" for more than a few seconds which makes me think that it is solely a spooler problem that I'm dealing with and not something with the usb drivers or printer issues. Based on the new information I've given, do you guys have any other suggestions? Would the Epson help line be able to help me?(I'm assuming that they would not) Thanks so much for your help.
0
Cloud Class® Course: Microsoft Windows 7 Basic

This introductory course to Windows 7 environment will teach you about working with the Windows operating system. You will learn about basic functions including start menu; the desktop; managing files, folders, and libraries.

scrathcyboyCommented:
"I could not figure out how to reinstall SP2"

Download SP2 from MS website, and run it, you have to download the complete original SP2 file of about 200MB,  not run the update feature, that will not work.

"remove the USB devices in the device manage"  My computer, properties, hardware tab, device manager button, open up the USB devices at the bottom of the list, click on each one and press DEL, when all gone, reboot -- they will reinstall automatically.

"the printer spooler will not stay "started" for more than a few seconds "

try installing some other printer to the system, that is NOT USB -- like a parallel printer, If that works OK, it is NOT the spooler, but the USB connection.  If it fails too, try the SP2 install to fix the spooler.  

One can also fix the spooler in the registry, but it is complicated --
e.g. -- http://forums.techguy.org/windows-nt-2000-xp/451388-print-spooler-registry-fix.html

"Apparently in the registry at:
HKEY_LOCAL_MACHINE\SYSTEM\currentcontrolset\service\spooler
the key dependonservice when loading a Lexmark printer is set to lexbcse.exeRPCSS. Seems when you de-install the Lexmark stuff this key is NOT deleted and restored to its default value RPCSS. All I did is delete the :lexbcse.exe" part, rebooted and the spooler started again"

members.shaw.ca/bsanders/CleanPrinterDrivers.htm

"navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows NT x86\Drivers

        under this key, there will be the keys Version-2 and Version-3 (one or the other of these may be absent - not a problem)

            the sub-keys under these contain the printer driver configuration information

        delete all the sub-keys inside Version-2 and Version-3, but not these keys themselves

    The Microsoft Knowledgebase article at http://support.microsoft.com/default.aspx?scid=kb;en-us;312052 lists some other registry entries to delete, but this is not usually necessary."
0
scrathcyboyCommented:
this didn't show in the above post as a link, but it is one you should look at if you edit the registry --

members.shaw.ca/bsanders/CleanPrinterDrivers.htm
0
cakanodeAuthor Commented:
Ok, so after reinstalling SP2 and uninstalling and re-installing the drivers, I still had no luck. The spooler continued to turn off. I then realized that one of the printer drivers in my registry that I thought was a default windows one or something important turned out to be related to a wireless printer setup from my school's library. Uninstalling that printer utility and restarting seems to have fixed the printer spooler problem as it no longer is turning off. However, my printer is still not responding to jobs sent from my computer. It is an all-in-one printer so I tried copying and a nozzle check. Both work. Then, to check the USB cable I scanned a photo using the printer's scanning software. That worked fine so I'm left to assume that the cable is not the issue. Since I've seemed to have solved the spooler problem, should this question be reposted under a seperate topic? I have not called Epson's Tech support as I'm not sure they will be able to help me out. Any suggestions?
0
scrathcyboyCommented:
Yes you can close this question and repost with the new topic (give a link to this for background though) and you will get more response (i.e. more people input, which is what you want).  

Now that you have fixed the spooler by removing the wireless (that is just the kind of "temporary" network issue that causes these windows delays and problems) -- you still might be able to fix the underlying problem be again removing the Epson software, Then checking the registry for all traces of the wireless printer and the epson, and remove them, and then remove all printers from control panel, and then redo SP2.  Reboot of course, and of course, set a restore point before you do any registry changes.  Doing these things AFTER removing the offending remote printer actually should work.  Good that you found the USB was working OK.   This advice is prob. more than what Epson would say anyway !!   Good luck
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
cakanodeAuthor Commented:
Thanks for all your help with my problem. Even though it isn't fully resolved, you're advice and help definitely helped me get things more stabilized.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Printers and Scanners

From novice to tech pro — start learning today.