• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 10764
  • Last Modified:

Windows Vista does not recognize USB devices

This one's a doozy.......

abit IP35Pro motherboard  (http://www.uabit.com/index.php?option=com_content&task=view&id=110&Itemid=2)
Intel Core2 Duo CPU, 2.20GHz
Main Memory = 2GB RAM
Motherboard has 4 backplane USB Ports plus two additional front panel ones as well.
All MB drivers provided by abit installed and operational in XP.
Windows Vista Business upgraded from Clean Windows XP Pro.

Prior to the upgrade to Vista Business, Windows XP Pro worked flawlessly with ALL USB devices.  USB Flash Drives, USB Camera, USB anything.

Upgraded to Vista Business.

After upgrade completed, activated, validated, tested and DNA samples provided to M$, the following devices were operational on the USB ports:

HP PSC2355 All-In-One printer with integrated flash card reader (5 types, plus additional USB connection) - Printer operational 100%, however, system wants to install drivers for "Unknown Device" every time the system starts up.

USB Bluetooth keyboard and mouse (MX5000 Laser by Logitech) - 100% operational.

First time I plugged my Imation 1gb Flip-Flash drive into the front panel USB Port, I got a ton of errors, all around "Windows needs to install a driver for you hardware"

I googled, yahoo'd and asked Jeeves and did everything I could come up with from those and we're at the following point:

Whenever I insert an card into my multi-format card reader on the Printer, or when ever I insert a flash drive, I get a "Safely remove Hardware" icon in the systray and that shows a USB Mass Storage Device, however, no drives show up in My Computer at all.  I get no hits, no runs, no errors at all, just an additional "Unknown Device" added to my Device Manager for each different type of device I connect.

Anyone got any ideas on this?  I'm at the end of my rope and I'm about ready to flush M$ down the drain.
Steven Sheeley
Steven Sheeley
1 Solution
Right-click My Computer | Properties | Hardware (tab). Click the Device Manager button. On the Unknown device, right-click and select Properties |Details (tab) | Device Instance ID. It will be in a format like this:


Post the device instance ID for the Unknown Device so we can try to determine what it is.
Steven SheeleyConsulting SW Engineer - Lync/Skype4BusinessAuthor Commented:
There is no Device Instance ID.  There is, however, Device Instance Path a Hardware ID.

When the Imation 1GB Flash Drive is inserted Device Instance Path = STORAGE\VOLUME\1&19F7E59C&0&_??_USBSTOR#DISK&VEN_IMATION&PROD__USB_FLASH_DRIVE&REV_2.00#AA00700052075123&0#{53F56307-B6BF-11D0-94F2-00A0C91EFB8B}  and Hardware ID = STORAGE\Volume

When inserting the Geek Squad 512KB flash drive, Device Instance Path = STORAGE\VOLUME\1&19F7E59C&0&_??_USBSTOR#DISK&VEN_&PROD_GEEK_SQUAD&REV_0.3#SNDK225CE531EDE09007&0#{53F56307-B6BF-11D0-94F2-00A0C91EFB8B}
 and Hardware ID = STORAGE\Volume AND this searches for a drivers, then displays a windpw that says " Found New hardware - Unknown Device" as shown in the attached image file.

When inserting the AData 1GB Flash drive, Device Instance Path = STORAGE\VOLUME\1&19F7E59C&0&_??_USBSTOR#DISK&VEN_USB_2.0&PROD_FLASH_DISK&REV_0.00#B337D78291E25A&0#{53F56307-B6BF-11D0-94F2-00A0C91EFB8B}
 and Hardware ID = STORAGE\Volume

When connecting my Sony  RM-AX4000 Universal Remote whch can be programmed using Windows Software and a USB connection, the Device Instance Path = USB\VID_054C&PID_022F\6&123D227C&0&6
 and the Hardware IDs = USB\VID_054C&PID_022F&REV_0100 and USB\VID_054C&PID_022F

some things to try :
-in device manager, delete ALL usb entries, reboot and test
-update the chipset drivers, or reinstall them
Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Steven SheeleyConsulting SW Engineer - Lync/Skype4BusinessAuthor Commented:
I've already done the removal of ALL USB devices, rebooted, same error exists.

Latest drivers from the Intel site for the IP35 chipset have been installed.
Steven SheeleyConsulting SW Engineer - Lync/Skype4BusinessAuthor Commented:
Additional info:

Just installed my TomTom 720 Home software, everything went smooth with the installation of the software, however, the first time I connected the TomTom to the computer, it went through it's gyrations of locating suitable drivers.  The attached image is what it came up with.  Notice it correctly identified the USB Mass Storage Device and correctly identified the TomTom, however, when it finished, it was unable to locate the drivers, asked to scan the hard drive and when finished, displayed the dialog attached below.

It does this with every new USB device that is connected.  I suspect a problem with the Generic Volume driver as evidenced by the image attached to the first post, however, I can not find any mention of that driver as a download from Microsoft to fix the "error".

Any idea?
Steven SheeleyConsulting SW Engineer - Lync/Skype4BusinessAuthor Commented:
Additional info:

The MX500 Lazer Bluetooth Keyboard and Mouse function perfectly when plugged into any of the USB ports on the system.

This particular problem seems ot be with the Generic Volume Driver that's either missing or corrupted.

Any ideas?
Steven SheeleyConsulting SW Engineer - Lync/Skype4BusinessAuthor Commented:
Problem fixed.

Resolution:  Removing volume.inf and volume.PNF from C:\Windows\Inf and replacing with files in C:\Windows\System32\DriverRepository.  Also replaced volsnap.sys in C:\Windows\System32\Drivers from same directory and rebooted.  Suffered BSD on reboot.  Rebnooted, everything normal.  Inserted USB Flash Drive, unknown device shows up in Device Manager. Tell system to search C:\Windows\System32 with SubFolders checked and it is now able to find and install Generic Volume Driver.  Had to do this for every flash drive and USB Mass Storage device I own, Imation Drives, AData flash drive, Geek Squad Drive, Tom Tom 720 GPS Device, HP PSC2355 Printer Card Reader addon, etc, etc, etc.

But, in the long run I can now see and access all of my devices.

Wonderful thing, Windows Vista................................... NOT!
thanks for posting the info!
Could it be caused because you connected the tomtom before installing the software? Normally, you have to install the soft first, and only connect when asked for (for devices requiring soft and drivers)
ok !
Closed, 500 points refunded.
Community Support Moderator
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now