FAT file system in working USB mass storage device misrecognized by windows as RAW.

Recently, I have got a problem with my USB device (Kingston Data traveller 2GB). It is originally in FAT file system. But my system recognizes it to be a RAW file system. I checked the device with other systems and its working fine. I cornered the problem to be in my Windows which can recognize NTFS file system but not FAT file system. All other FAT FS drives shows as RAW format and no problem with NTFS.  I don't want to format my drive to NTFS, which I tried it successively. I have my phone, MP3 player, all other USB flash memory in FAT file system which would work in FAT FS only not in NTFS. I'd like to know if there are any ways to change things through REGISTRY so that windows recognizes FAT file system as FAT and not RAW
p_boopeshAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

PUNKYCommented:
Does the drive work on other system?
0
jstouteCommented:
Windows can recognize FAT16 (original FAT) and FAT32 (enabled since Win98).  If you formatted the USB drive using FAT16, XP might not like the cluster size that was put down on it by another OS (like a phone or camera).  Pull the data off of it onto another device, have XP format it as FAT32 with the standard cluster size (default) and put the data back from the camera / phone that you saved it on.  Then all the systems should be able to read it properly.

Make sure you are not setup to see the USB device as a 'Dynamic Disk' in 'Disk Management'.  This will try to enable the Veritas Volume Manager on a device that is not formatted properly for this usage.  Make sure it is set to Basic in the 'Disk Management'
0
p_boopeshAuthor Commented:
Thanks for your reply Mr Punky and Jstoute, The drive is working in other systems and the drive is already in fat32 fs. Not only my drive, all other drives with fat32/16 fs are recognized as RAW format. I could see the physical drive in Disk management, but couldn't format it as it is in RAW format. Also the USB device in Disk Management shows as 'Removable' and "online", but the "file system' is blank.
0
jstouteCommented:
When you say 'other systems' do you mean other XP Pro SP2 systems?  If you mean phones and cameras, they typically are not looking for a MBR, they just look for the File System as is.  If the device was formatted by one of these devices, then XP is not going to like it.

There are many threads throughout these tech sites that go through these scenarios, but here's what it basically boils down to.  XP is the most restrictive when it comes to FAT32:
1. put the usb device in the USB slot and reboot the machine
2. after you get back onto the desktop, go into Disk Management and locate the USB device
3. Create a new partition and format it as FAT32
4. properly eject it using the XP eject tool (taskbar)
5. verify that the 'other systems' can still see the FAT32 partition
Let us know what fails along these steps...
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
p_boopeshAuthor Commented:
The problem is that the xp system recognizes usb drive with fat system as RAW file system. This doesn't happen if the usb drive has NTFS file system and the drive works well. So, it means the problem lies in the OS only and not  in the drive as such. I have decided to reinstall the Windows XP and I expect the problem to be solved.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Storage

From novice to tech pro — start learning today.