Some E-mail messages not coming through

I recently got rid of an SBS and put in Exchange 2003 Standard.  Everything appears to be working normally except for two issues.

1) I have a linux server that e-mails me daily logs (logwatch).  The automatic messages are not coming through. I can track the logwatch e-mail message all the way from the Linux, through my Barracuda (which stores a copy of the e-mail that I can read), and into the Exchange server.  The Message Tracking Center in the Exchange server says that the message has been delivered to my mailbox store.  I never get the automatic messages.  The wierd thing is if I manually run logwatch on the Linux and force it to send me an e-mail right away, then I will get the message in my Outlook.  I have no rules or filtering set, and the Exchange spam filter thing is turned off.  What am I missing?

2)  For some reason, whenever I create a user, I have to manually change the e-mail address from user@domain.local to user@e-mail-domain.com, and then go into the list of e-mail addresses and add user@domain.local.  If I don't, outside e-mails won't come in.  I pretty much just followed the wizard when I setup the Exchange, so I'm hoping I just did some stupid noob mistake.  Any help?
LVL 1
judas2158Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

P0rterCommented:
You have problem with Recipient policy
Go to Exchange System Manager
First Organization->Recipients->Recipients policies->Default Policy->properties->E-mail adresses (policy) add @e-mail-domain.com. You can set it by default to force exchange to send from those addresses rather than @domain.local
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
smckellar83Commented:
Regarding 2)

You can set this up in the Recipient policy in Exchange and change the default. It will then prompt you as to whether you want to apply the new policy to all users. I would suggest clicking no, because if you have any special settings for some users/mailboxes these will be replaced by the username @ domain.com

You can also use %g and %s for wild cards eg. %g.%s@domain.com will make firstname.surname the default email address or %1g%s@domain.com will give John Smith an email jsmith@domain.com
exchange.png
0
judas2158Author Commented:
Thanks for the help, the solution worked quite well.  I think I'll ask part 1 as a seperate new question.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.