We help IT Professionals succeed at work.

autorun not working correctly

jsthursday
jsthursday asked
on
Medium Priority
836 Views
Last Modified: 2008-02-01
i am trying to install crysis and company of heroes...like most games, vista pops up saing use autorun or view folder. i click autorun, but nothing ever happens.  how do i fix this? it acts like it's loading it, then never does.  when is vista going to be normal like xp is? does vista even have a service pack 1 yet? thanks!
justin
Comment
Watch Question

CERTIFIED EXPERT

Commented:
If you view the folder and set run setup.exe you should be able to install it.  If you haven't disable UAC it will prompt you to comfirm you want to run with elevated permissions to which you should choose continue.

Author

Commented:
yes i know i can install it that way, but then it doesnt install right. like i get no start menu programs of desktop icons for it....i just like the old way. what is UAC. i just want the autorun to work.
Change or Reset AutoPlay
http://www.vistax64.com/tutorials/78021-autoplay-settings.html

Change how programs are Handled
http://windowshelp.microsoft.com/Windows/en-US/Help/72b76107-08c3-47a7-92f4-f2085403e26b1033.mspx

--
Its usedul to stop and restart a couple of Services.
From Start Search bar type services.msc
Locate Shell Hardware Detection - Stop and restart/ should be set to Automatic
Locate Microsoft Installer (or Windows Installer) - stop and restart.

Author

Commented:
hey thanks gregerson, that really helped a lot. i made all the autoplay settings back to default and i started windows installer. windows installer was not started, that could have been the reason, nonetheless thanks so much for the help! i love e-e

Explore More ContentExplore courses, solutions, and other research materials related to this topic.