Recieve Connector Problem After Installing E2k7 SP1

Tonight I installed SP1 for Exchange 2007. Prior to completing the installation I recieved an error message about the Recieve Connectors in my Server -> Hub Transport

_______

When the AuthMechanism parameter on a Receive connector is set to the value ExchangeServer, you must set the FQDN parameter on the Receive connector to one of the following values: the FQDN of the transport server "Xchng2k7.domain.org", the NetBIOS name of the transport server "XCHNG2K7", or $null.

_________

Our internal domain name is different then our external domain name. Internal = .org / External = .com
Our Recieve Connector's FQDN was ( prior to installing SP1 ) webmail.domain.com. This was needed due to it being the url for our SSL cert and the requirements for AutoDiscovery.

When I recieved the error, I looked around for a while for an answer, but when I couldn't find one, I decided to just go ahead and change the FQDN to Xchng2k7.domain.org and figured once SP1 completed successfully, I could then go back and change it to what it was, webmail.domain.com. Well, I was wrong! If I try to change it back, I get the same error message.

How can I resolve this?
fgarufijrAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

fgarufijrAuthor Commented:
Unfortunately, those links really dont help... I dont need help doing an upgrade from E2k3 to E2k7... I understand how Recieve Connectors work and their role... And I'm not doing a migration from E2000 to E2k7 :)

Due to the constraints of AutoDiscovery, SSL, and now how SP1 handles Recieve Connectors, I need to know if I'm going to run into problems with AutoDiscovery since its no longer using our external SSL FQDN.
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

fgarufijrAuthor Commented:
Does anyone else have any ideas on this???
NOLA504Commented:
Another guy with same issue here. Anybody with a solution?
fgarufijrAuthor Commented:
I was hoping by now someone would have some answers : )
systemnetCommented:
I am in the same boat! I can not believe there isnt more data on this available out there!!!

I will be watching this question closely!
fgarufijrAuthor Commented:
Well, its been over a month and no one has posted any solutions!

this is the third question in a row that hasn't gotten an acceptable answer. I wounder if EE is starting to loose some of its "expertise"
CrownappraisalCommented:
1. SP1 doesn't allow you to set the external FQDN name of the Default receive connector to something that is not the real server FQDN or NETBIOS name. This is because the receive connector has the "Exchange Servers" authentication method set. If you are running without an Edge server and using the Hub Transport as the external gateway, you need to set the external FQDN to your external host name. In the documentation, Microsoft advises not to change the FQDN of the Default Receive connector, because it will give problems when Hub Transport servers want to communicate with each other. Since my setup only has one Hub Transport server, I decided to leave the external FQDN set and turn off the "Exchange Servers" authentication option. This allowed me to install SP1 and mail flow is still working. FYI my mailbox server role is on the same server as the hub transport server.


2. If you have any UM language packs other than US English installed, the SP1 install will not run and tells you to uninstall the additional language packs. After doing this, SP1 will install, but you will not be able to reinstall the language packs again. The error message you get is: A Unified Messaging Language Pack is already installed for the culture 'nl-NL' (for example). I discovered that you need to delete the appropriate registry value for the language packs that you uninstalled from: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\v8.0\UnifiedMessagingRole\LanguagePacks. After deleting they key, the language pack would install again.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.