We help IT Professionals succeed at work.

Issue with getting smartphone email to work with OWA

I've finally got OWA working on the web.  My boss has now asked for me to get his dopod working with mail from our OWA.  I don't seem to be able to get it to access any mail.  

I have a feeling it may be that the url is https\\mail.mycompany.com/exchange.  I've been advised by our mobile provider that the phone may not like /exchange part of the url.  I've tried to find out how to change it so that mail is accessed from https:\\mail.mycompany.com but have not been successful in finding a resolution.  I'm not sure if I need to change settings on our exhange server, ISA server or the ISS server.  

PLEASE HELP!

Both the ISA server and exchange server are running windows server 2003 SE SP2.  The ISS server is running on the same server as the exchange server.  The exchange system is version 6.5.7638.1 and we are running ISA server 2006.  the phone is a dopod and is running windows mobile 6. Sorry if I haven't provided enough info, please let me know.
Comment
Watch Question

Commented:
Hello kiwi4000,

Are you trying to configure OWA or Active Sync on the mobile?

Mike

Commented:
Also,

if you get any errors when you try to connect -- what is the error?

Mike
If your Exchange server is acessible from the web, you should not worry about OWA on Windows Mobile devices. You should use Active Sync and the mail client on your devices. It's fairly simple to configure on both ends.

Author

Commented:
Hi Mihapi,

I'm trying to configure OWA, and there is no error message recieved.   I just can't see any emails when I go to outlook emails in the menu.

cptntrips, what would I need to configure for the active sync on the exchange server?  I can access OWA from the web.

thanks for your help,

Author

Commented:
Hi Guys,

Sorry just tried the hone againa nd I'm trying to use the active sync.  the error message says that the scurity certificate on the server is not valid.
You should be presented with the option to move forward anyway. You also need to check the permissions in AD to make sure you allowed to use Active Sync on that side.

Author

Commented:
Hi,

Active sync is enabled in AD for the user and the exchange settinga appear to be correct as per technet article http://www.microsoft.com/technet/solutionaccelerators/mobile/deploy/msfp_6.mspx
The device I'm trying to connect is a dopod C730 and it's running windows mobile 6.

the full error message from the comms manager is:

The security certificate on the server is not valid.  Contact your exchange server administrator or ISP to install a valid certificate on the server.

there doesn't appear to be an option to continue passed this.
Commented:
Hi,

you will have to configure your mobile device to trust the certificate. This can be done in few ways. My best recommendation is to buy certificate from commercial CA such as Thawte or VeriSign. Thawte charge about 450 USD for certificate for two years (or less). There are other commercial CAs that you could use.

Second option would depend on your certificate. Where did you get it? Did you issue it from your own CA server? If so, you could try to install your CA certificate chain on the device (every device that is used in your network). This would make your device trust certificate on the server.

Mike

Author

Commented:
Hi,

I've now installed the certificates on the device and I'm now getting a different error.  It is error code 85010014 and no other explaination as tot he reason it's failing.

Explore More ContentExplore courses, solutions, and other research materials related to this topic.