We help IT Professionals succeed at work.

Why postgres processes are not killed automatically?

Medium Priority
1,848 Views
Last Modified: 2013-12-12
in my development Linux server, i have postgres installed and am using the connection to my php web sites..,. after starting the postgress service exactly 5-6 hours.. the postgres server is hang .... it is not responding.. when i go to the server and seen the services of postgres's

like, (see log attached)...

why it has not been automatically killed / closed by server  ???

if I clear these , the postgres responding to me...

what should I do?

In fact this is occurring only these days...earlier all were working fine.,



[root@testwebdevserver root]# ps -ef | grep postgres
postgres  1235     1  0 04:31 ?        00:00:00 /usr/bin/postmaster -i
postgres  1318  1235  0 04:31 ?        00:00:00 postgres: stats buffer process   
postgres  1321  1318  0 04:31 ?        00:00:00 postgres: stats collector process   
postgres  1340  1235  0 04:31 ?        00:00:00 postgres: ami AMM5 127.0.0.1 idle
postgres  1448  1235  0 04:32 ?        00:00:00 postgres: ami AMM 127.0.0.1 idle
postgres  1462  1235  0 04:32 ?        00:00:00 postgres: ami AMMy15 127.0.0.1 idle
postgres  1463  1235  0 04:32 ?        00:00:00 postgres: ami AMMy15 127.0.0.1 idle
postgres  1476  1235  0 04:33 ?        00:00:00 postgres: ami AMMy15 127.0.0.1 idle
postgres  1610  1235  0 04:33 ?        00:00:00 postgres: ami AMMy15 127.0.0.1 idle
postgres  1640  1235  0 04:34 ?        00:00:00 postgres: ami AMMy15 127.0.0.1 idle
postgres  1671  1235  0 04:38 ?        00:00:00 postgres: ami AMMy15 127.0.0.1 idle
postgres  1674  1235  0 04:38 ?        00:00:00 postgres: sdp SDP 127.0.0.1 idle
postgres  1676  1235  0 04:38 ?        00:00:00 postgres: ami andhimay15 127.0.0.1 idle
postgres  1714  1235  0 04:41 ?        00:00:00 postgres: sdp SDP 127.0.0.1 idle
postgres  1715  1235  0 04:41 ?        00:00:00 postgres: sdp SDP 127.0.0.1 idle
postgres  1716  1235  0 04:41 ?        00:00:00 postgres: sdp SDP 127.0.0.1 idle
postgres  1717  1235  0 04:41 ?        00:00:00 postgres: sdp SDP 127.0.0.1 idle
postgres  1718  1235  0 04:41 ?        00:00:00 postgres: sdp SDP 127.0.0.1 idle
postgres  1720  1235  0 04:42 ?        00:00:00 postgres: postgres MDP 127.0.0.1 idle
postgres  1721  1235  0 04:42 ?        00:00:00 postgres: sdp SDP 127.0.0.1 idle
postgres  1722  1235  0 04:42 ?        00:00:00 postgres: sdp SDP 127.0.0.1 idle
postgres  1723  1235  0 04:42 ?        00:00:00 postgres: postgres MDP 127.0.0.1 idle
postgres  1724  1235  0 04:43 ?        00:00:00 postgres: sdp SDP 127.0.0.1 idle
postgres  1725  1235  0 04:43 ?        00:00:00 postgres: sdp SDP 127.0.0.1 idle
postgres  1726  1235  0 04:43 ?        00:00:00 postgres: sdp SDP 127.0.0.1 idle
postgres  1736  1235  0

Open in new window

Comment
Watch Question

Top Expert 2007
Commented:
if you use pg_pconnect the connection will be kept over different http-processes and this might flood you server. Don't use pg_pconnect or disable persistant connection for postgres via php.ini -setting
http://www.php.net/manual/en/ref.pgsql.php#ini.pgsql.allow-persistent

Explore More ContentExplore courses, solutions, and other research materials related to this topic.