Word has created a style 'char char char char char' and is corrupting the document

Hi,

I have a document that is based on normal.dot

Inside the document are a number of styles (all the normal ones such as 'normal', 'heading 1, 2, 3...' plus a few that are created such as 'note', 'command' etc...)

This was all working OK until the document was copied by someone and edited.  Now a style called 'char char char char char' has appeared and whatever I select in the document appears to have this style (if I look on the formatting toolbar).

The document looks fine, but all the styles are now wrong.

If I use the 'styles and formatting' sidebar then if I tell word to 'select all 198 instances' of 'char char char char char' it selects most of the document but leaves gaps in the middle of some paragraphs.  If I tell word to 'select all xxx instances' of another style it behaves as I'd expect, however if I click on the actual text in the document the formatting toolbar still insists it's 'char char char char char'.

If I delete the style then all returns to normal - until I save and re-open the document whereupon the problem reappears.

I am unable to delete the style from the organizer, only from the formatting sidebar.

Define Styles Based on your Formatting is not checked in my auto correct options.

I am using MS Word 2002 SP3 on a corporate network, so cannot apply patches/upgrade.  Also, any fix shouldn't really rely on macros as other users may need to do this who may not know/understand how to use macros.
LVL 1
jamesnoeAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Glenn_MooreCommented:
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
GrahamSkanRetiredCommented:
This is a known problem when using autoformat.

This question by Eric Fletcher has a full discussion and several links:
 
http://www.experts-exchange.com/Software/Office_Productivity/Office_Suites/MS_Office/Word/Q_20827522.html

It must have been effective because Eric is now the top expert on Word styles.
0
jamesnoeAuthor Commented:
Hi,

Thanks for those links, unfortunately, they don't address the precise problem I'm having, nor do any of the fixes work.

The style actually appears as "char char char char char char" not "body text, body text char char char..."

Also, if I try to apply a differnt style (e.g. normal) to an entire paragraph that does NOT fix the problem - the formatting is applied, but the style is still shown as char char char char char

Any ideas?
0
Introducing Cloud Class® training courses

Tech changes fast. You can learn faster. That’s why we’re bringing professional training courses to Experts Exchange. With a subscription, you can access all the Cloud Class® courses to expand your education, prep for certifications, and get top-notch instructions.

jamesnoeAuthor Commented:
OK - bit more inforamtion....

I can re-create the problem by starting with an OK document clicking Format -> AutoFormat -> AutoFormat Now, saving, closing and re-opening the document.

Also, anyone who edits the document who has the "Define Styles Based on your Formatting" checked in their auto correct options will cause the same issue.

As this is a corporate environment, I have no control over that setting, and this document must work regardless of what it's set to....

Any ideas?
0
GrahamSkanRetiredCommented:
This Microsoft article might help. It recommends a hotfix (825814) to stop it happening.

http://support.microsoft.com/kb/902064
0
jamesnoeAuthor Commented:
Hi,

I already have SP3 - so believe this is included, plus I can't install anything (corporate PC!)

Anyway, I think I've found a rather nasty but functioning workaround...

If anyone else stumbles upon this - the following appeared to work for me:

1) Open new document (blank document based on normal.dot)

2) Using the organiser copy all the styles (except char char char char...) to the new document

3) Copy and paste the content of the faulty document into the new document

4) Check that the format of something is 'char char char char'

5) Open the style organiser

6) Open up the formatting sidebar

7) Delete 'char char char char' - this should fail - but you apparently have to do this

8) All should now be well


Don't know why this works, but tried it on two documents and it does!

Thanks for all the help

James

0
GrahamSkanRetiredCommented:
The following information and snippet is from this link: http://homepage.swissonline.ch/cindymeister/MyFavTip.htm#CharStyl

Since the introduction of Word 2002, we've been plagued by Word creating new character styles that look just like an existing paragraph style, and have that style name plus the word Char (any number of times).

This problem occurs when you apply a paragraph style to a selection of characters, rather than to an entire paragraph (either by selecting the paragraph + paragraph mark or leaving the insertion point blinking in a paragraph). Word creates a new character style, and links it to the paragraph style.

If you try to delete the "Char" styles, the paragraph style to which it is linked will also be deleted. The only way around this is to use a macro to break the link. The following sample code creates a new style ("Style1"), links the "Char" style that bases on "Heading 2" to this new style, then deletes the new style.
Sub DeleteHeading2Char()
    Dim styl As Word.Style, doc As Word.Document
 
    Set doc = ActiveDocument
    Set styl = doc.Styles.Add(Name:="Style1")
    On Error Resume Next
    doc.Styles("Heading 2 Char").LinkStyle = styl
    styl.Delete
End Sub

Open in new window

0
jamesnoeAuthor Commented:
Thanks all for your comments - as I said, I can't install things or put macros into docs - but see my solution on here.

Have split the points for your assistance....
0
GrahamSkanRetiredCommented:
Thanks James
Your workaround looks interesting.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Word

From novice to tech pro — start learning today.