Can't install mouse

I have a computer using a Logitech Cordless Mouse (MX LASER). I reinstalled WINXP on the machine (repaired the current install) and since then I can not get WINXP to install a mouse. The cordless mouse or any other. When I try to plug in a Dell USB Optical mouse it thinks it is a Logitech device. I get the error: Cannot Install this Hardware. There was a problem installing this hardware: Logitech USB Optical Wheel Mouse. An error occurred during the installation of the device. Fatal error during installation.
I have tried removing all USB devices and installing it again and I get the same result.

Help is apprecatied! I'm banging my head here!
purplestar1970Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

kanalQkoTechnical Support EngineerCommented:
removing devices is not helpful, because drivers still remains in windir\system32\drivers

download driver from manufacturer a reinstall with this new one
0
purplestar1970Author Commented:
I downloaded Setpoint 4.0 from Logitech's website. I installed it and was not able to change the result.
I can't find a driver for the dell usb mouse.
0
kanalQkoTechnical Support EngineerCommented:
if you logitech mouse use logitech driver, if you have dell mouse, use dell driver, system is always asking you when reinstalling keep current driver (recommended) or replace the new driver, select 2nd choice to replace driver
0
Newly released Acronis True Image 2019

In announcing the release of the 15th Anniversary Edition of Acronis True Image 2019, the company revealed that its artificial intelligence-based anti-ransomware technology – stopped more than 200,000 ransomware attacks on 150,000 customers last year.

purplestar1970Author Commented:
As I stated in the original post, the problem is when I plug in the DELL mouse WINXP thinks it is a Logitech Mouse.
0
kadadi_vIT AdminCommented:
Is there logitech mouse application installed so check in Add/Remove programs adl also check in registry editor....and remove that logitech mouse enteries .Also download the windows installer cleanup utlity and remove the entry if it found in Add/remove programs.Also check any virus infected on your pc.



Regards,

Vijay Kadadi
0
Erik BjersPrincipal Systems AdministratorCommented:
Uninstal any and all logitech software and update your USB drivers (not from M$, but from the computer or motherboard manufacturer web site)
Then in safe mode reomve any mouse devices from device manage

After all that reboot in normal mode with the mouse you want connected and then reinstall logitech software.  Also Logitech has excelent support and will gladley help you through your issues.

If this still does not work you may have a bad USB controler and should try a PS2 mouse (cheep one should cost around 10 - 20)

eb
0
purplestar1970Author Commented:
Removing the installation of the logitech software and even editing the registry to remove all traces did not work.

What did work was:
Instead of choosing the default driver to install I had to tell it to install from a list instead of automatically and then to not search but choose from a list.
Then the Dell mouse appeared and I installed it easily.

Thanks for all that helped out!
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Peripherals

From novice to tech pro — start learning today.