Can't connect to windows 2003 R2 shares using wireless network

I have a single domain with a Windows 2003 R2 server hosting all the master roles and a Windows 2003 server acting as backup.  DNS servers run on both, with the R2 server being first in the DNS server list for all clients and both servers.  All clients are Windows XP Pro.

I have a wired network with a number of wireless access points, each having its own SID.

The problem arises when a laptop attempts to connect to a share on the R2 server (or even just to list the shares).  After a long delay I get a message "\\Server is not accessible.  You might not have permission to use this network resource...".   I get the same behaviour if I try to connect using the server IP address instead of its name (i.e. I type "\\10.141.13.17" in the address bar of Windows Explorer).

I can list and connect to shares on the other (non-R2) server.

I can list and connect to shares on both servers if I connect the laptop to the wired network.  This works even if I plug the ethernet cable into a spare socket on the wireless router.

Through the wireless connection I can ping both servers, and nslookup correctly identifies which IP address I am using (the wireless and wired interfaces on the laptop have been allocated different addresses by a DHCP server which runs on the non-R2 server).

I am connecting through a DLink DI-634M router with DHCP turned off and the uplink unused so it acts as an access point.  The wireless is set for Open Access with WEP encryption; no filtering or firewall rules are enabled.  When I connect with a cable to an unused port on this router I can access shares on both servers.  Connecting through an identical DI-634M with a different SID which is attached to a different point on the wired network I get the same problem.  The DI-634Ms have version 1.21 of their firmware, which is the latest I know of.

Connecting through a DLink DWL-2100AP access point with a different SID I can access shares on both servers!

I have also tried using a different make of laptop with different wireless hardware and software, but still the same symptoms.  One was a Packard Bell with Dlink DWL-G650M card in its PCIMIA slot, the other an Acer with Intel Pro 3495 built-in wireless.

Both servers are connected to the same switch, which then connects to a further switch from which all wireless routers/APs hang.The symptoms are unchanged if I swap the cables from this switch to the servers, and if just swap one end of the cables (thus swapping ports).

I have completely run out of ideas!

There must be some difference between the servers, but there must also be some difference between the methods of connection.  What are they?  I'm tempted just to replace the routers but that would still leave some difference between the servers which could come back to haunt me.
atfis52Asked:
Who is Participating?
 
lamaslanyConnect With a Mentor Commented:
http://support.dlink.com/products/view.asp?productid=DI%2D634M

This lists the latest firmware as 2.0.1.
0
 
atfis52Author Commented:
Thanks for the suggestion.  The site you give has a health warning saying the firmware should be loaded on North American devices only.  The UK site says the latest firmware is 1.21, but I will check with them whether I can use the later firmware.

Unfortunately, I can't get my hands on the equipment again until Monday a.m.  In the meantime, I'm still stumped as to how the wireless router, whatever firmware it has, knows to work with one server but not with the other.
0
 
lamaslanyCommented:
Sorry - forgot the regional differences!
0
 
atfis52Author Commented:
I've still had no information from DLink on this, but I've been reading a lot about 802.11 networks and I'm beginning to realise how much needs to go on under the bonnet, especially when you have overlapping BSSs.  It may be that the DI-634M, which is aimed mainly at the consumer market, fails to implement some part of the standard.  That still leaves me wondering why it works with one server but not with another, so further suggestions will certainly be appreciated.
0
 
atfis52Author Commented:
I'm closing this question and giving you the points because you were the only person who engaged at all.  On the other hand, it really wouldn't be fair to give a high grade since your proposed solution wasn't actually implementable in the UK (and I still don't know if it would have made any difference elsewhere).
0
All Courses

From novice to tech pro — start learning today.