We help IT Professionals succeed at work.

Send to Email doesn't send to default client

Tsdjws
Tsdjws asked
on
Medium Priority
2,339 Views
Last Modified: 2013-11-29
When I right-click on a file and pick Send To --> Mail Recipient, Windows attempts to send using Outlook Express instead of Outlook. It starts by noting the Outlook Express is not my default mail client, and asks if I want to make it so. In Internet Options, Outlook 2007 is selected as my default client. I want to change this selection so that Outlook is chosen as the destination.

I am using Windows x64 SP2 on a Dell 470 workstation with IE7 and Outlook 2007.
Comment
Watch Question

CERTIFIED EXPERT
Top Expert 2008

Commented:
Hello Tsdjws,

Make sure you have done the following to make Outlook your default mail client
http://email.about.com/cs/outlooktips/qt/et100701.htm

You can use this registry edit to make Outlook your default mail client
http://www.windowsitpro.com/Article/ArticleID/13694/13694.html

Hope this helps!
war1

Author

Commented:
This didn't help. I went around, and found that Send To Email doesn't work on any of our x64 machines.

Actually, at first, doing this would try to configure Outlook Express even though that was not chosen as the default mail client.
CERTIFIED EXPERT
Top Expert 2008

Commented:
Did you try the suggestions in both links?
CERTIFIED EXPERT
Most Valuable Expert 2011
Top Expert 2011

Commented:
Have you tried setting it at the Folder Options level? My computer>Tools>Folder Options>File Types>Mailto:, and select Advanced>Highlight Open, and select Edit, and specify the program you want to use there....

Author

Commented:
To war1: Yes, I tried both. After I did the regedit, I started to get the photo resize box if I tried to send a JPG, but then nothing.

To: Johnb6767: I don't have a "mailto" there. I have a .MAPIMAIL, which is set to open Outlook.

I put in a paid support call to MS, which they haven't returned.
CERTIFIED EXPERT
Most Valuable Expert 2011
Top Expert 2011

Commented:
Im sorry, it was (NONE) URL:MailTo Protocol, towards the top.....

Author

Commented:
That is set to Outlook:

"C:\PROGRA~2\MICROS~2\Office12\OUTLOOK.EXE" -c IPM.Note /m "%1"

But it is duplicated. Should it be?
CERTIFIED EXPERT
Most Valuable Expert 2011
Top Expert 2011

Commented:
What do you mean duplicated?
CERTIFIED EXPERT
Most Valuable Expert 2011
Top Expert 2011

Commented:
"C:\PROGRA~1\MICROS~2\OFFICE11\OUTLOOK.EXE" -c IPM.Note /m "%1"

is correct.... Use DDE is checked, Applicaiton simply says Outlook, and the topic is system....

Only need one Mailto entry in there though, if thats what you are referring to....

Author

Commented:
I mean there are two completely duplicate entries. I can't find any difference between them.

Author

Commented:
I think PROGRA~2 is correct. On the 64 bit Windows, there is Program Files and Program Files (x86). As a 32 bit application, Outlook is in the (x86) folder.

Author

Commented:
BTW, it don't get the option to delete either of the untries for URL:Mailto. I also confirmed that both duplicated entries are to the PROGRA~2 directory.
CERTIFIED EXPERT
Most Valuable Expert 2011
Top Expert 2011

Commented:
I am on a #@ Bit OS, so I cannot verify if that second one should be there or not....

Need to see if someone else can verify....
Hi.. I did call MS Support for same issue for a x64 Windows 2003 Terminal Server, with Outlook 2007. Here what they sent to me:
Issue: Windows Server 2003 Terminal Server boxes running 64bit version
When you right-click documents on the Desktop and select the Send To option to initialize email submissions.

Result:
The above actions would prompt users for the Outlook Express configuration Wizard instead.

Expected Result:
An Outlook 2003 mail message would open to compose since this is the default mail client installed.

Notes:
Looking at the Programs in the IE 32 bit properties you will see it is set correctly to the Outlook Mail client.
but
The Programs for the IE 64 bit properties will have remained at the Outlook Express setting.
Resolution:
You get the Outlook Express (simple mapi) client configuration coming up as it is a 64-bit application as is the Windows Explorer which makes the call.

I confirmed that this is a known scenario and has been bugged per Windows SE 140588. This is described as the inability of the Windows 64-bit Explorer not being able to engage the 32-bit Outlook client (even though it is configured as the Default Email Client) and thus defaults to calling the Outlook Express client instead.

At this time there is not a viable workaround or solution other than going back to
a 32-bit version of Windows Server 2003, which is not acceptable.
The only option currently is to check back with us or in the Blogs and Newsgroups and Knowledge Base to see if anything gets addressed with this.

Results

We are unable to provide an acceptable solution to you on this issue with the Windows Terminal Server 64-bit OS and the failure of the Send To functionality to call the 32-bit Outlook 2007 client to bring up a compose new email window and facilitate the sending of the file from the desktop via the Right-Click/Send To action. The failure is the inability to transition the call from the 64-bit Windows Explorer to a 32-bit application (Outlook). We are closing the case as Bugged.

Author

Commented:
The solution is: I'm screwed! ;) I'll wait on MS, and not waste anymore time on this. Thanks!

Commented:
hi does anyone know if there is a fix for this problem or a work around, because im having the exact same problem with a windows 2003 x64 terminal server and outlook 2003

Cheers

Author

Commented:
I'm sorry, I should have followed up with this. After consulting with MS, they acknowledge that this is a bug in the x64 software, and some day will publish a patch. There is no workaround that I am aware of, other than opening a new email and attaching the file directly.
Hi
Although an accepted solution has been found, you might like to be aware of the following 'workaround'

http://support.microsoft.com/kb/895561/en-us refers to "Some Windows Explorer extensions and some Control Panel items are not displayed on computers that are running an x64-based version of Windows"

An exerpt from the article:

Windows Explorer
To work around the Windows Explorer issue, you must use the 32-bit version of Windows Explorer. The 32-bit version of Windows Explorer is located in the %windir%\Syswow64 folder on the computer that is running an x64-based version of Windows.

To use the 32-bit version of Windows Explorer, follow these steps:

Click Start, click Run, type the following in the Open box, and then click OK:
Drive_Letter:\windows\syswow64\explorer.exe /separate
Note The placeholder Drive_Letter represents the drive where the x64-based version of Windows is installed.

We have done the above in our Windows Server 2003 R2 Citrix Presentation Server 4.5 environment, and can confirm it works.  We created a shortcut with the details above to enable users to run the 32 bit version of Windows Explorer - on demand.

Although this is not ideal, it does bring back some lost funcationality.

Hope this helps someone.

Cheers

Janson

Commented:
Thought I would give an update,  a work around is to create a shortcut for outlook and put it in your Documents and Settings/%username%/Send to folder.


examples on this page.

http://www.slipstick.com/outlook/create-a-custom-send-to-shortcut

Explore More ContentExplore courses, solutions, and other research materials related to this topic.