We help IT Professionals succeed at work.

the component services does not run

Hello

I have an application that use the component services to work, but i can not run this service because the icon that appears shows and red symbol later, if i want to enter in the COM + Application the system shows the next message " and error occurred while procesing the last operation. error code 8004e00f - +com was unable to talk the microsoft distributed transaction coordinator the event log may contain additional troubleshooting  information " later If i want to see the distributed transaction coordinator and select one of the options of transaction list and transaction statistics show me the next message
" can not open this folder because the connection to the MSDTC service on my computer failed make sure that : the computer is running, have permision to administrate the computer, and the computer name is correct. " 

I check the event log and appears the nex error

Event Type:      Error
Event Source:      MSDTC
Event Category:      SVC
Event ID:      4437
Date:            1/24/2008
Time:            4:55:17 PM
User:            N/A
Computer:      JADEMXPRNT
Description:
The account that the MS DTC service is running under is invalid.  This can happen if the service account information has been changed using the Services snap-in in Microsoft Management Console (MMC).  MS DTC service will continue to start. Please make sure that the MS DTC service account information is updated using the Component Services Explorer.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

What can i do in order to fix this problem ?

Regards
Comment
Watch Question

BRONZE EXPERT

Commented:
Reset the account that MSDTC runs under to local service account and restart the service - does the 4437 error come back?

Author

Commented:
thanks to write i checked the account  in other server that load the service and is  NT AUTHORITY\NetworkService, but in the  but in the server that has the problem has selected local system account,  i change to the option local system account and set the administrator account but still having the same problem, do you think that i need to type the account that set by default windows
BRONZE EXPERT
Commented:
Sorry... by deafult on a SP2 system it should be the Network service account.... Try that, if you havent already

Are there any other errors in the system / application logs on this server?

What applications is this server hosting?

Author

Commented:
thank is it  fixed, i set the account NetworkService and the componen service worked.
Regards

Explore More ContentExplore courses, solutions, and other research materials related to this topic.