[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1422
  • Last Modified:

W32time service suddenly stopped working and refuses to start on one of my DCs

This is happening on one DC.  It started after patching.  One interesting thing I have foune is that the registry entires that point to w32time.dll were pointing to c:\windows\system32\w32time.dll instead on c:\WINNT\system32\w32time.dll (this machine was upgraded from Windows 2000).  I changes the entries, but this did not correct the problem.  I have not rebooted since making these changes.  Any ideas?

C:\>net start w32time
The Windows Time service is starting.
The Windows Time service could not be started.

A system error has occurred.

System error 126 has occurred.

The specified module could not be found.

System log shows EventID 7023 with:
The Windows Time service terminated with the following error:
The specified module could not be found.


0
robertmahan
Asked:
robertmahan
1 Solution
 
ryansotoCommented:
I don tknow if your registry change will make a difference but you will need to reboot for the changes to take effect.  Then you will see if it worked or not.
0
 
sysadmin81Commented:
Also you may want to run regsvr32 c:\WINNT\system32\w32time.dll to register the time DLL
0
 
robertmahanAuthor Commented:
I have that scheduled for this weekend.  Unfortunatley, someone decided to add some services to this server that will cause outages if the server is down for maore than a couple of minutes.  I'll let oy uknow if that works.  I did do the regsvr32, I also replaced the dll and exe files from a server that is working.  I did see on another forum where someone did a dcpromo to demote and another to promote the DC and fixed the problem.  That would be a last resort here.  
Thanks for the input!
0
Easily manage email signatures in Office 365

Managing email signatures in Office 365 can be a challenging task if you don't have the right tool. CodeTwo Email Signatures for Office 365 will help you implement a unified email signature look, no matter what email client is used by users. Test it for free!

 
robertmahanAuthor Commented:
Looks like the registry hack corrected the problem.  Just needed a reboot.  Thanks everyone for your input.
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\w32time\TimeProviders\NtpClient
value = C:\WINNT\system32\w32time.dll

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\w32time\Parameters

value = C:\WINNT\system32\w32time.dll
0
 
robertmahanAuthor Commented:
The registry entries took care of the problem.
0
 
Computer101Commented:
Closed, 500 points refunded.
Computer101
EE Admin
0

Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now